IPD sale Volvo Parts

2001 XC70 Cranks but won't start

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" cars.
2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R
User avatar
abscate
MVS Moderator
Posts: 14786
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 1999 V70T5, 2005 V70
Location: NYC
Has thanked: 87 times
Been thanked: 317 times
Trinidad & Tobago

Re: 2001 XC70 Cranks but won't start

Post by abscate » Wed Sep 03, 2014 7:31 pm

altalake - this doesn't sound like a fuel problem to me. Im still thinking loose wires, grounds...that immob message also has be suspicious of that circuit.
1 SWMBO for 30 years
2 Volvos
3 VWs
4 Careers
5 cats/dogs/gears
6 Perfect Ladies in waiting
7 Drivers
8 Boats- with a big pointy metal thing on top

1999 V70 T5M 56 2005 V70 NA M56 VWs BMW

draser
Posts: 789
Joined: Thu Aug 18, 2011 10:49 am
Year and Model: 2005 S60 2.5T
Location: Detroit MI
Been thanked: 1 time

Re: 2001 XC70 Cranks but won't start

Post by draser » Wed Sep 03, 2014 9:13 pm

Immobilizer antenna around the ign sw, try tapping ign sw area when acting up.
2005 Volvo S60 2.5T, Zimmerman/Akebono brakes
2012 Honda Accord, EBC slotted rotors

altalake
Posts: 43
Joined: Mon Oct 14, 2013 10:24 pm
Year and Model: V70 T5 2001
Location: Canada
Canada

Re: 2001 XC70 Cranks but won't start

Post by altalake » Thu Sep 04, 2014 3:09 pm

Already replaced the immobilizer key antenna (with new) and that didn't help. You might be on to something re: the ignition switch. If (when) it happens again that will be the first thing to try. Most recent fix attempt involved cleaning the immobilizer antenna connector contacts (with DeOxit again) and cleaning the ignition switch connector contacts. No starting/stalling issues since then but it's been less than a week.

Buckone
Posts: 20
Joined: Wed Dec 04, 2013 1:54 pm
Year and Model: S60 2002
Location: United States

Re: 2001 XC70 Cranks but won't start

Post by Buckone » Thu Sep 04, 2014 6:55 pm

I'm just going to throw this out there, but my 2002 S60 T5 had intermittent start problems that eventually became a no start problem. Codes always pointed to camshaft/crankshaft position sensors or bad ECM. It ended up being a stripped camshaft pulley (bottom of engine/timing belt). I've got a post somewhere on this site about it.

altalake
Posts: 43
Joined: Mon Oct 14, 2013 10:24 pm
Year and Model: V70 T5 2001
Location: Canada
Canada

Re: 2001 XC70 Cranks but won't start

Post by altalake » Sat Jan 10, 2015 10:07 am

Crank no start fixed on the '01 V70. Situation had to get worse to find the problem - while it remained intermittent likely nobody would have been able to find it. The faulty part was the fuel level sensor (accessed under the left rear passenger's seat). Dealer cost to troubleshoot and repair $1K.

User avatar
abscate
MVS Moderator
Posts: 14786
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 1999 V70T5, 2005 V70
Location: NYC
Has thanked: 87 times
Been thanked: 317 times
Trinidad & Tobago

Re: 2001 XC70 Cranks but won't start

Post by abscate » Fri Sep 14, 2018 5:26 am

I stumbled on this thread again and now have more experience with P2 fuel delivery

Your dealer who reported you don’t have a pump electronic module PEM has an opportunity To improve.

P2 uses a CEM based relay to power a PEM which lives above the steel fuel tank or in the trunk with a plastic fuel pump ( confirm)

The PEM take some a control signal from the ECU to drive the fuel pump ,with theECU using the fuel pressure sensor on the rail as feedback.

The design of the PEM is such that Al corrosion Can short the circuit board internally in about ten years. You can open it and clean it preventative in about one hour

I have a good known working PEM for testing available here
1 SWMBO for 30 years
2 Volvos
3 VWs
4 Careers
5 cats/dogs/gears
6 Perfect Ladies in waiting
7 Drivers
8 Boats- with a big pointy metal thing on top

1999 V70 T5M 56 2005 V70 NA M56 VWs BMW

Post Reply

Who is online

Users browsing this forum: oragex and 40 guests