Login Register

'98 S70 - flash code 122, air temp sensor

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, including 850 R, 850 T-5R, 850 T-5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

Post Reply
User avatar
Stu70
Posts: 159
Joined: 12 Oct 2016, 10:27
Year and Model: 1998 S70 10v
Location: New Zealand
Has thanked: 28 times
Been thanked: 25 times

'98 S70 - flash code 122, air temp sensor

Post by Stu70 »

I'm hoping some body can help with this problem!
Fenix management 10v engine.
Air intake sensor
Returning 15 mpg city driving and smells like it's running rich.
I have replaced the sensor, traced wiring back to ecu all present and correct, 5v present at sensor.
Any thoughts on where I can look?
I have replaced the pcv system, and deleted the factory CNG ( one of 3 made, as press release cars) could this have an effect? I'm getting really frustrated, there is no CEL but I know it's there lurking...
1998 S70 10v BiFuel - Sold
2006 Sonic V70R - “this is going to be expensive “

User avatar
Stu70
Posts: 159
Joined: 12 Oct 2016, 10:27
Year and Model: 1998 S70 10v
Location: New Zealand
Has thanked: 28 times
Been thanked: 25 times

Post by Stu70 »

Any thoughts anyone ??
1998 S70 10v BiFuel - Sold
2006 Sonic V70R - “this is going to be expensive “

crlande
Posts: 345
Joined: 27 Jul 2013, 20:48
Year and Model: 240DL;850;S70
Location: Lehigh Valley, PA
Has thanked: 1 time
Been thanked: 29 times

Post by crlande »

My 98 S70 uses the OBDII. P0122 which is the throttle position sensor.

https://www.obd-codes.com/p0122

User avatar
misha
Posts: 4941
Joined: 07 Dec 2008, 16:09
Year and Model: '97 850 2.5 20v
Location: Serbia
Has thanked: 108 times
Been thanked: 246 times

Post by misha »

U.S market never got 10v cars,they are more present in U.K.(http://www.volvoforums.org.uk) and EU generally.

You can have few problems going on on 10v car:
-vacuum leak(almost always on any car)
-bad or slow o2 sensor
-map sensor or it's vacuum line
-ect sensor or thermostat
If i understand correctly,you have just a code for IAT sensor?
Does the car actually running rich...ie black smoke from the exhaust?

Since you have been in intake area recently for PCV replacement AND you deleted CNG system... i would say that you need to check intake manifold gasket and generally the whole area for some vacuum leak or some hoses disconnected.

Does the code appeared AFTER pcv system service or it was present before?

One more thing...
Factory CNG/TNG system is sequential system and their injectors are installed onto intake manifold,just after fuel injectors.
That said....what happened with the holes onto intake manifold where CNG injectors were?
If that is left unsealed,that's your problem.
Last edited by misha on 19 Mar 2017, 15:47, edited 2 times in total.
'97 850 2.5 20v / fully equipped / Motronic 4.4 from the factory / upgraded with S,V,C,XC70 instrument cluster / polar white wagon
'91 Citroen XM 2.0 SI /fully equipped/mandarine red metallic
History of Volvos in the family:
'71 144 S
'73 144 De Luxe
'78 244 DL
'78 244 DL
'79 244 GLE
'85 340 GLS

User avatar
misha
Posts: 4941
Joined: 07 Dec 2008, 16:09
Year and Model: '97 850 2.5 20v
Location: Serbia
Has thanked: 108 times
Been thanked: 246 times

Post by misha »

crlande wrote:My 98 S70 uses the OBDII. P0122 which is the throttle position sensor.

https://www.obd-codes.com/p0122
It's 10v car with Siemens Fenix management and it produce flash codes,just like Motronic 4.3.
'97 850 2.5 20v / fully equipped / Motronic 4.4 from the factory / upgraded with S,V,C,XC70 instrument cluster / polar white wagon
'91 Citroen XM 2.0 SI /fully equipped/mandarine red metallic
History of Volvos in the family:
'71 144 S
'73 144 De Luxe
'78 244 DL
'78 244 DL
'79 244 GLE
'85 340 GLS

User avatar
Stu70
Posts: 159
Joined: 12 Oct 2016, 10:27
Year and Model: 1998 S70 10v
Location: New Zealand
Has thanked: 28 times
Been thanked: 25 times

Post by Stu70 »

Thanks for the help there Misha !
I sealed the injector holes with bolts and thread lock/sealer - I even went as far as contouring the ends of them that protruded into the manifold.
I must build a smoker to sniff out any vacuum leaks, looking back in my workshop part/repair journal; the fault occurred before the pcv job and CNG delete. It just smells like it's running rich - thinking now it's not linked- might check the canister...
Ive come to a dead end on the UK site, so yours is the first reply to this problem on any site
There is not an over abundance of these P80 cars in New Zealand, so parts are a week away from the US or U.K. and expensive , it's difficult to try substitute parts as there is only two being parted out in the whole country, so any help is always welcome !
1998 S70 10v BiFuel - Sold
2006 Sonic V70R - “this is going to be expensive “

User avatar
misha
Posts: 4941
Joined: 07 Dec 2008, 16:09
Year and Model: '97 850 2.5 20v
Location: Serbia
Has thanked: 108 times
Been thanked: 246 times

Post by misha »

Ok,so you had a problem even before pcv system replacement and CNG delete?
Did the car smell rich before all of that or after repairs?
Did you drove the car periodically on petrol while CNG was in it?

I would say that petrol injectors would need professional cleaning because of driving the car on CNG.
Maybe they are a bit clogged and that's why you smell rich running condition.
What is the brand of IAT sensor you installed?
'97 850 2.5 20v / fully equipped / Motronic 4.4 from the factory / upgraded with S,V,C,XC70 instrument cluster / polar white wagon
'91 Citroen XM 2.0 SI /fully equipped/mandarine red metallic
History of Volvos in the family:
'71 144 S
'73 144 De Luxe
'78 244 DL
'78 244 DL
'79 244 GLE
'85 340 GLS

User avatar
Stu70
Posts: 159
Joined: 12 Oct 2016, 10:27
Year and Model: 1998 S70 10v
Location: New Zealand
Has thanked: 28 times
Been thanked: 25 times

Post by Stu70 »

Fuel usage has been high since before I undertook any work, I use a fuel tracker app , I don't have the trip computer.
CNG tank was removed before car was imported into the country, but its first 14 years in the U.K. it would have definitely been driven on both fuels.
Can't say exactly when it started smelling rich, but an injector clean sounds like a sensible job.
IAT was from dealer, so OEM. Being a 10v not many to be had from US or U.K. websites.
1998 S70 10v BiFuel - Sold
2006 Sonic V70R - “this is going to be expensive “

scot850
Posts: 8886
Joined: 05 Apr 2010, 14:46
Year and Model: 2000 V70 R
Location: Calgary, Alberta, Canada
Has thanked: 178 times
Been thanked: 589 times

Post by scot850 »

Are you sure the car is running rich and there is not a fuel leak near the back of the vehicle. Now that should through a code I believe but thought we may need to widen the possible cause issues.

Neil.
2000 V70 R - still being an endless PITA
2006 XC70
2003 Toyota 4Runner V8 Limited
2015 Kia Sportage EX-L - Sold
1993 850 GLT -Sold
1998 V70 XC - Sold
1997 Volvo 850 SE NA - Went to niece in California - Sold
2000 V70 SE NA - Sold

User avatar
misha
Posts: 4941
Joined: 07 Dec 2008, 16:09
Year and Model: '97 850 2.5 20v
Location: Serbia
Has thanked: 108 times
Been thanked: 246 times

Post by misha »

Neil....raw fuel smell is totally different from smell when car runs rich.
So.... that can't be comparable.
'97 850 2.5 20v / fully equipped / Motronic 4.4 from the factory / upgraded with S,V,C,XC70 instrument cluster / polar white wagon
'91 Citroen XM 2.0 SI /fully equipped/mandarine red metallic
History of Volvos in the family:
'71 144 S
'73 144 De Luxe
'78 244 DL
'78 244 DL
'79 244 GLE
'85 340 GLS

Post Reply
  • Similar Topics
    Replies
    Views
    Last post