Welcome to the world's #1 Volvo forum!

Volvo Fixes & Advice since 2001.

Login Register

xiaotec "850 OBD-II" Android app on Google Play for '96-'98 850/S70/etc

How to buy, install and use VIDA, VADIS, DiCE, VMWare and all the questions and answers that come with these tools.
Post Reply
User avatar
Esperado
Posts: 29
Joined: Fri Oct 18, 2019 10:48 pm
Year and Model: 1998 S70 T5 Auto
Location: Portugal
Has thanked: 5 times
Been thanked: 4 times

Re: xiaotec "850 OBD-II" Android app on Google Play for '96-'98 850/S70/etc

Post by Esperado »

xanthefin, As I'm travelling; no time to comment. Just this little word to send-you some love: I appreciate all your efforts.
About the price of you software, do you have some kind of donation form ? If I do not like too much to give money to Google, people like-you need support.

User avatar
xanthefin
Posts: 82
Joined: Sat May 04, 2019 12:22 pm
Year and Model: 1997 850
Location: Pluto
Has thanked: 7 times
Been thanked: 14 times

Post by xanthefin »

In app front page has button on top an i (info) button and there is mentioned (very bottom) the email of my one paypal in bottom section if people really wants to send donations. I appreciate all. Thank you!
As again i wrapped up and made some progress from what Richard made on pc. Without him or his work (and support towards my development when i contacted him years ago) i wouldn't have seen what Volvo can have possible and been stuck then ever since developing this as side project until i got it working so that i could publish it open with support (and kick) of Richard :)

Wish best for your traveling, stay healthy Esperado!

User avatar
xanthefin
Posts: 82
Joined: Sat May 04, 2019 12:22 pm
Year and Model: 1997 850
Location: Pluto
Has thanked: 7 times
Been thanked: 14 times

Post by xanthefin »

http://i.imgur.com/hkUhd3T.gifv

Finally some newer CAN based Volvos getting some stuff in app. Got tools working to learn these too now and friend donated V70 dashboard to learn about it to help mod his own then for him in return :mrgreen:

User avatar
xanthefin
Posts: 82
Joined: Sat May 04, 2019 12:22 pm
Year and Model: 1997 850
Location: Pluto
Has thanked: 7 times
Been thanked: 14 times

Post by xanthefin »

Oh that took long time.
Now did send update for annoying permission request poppin up more than requested on newer Androids.

Looking for feedback does on what years on newer Volvos (i tested on 2001 DIM (Dash) myself) does Gauge test now work on CAN Bus based Volvos. And yes i am actually too looking is ELM327 able to open how well CAN Bus from OBDII port enough fast as i heard it closes automatically after set of time. Sorry i don't have car myself to test it out. *Sad emoji looking at wallet*.


I tested already too reading fault codes and resetting them from CAN Bus DIM too but one step at a time... I want first to know the ELM327 working on simple thing before cluttering the app with the CAN Bus stuff more..

User avatar
Esperado
Posts: 29
Joined: Fri Oct 18, 2019 10:48 pm
Year and Model: 1998 S70 T5 Auto
Location: Portugal
Has thanked: 5 times
Been thanked: 4 times

Post by Esperado »

Great, xanthefin . If i can help to test out things, do not hesitate.
First tries ... so far ... so good.

User avatar
Fiodor
Posts: 135
Joined: Tue Oct 17, 2017 7:46 am
Year and Model: 1997 V70 2.0 T5 AWD
Location: Reims
Has thanked: 12 times
Been thanked: 7 times

Post by Fiodor »

Hello, my STFT and LTFT are reading 0 in your app, is this normal ?
1997 V70 T5 2.0 AWD with welded angle gear at 240k km
1990 740 Break (dead)

User avatar
xanthefin
Posts: 82
Joined: Sat May 04, 2019 12:22 pm
Year and Model: 1997 850
Location: Pluto
Has thanked: 7 times
Been thanked: 14 times

Post by xanthefin »

Fiodor wrote: Sat Feb 27, 2021 9:32 am Hello, my STFT and LTFT are reading 0 in your app, is this normal ?
I don't get notifications from this thread sorry so late notice.

I did quickly check on mine M4.4 how it behaves and behaves correctly on it.


0106 >> 01 06 01 06 48 6B 17 41 06 00 11
0107 >> 01 07 01 07 48 6B 17 41 07 00 12

Both were zero and app reported zero as should be.


Answer: It can be and should be as totally normal.



For the title says 98 and as i previously has thought but there is been couple cases by now that some 99 V70 (checked via VIN code) are mixed bags 98 style communication and newer CAN Bus style Vida. Example Immo, Combi, ECC, VGLA, Gearbox and SRS can be connected but if ME7 thats no go or if new ABS system thats no too.
There was some new command on these for reading and clearing fault codes for one module but i configured so that app detects if any module responds that "not supported" command for old style it will automatically change commands for this new style. Thanks to one who did provide feedback.

User avatar
xanthefin
Posts: 82
Joined: Sat May 04, 2019 12:22 pm
Year and Model: 1997 850
Location: Pluto
Has thanked: 7 times
Been thanked: 14 times

Post by xanthefin »

Image

I am sorry as I have no idea why i didn't just make app do live data logging like this from the start..

User avatar
Esperado
Posts: 29
Joined: Fri Oct 18, 2019 10:48 pm
Year and Model: 1998 S70 T5 Auto
Location: Portugal
Has thanked: 5 times
Been thanked: 4 times

Post by Esperado »

A problem with live data Lambda1 +Lambda2 in graph.
The app does not start always to send data and the screen never turn to horizontal (landscape) with the phone.

User avatar
xanthefin
Posts: 82
Joined: Sat May 04, 2019 12:22 pm
Year and Model: 1997 850
Location: Pluto
Has thanked: 7 times
Been thanked: 14 times

Post by xanthefin »

Esperado wrote: Sun Jul 25, 2021 5:52 am A problem with live data Lambda1 +Lambda2 in graph.
The app does not start always to send data and the screen never turn to horizontal (landscape) with the phone.
Good feedback to remind! I blocked originally turning to horizontal in the live data's graph page so far due work required make it work fluently both and on older (slower) devices. Will continue work on it surely.
Ordered finally newer Android phone after iPhone 6 not keeping up and Samsung Galaxy S5 becoming too old. Helps to see personally problems in androids unlike on slow emulator.

Some ECUs has been more prompt not getting connections always so will keep making them better if i catch some. There is been problems in past like MSA15.7 was kinda hard ever to connect but on my bench todays connect very well each time i try. Motronic i can try check i do remember once it did still put out NO DATA messages.

What ECUs you have had problems?


Lambdas on Motronic M4.4 for me is problematic triple check as the ECU itself for me won't let me test them properly yet. Requires either me retrofitting my car that ECU fully or i fake it to have engine running.

M4.4 if i remember correctly does support Lambda reading over standard OBDII too and those has been working fine on mine when i tested on totally other car brand.

Post Reply