1995 850 Instrument Panel Inoperative

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

Post Reply
DwainM11
Posts: 6
Joined: Wed Nov 22, 2017 7:18 pm
Year and Model: 1995 850
Location: Arkansas
Has thanked: 3 times

1995 850 Instrument Panel Inoperative

Post by DwainM11 »

Hi,

My speedometer, tachometer and gauges stopped working. Warning lights are OK. I have the VDO instrument cluster.

I tried to do the on board diagnostic test with the jumper in port #7 with the ignition key in the II position but I get no response from the test. I can't even get a 1-1-1 code. I do get the red LED to light up when I push the button and I was able to perform other tests with the jumper in port #1.

I removed the instrument cluster and made a visual inspection, all appears to be well. Solder joints look ok. There are a few that are suspect but nothing obvious.

I read that the ignition switch could be the culprit. Has anyone seen this situation with a bad ignition switch?

What's next? What else do I need to check?

Thanks!
Dwain

scot850
Posts: 6548
Joined: Mon Apr 05, 2010 2:46 pm
Year and Model: 2000 V70 R
Location: Calgary, Alberta, Canada
Has thanked: 22 times
Been thanked: 309 times

Post by scot850 »

Yes it can give you lots of weird warning lights and lack of activity, even make the engine run badly. Not particularly hard to replace and suggest trying a junkyard part. Even if it is also poorly, it might correct some of the issues to help identify if you are looking in the right area.

Neil.
2000 V70 R - still being an endless PITA
2006 XC70
2003 Toyota 4Runner V8 Limited
2015 Kia Sportage EX-L
1993 850 GLT -Sold
1998 V70 XC - Sold
1997 Volvo 850 SE NA - Went to niece in California - Sold
2000 V70 SE NA - New project and test bed - Sold

DwainM11
Posts: 6
Joined: Wed Nov 22, 2017 7:18 pm
Year and Model: 1995 850
Location: Arkansas
Has thanked: 3 times

Post by DwainM11 »

OK, thanks. It is the easiest thing to do at this point. I will report back after I have changed it.

DwainM11
Posts: 6
Joined: Wed Nov 22, 2017 7:18 pm
Year and Model: 1995 850
Location: Arkansas
Has thanked: 3 times

Post by DwainM11 »

Well,
That didn't work. Changed the ignition switch with a brand new one. Nothing changed.
The gauges still don't move. No tach, no fuel, no temperature.
I can not get a response from the On Board Diagnostic test with the test lead plugged into port 7.

What's left? Are there any other tests to perform?

Where can I get another instrument cluster?

scot850
Posts: 6548
Joined: Mon Apr 05, 2010 2:46 pm
Year and Model: 2000 V70 R
Location: Calgary, Alberta, Canada
Has thanked: 22 times
Been thanked: 309 times

Post by scot850 »

Again, a junkyard for the cluster. There are 2 versions (not sure for 95). One has the computer /LCD at the bottom and the other does not. If you replace like with like they are interchangeable. Not a hard job and it will be on here as a speedo cluster bulb change repair.

Neil.
2000 V70 R - still being an endless PITA
2006 XC70
2003 Toyota 4Runner V8 Limited
2015 Kia Sportage EX-L
1993 850 GLT -Sold
1998 V70 XC - Sold
1997 Volvo 850 SE NA - Went to niece in California - Sold
2000 V70 SE NA - New project and test bed - Sold

DwainM11
Posts: 6
Joined: Wed Nov 22, 2017 7:18 pm
Year and Model: 1995 850
Location: Arkansas
Has thanked: 3 times

Post by DwainM11 »

Thanks Neil,
Not much to choose from around here. I see a nice one on Ebay.
I'll report back when I have more info.

BR
Dwain

User avatar
BEJinFbk
Posts: 3799
Joined: Sat Jan 05, 2008 10:32 pm
Year and Model: '98 V70 R
Location: Fairbanks, Alaska
Has thanked: 30 times
Been thanked: 66 times

Post by BEJinFbk »

Have you checked your fuses?
'98 V70 R - Well Equipped for Life Up North... ;)

User avatar
erikv11  
Posts: 10209
Joined: Sat Jul 25, 2009 2:03 pm
Year and Model: 850, V70, S60R, XC70
Location: Iowa
Has thanked: 137 times
Been thanked: 373 times

Post by erikv11 »

Agreed with BEJ, check fuses too.

If it comes to it, PM me an offer if you want to pay less for the cluster, I have a couple VDO ones. :)
'95 854 T5-R, Motronic 4.4, 185k
'96 855 NA, 145k
'98 S70 NA, 220k (living out west)
'98 V70, T5 tune-injectors-turbo, LPT engine, 293k
'06 S60 R, 167k
'07 XC70, 170k
'99 Camry V6 :shock: 130k
gone: '96 NA 850 210k, '98 NA V70 182k

DwainM11
Posts: 6
Joined: Wed Nov 22, 2017 7:18 pm
Year and Model: 1995 850
Location: Arkansas
Has thanked: 3 times

Post by DwainM11 »

I'm back in action.
Replaced the instrument panel and everything started working. Gauges, odometers. I'm good.
Transferred my odometer to the replacement panel and changed all the bulbs too.

I have to put the dashboard cover back on after I glue the airbag cover back together.
It's time for a new project I guess. It would be nice if the remote entry worked....
There's also the shift lock not working...
Seat covers...
Sound system...

Hmmm... where's Santa?

Post Reply
  • Similar Topics
    Replies
    Views
    Last post