IPD sale Volvo Parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

2008 XC70 Blower

Help, Advice, Owners' Discussion and DIY Tutorials on the current (third) generation Volvo V70 wagon and XC70 crossover, and second generation S80.

This is a forum for owners or prospective owners of the third generation V70, second generation S80, and its siblings built on the EUCD platform.
TheEngler
Posts: 5
Joined: Sun Mar 18, 2018 2:30 pm
Year and Model: 2008 XC70
Location: NY - New York
Has thanked: 0
Been thanked: 0
United States of America
TheEngler

2008 XC70 Blower

Post by TheEngler » Sun Mar 18, 2018 3:03 pm

My 2008 XC70 blower died suddenly. I have a Delphi knockoff reader that I was able to read the Climate Control Unit with:

Compartment Temperature 23°C
Control Unit Power Supply 12.0V (I assume this is the Climate Control Unit)
Fan Requested 41.73% (reacts to knob)
Left Temperature Selector 21°C (reacts)
Right Temperature Selector 23°C (reacts)
Fan Control Voltage 0.00V

I suspect the issue is either the blower regulator (no longer simply a resistor) or the blower fuse, both of which are difficult to access.

The fuse (#11 in the engine compartment) is on the lower fuse level. It is not readily apparent how to remove the upper fuse tray to get at the lower portion.

The blower regulator is up against the firewall. I can touch it but trying to remove the connector or twist the regulator is nearlt impossible even with the gas pedal removed. The diagram is in the second to last post of this thread:

viewtopic.php?t=62130

Image:
download/file.php?id=29406


Can anyone offer some suggestions?



TheEngler
Posts: 5
Joined: Sun Mar 18, 2018 2:30 pm
Year and Model: 2008 XC70
Location: NY - New York
Has thanked: 0
Been thanked: 0
United States of America
TheEngler

Re: 2008 XC70 Blower

Post by TheEngler » Sun Mar 18, 2018 3:49 pm

I FINALLY was able to get the stupid connector off the regulator. It is a 4 pin connector with latches that have barbs on the end. I couldn't push both latches and pull the connector - I think I finally had success pressing one latch (top?) and backing one side out and then the other. According to the ALL Data schematic (in the attachment), it looks like:

RegulatorWiring.jpg
RegulatorWiring.jpg (81.19 KiB) Viewed 604 times

where 4/31 is the regulator and:

pin 1 GND
pin 2 PWM signal from Climate Control
pin 3 blower low side
pin 4 Fused 12 VDC (from Fuse 11)

I measured 12.17 V from pin 4 to pin 1 so fuse 11 is good. I would still like to know how to get at the lower level of the engine fuse compartment though. I jumpered from pin 3 to pin 1 for about 5 seconds and the blower ran. But the jumper got hot quick. So the immediate issue is the regulator is toast. The blower could also be drawing too much current but I won't know unless I replace it and smoke it.

So:

#1 Can anyone suggest how to turn the regulator and remove?

#2 Anyone ever get at the lower fuse level for future reference?

-Thanks-
Last edited by TheEngler on Sun Mar 18, 2018 3:54 pm, edited 1 time in total.



TheEngler
Posts: 5
Joined: Sun Mar 18, 2018 2:30 pm
Year and Model: 2008 XC70
Location: NY - New York
Has thanked: 0
Been thanked: 0
United States of America
TheEngler

Re: 2008 XC70 Blower

Post by TheEngler » Sun Mar 18, 2018 3:52 pm

Had to re-attach image...



User avatar
abscate
MVS Moderator
Posts: 16621
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 164 times
Been thanked: 482 times
Trinidad & Tobago
abscate

Re: 2008 XC70 Blower

Post by abscate » Tue Mar 20, 2018 8:11 am

You still don't know if your regulator 4/31is bad or if the CCM is not sending the fan signal to the regulator.

How thick was the wire you jumped term 3-1 with? If it was thin, it will get hot - fans will pull 4-8 amps which is a lot of current.

Where are you in NY? PM me and Ill see if we have someone nearby with a good ammeter who can measure that current for you.


1 SWMBO for 30 years
2 Volvos
3 VWs
4 Careers
5 cats/dogs/gears
6 Perfect Ladies in waiting
7 Drivers
8 Boats- with a big pointy metal thing on top

1999 V70 T5M 56 2005 V70 NA M56 VWs BMW

TheEngler
Posts: 5
Joined: Sun Mar 18, 2018 2:30 pm
Year and Model: 2008 XC70
Location: NY - New York
Has thanked: 0
Been thanked: 0
United States of America
TheEngler

Re: 2008 XC70 Blower

Post by TheEngler » Tue Mar 20, 2018 5:52 pm

abscate-
Thanks for the reply. No I did not check the voltage on the PWM pin to see if it varied with setting as I was rushing to get things cleaned up before dark. A DMM will average out the pulses from the CCM and show different DC levels for the different fan speed settings. I will check that voltage quickly before ordering the regulator.

As to the current, I was using a steel 'pick stick'. Steel does not conduct as well as copper. I just looked up the particulars and it is about 10x the resistance for carbon steel and >40x for stainless steel (which is what I suspect it is). The stick was about 1mm in diameter which equates to ~18 AWG wire. The fuse in the engine compartment for the blower is 40A which would equate to 8 AWG wire which has roughly 10 times the area and IS made of copper. My Fluke DMM is only good for 10 amps as it is a shunt ammeter. Thanks for the offer but I am halfway out on LI and can grab a clamp ammeter good to hundreds of amps from work. I was only commenting as to how QUICKLY it got HOT. Since the resistance is 100x to 400x (resistance x area) greater, it is apparent as to why.



User avatar
oragex
Posts: 4004
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 76 times
Been thanked: 139 times
Contact:
Canada
oragex

Re: 2008 XC70 Blower

Post by oragex » Tue Mar 20, 2018 6:16 pm

Try searching on Youtube, some russian guy had to replace his blower on XC70 P3


2003 2.4i S60 automatic 125k miles
DIY Volvo repairs videos https://www.youtube.com/playlist?list=P ... s0FSVSOT_c

TheEngler
Posts: 5
Joined: Sun Mar 18, 2018 2:30 pm
Year and Model: 2008 XC70
Location: NY - New York
Has thanked: 0
Been thanked: 0
United States of America
TheEngler

Re: 2008 XC70 Blower

Post by TheEngler » Tue Mar 20, 2018 6:45 pm

Yes, saw that one. Does not look like a fun job.



User avatar
oragex
Posts: 4004
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 76 times
Been thanked: 139 times
Contact:
Canada
oragex

Re: 2008 XC70 Blower

Post by oragex » Tue Mar 20, 2018 6:49 pm

Indeed. And after googling about it, seems quite common with low miles and recurrent


2003 2.4i S60 automatic 125k miles
DIY Volvo repairs videos https://www.youtube.com/playlist?list=P ... s0FSVSOT_c

Post Reply