IPD sale Volvo Parts

1999 S70 Cruise Control Surging, solved with new axle and ABS ring Topic is solved

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.
1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70
Post Reply
Reinie
Posts: 55
Joined: Tue Feb 17, 2009 12:40 pm
Year and Model: 1999 S70
Location: stillwater, mn

1999 S70 Cruise Control Surging, solved with new axle and ABS ring  Topic is solved

Post by Reinie » Tue Jun 12, 2018 9:42 pm

My 1999 S70 non-turbo, base, (240K miles) has an issue with the cruise control. It will set and hold speed, but it pumps the gas pedal really bad. I have a rebuilt Xemodex ETM with about 140K miles on it. When the original ETM failed, I had no cruise at all and dash lights on. Could the ETM be going bad again? I checked the vacuum line elbow on the end of fuel rail and it was good.



Ozark Lee
MVS Moderator
Posts: 14656
Joined: Thu Sep 07, 2006 8:24 am
Year and Model: Many Volvos
Location: USA Midwest
Been thanked: 18 times
United States of America

Re: 1999 S70 Cruise Control, Pumps the Gas Pedal

Post by Ozark Lee » Tue Jun 12, 2018 10:32 pm

On a '99 the gas pedal shouldn't move at all when the cruise is engaged. The pedal has no physical mechanical connection with the throttle body, it is totally fly by wire. The pedal itself has only wires from a position sensor and it typically stays all the way out since the signal is a one way flow from the pedal to the ETM. There is no return signal that would adjust the pedal position electronically.

Perhaps I am misreading the question.

...Lee


'94 850 N/A 5 speed
'96 Platinum Edition Turbo
'99 V70XC - Nautic Blue
Previous:
1999 V70XC - RIP - Wrecked Parts Car.
1998 S70 T5
1996 850 N/A
1989 740 GLT
1986 740 GLT
1972 142 Grand Luxe

Reinie
Posts: 55
Joined: Tue Feb 17, 2009 12:40 pm
Year and Model: 1999 S70
Location: stillwater, mn

Re: 1999 S70 Cruise Control, Pumps the Gas Pedal

Post by Reinie » Wed Jun 13, 2018 6:42 am

Your right, the pedal does not move, but the cruise constantly accelerates / decelerates back and forth to maintain speed. It’s super annoying.



Pater
Posts: 14
Joined: Wed Jun 06, 2018 11:49 am
Year and Model: S70 1999 2.5 20V
Location: Netherlands
Netherlands

Re: 1999 S70 Cruise Control, Pumps the Gas Pedal

Post by Pater » Wed Jun 13, 2018 8:20 am

Is this problem similar as in my topic?
Is this light surging or heavily (speed increase/decrease)

viewtopic.php?f=1&t=85562&p=474073



Reinie
Posts: 55
Joined: Tue Feb 17, 2009 12:40 pm
Year and Model: 1999 S70
Location: stillwater, mn

Re: 1999 S70 Cruise Control, Pumps the Gas Pedal

Post by Reinie » Wed Jun 13, 2018 8:34 am

Yes, I noticed your post. I have the same issue. Let me know if you solve it.



Reinie
Posts: 55
Joined: Tue Feb 17, 2009 12:40 pm
Year and Model: 1999 S70
Location: stillwater, mn

Re: 1999 S70 Cruise Control, Pumps the Gas Pedal

Post by Reinie » Sat Aug 04, 2018 2:08 pm

SOLVED: This was caused by a broken reluctor ring on the front axle. Parts were covered under warranty from previous repair (Oreilly Auto Parts). $130 labor to replace the axle. This also solved my issue with abs brake deployment on dry pavement.
90B3A758-03D0-4D91-8573-FC37A2C53B1B.jpeg



Post Reply

Who is online

Users browsing this forum: Chuck W, misha and 55 guests