IPD sale Volvo Parts

CEL and barometric pressure sensor error code

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.
1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70
Post Reply
User avatar
Saratoga Gal
Posts: 2
Joined: Sat Apr 09, 2016 7:36 pm
Year and Model: 1998 V70 GLT
Location: Saratoga Springs, NY
United States of America

CEL and barometric pressure sensor error code

Post by Saratoga Gal » Mon Jul 09, 2018 6:37 pm

Hello new to this forum,

I have a 1998 Volvo V70 wagon that has an annoying CEL light. My car has 198K miles and has been meticulously cared for. I have replaced this barometric pressure sensor before and the CEL has gone out. The CEL came on again after my son hit a very bad pot hole. So I bought another Bosch sensor thinking that it would solve the problem but the CEL will not go out. I read here in this forum that sometimes the wiring harness gets corroded or that the wiring insulation breaks down. My ODB meter shows an error code of P0107. Would a bad wiring harness in the vicinity of the barometric pressure sensor result in the same error code? If so does anyone know what part the wiring harness is and is it easy to replace? I am a DYI but I have limited car mechanics experience. Many thanks in advance for any and all of your help. I am on the verge of pulling my hair out! Please help before I go bald!!! :?

Tags:

User avatar
RickHaleParker
Posts: 1633
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 2 times
Been thanked: 165 times
United States of America

Re: CEL and barometric pressure sensor error code

Post by RickHaleParker » Mon Jul 09, 2018 11:29 pm

1997 S90, B6304S, AW30-42, Bosch Motronic 4.4
1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4
2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000.

User avatar
abscate
MVS Moderator
Posts: 14786
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 1999 V70T5, 2005 V70
Location: NYC
Has thanked: 87 times
Been thanked: 317 times
Trinidad & Tobago

Re: CEL and barometric pressure sensor error code

Post by abscate » Tue Jul 10, 2018 3:57 am

Welcome Saratoga Gal!

You might have to clear that code with a code reader or Go through several drive cycles to makeit go away. In that link above, the MAP and AC sensors share the power bus and failures on either of these can pop that code. If you can find the right wiring code for your car ( we don’t host them here by legal agreement with Volvo, but users can locate and post them in threads) that might help us on the diagnostic path.

If you come South a bit, you can join us for ALBANY Volvo fest sometime and have us look it’s over , too.


It’s free, bad puns are the only cost of attending.
1 SWMBO for 30 years
2 Volvos
3 VWs
4 Careers
5 cats/dogs/gears
6 Perfect Ladies in waiting
7 Drivers
8 Boats- with a big pointy metal thing on top

1999 V70 T5M 56 2005 V70 NA M56 VWs BMW

User avatar
Saratoga Gal
Posts: 2
Joined: Sat Apr 09, 2016 7:36 pm
Year and Model: 1998 V70 GLT
Location: Saratoga Springs, NY
United States of America

Re: CEL and barometric pressure sensor error code

Post by Saratoga Gal » Tue Jul 10, 2018 2:20 pm

I love my Volvo but smacking it around seems a bit harsh! Whack the MAP sensor with a hammer? A most curious fix indeed but I suppose worth trying. Let it be known that I am a pacifist at heart. I have a OBD-II meter that can clear codes but I have had no success so far. I will try anything if it keeps me from going bald soon.

I will give an update. Thanks again for all your help and I have nothing against bad puns so Volvo fest might be in my future!

jimmy57
Posts: 5846
Joined: Fri Nov 12, 2010 9:25 am
Year and Model: 2004 V70R GT, et al
Location: Ponder Texas
Been thanked: 68 times

Re: CEL and barometric pressure sensor error code

Post by jimmy57 » Tue Jul 10, 2018 2:29 pm

the supply voltage, reference voltage, is shared with a/c high pressure sensor and the vertical accel sensor. The accel sensor is on the subframe below a/c compressor and may have been damaged.

WhatAmIDoing
Posts: 374
Joined: Sat Jul 30, 2016 1:13 pm
Year and Model: 1998 S70 T5M
Location: North America
Has thanked: 25 times
Been thanked: 28 times
Canada

Re: CEL and barometric pressure sensor error code

Post by WhatAmIDoing » Tue Jul 10, 2018 2:37 pm

Last time I got this code, I pulled the sensor, tapped it against a hard surface a few times, and reinstalled. No more code. But since you said you had replaced the sensor, I doubt this is the issue. I think it lies somewhere in the wiring.
'98 S70 T5M - 265,000+mi

Post Reply

Who is online

Users browsing this forum: bmdubya1198, ecbsykes, Majestic-12 [Bot], WhatAmIDoing and 92 guests