IPD sale Volvo Parts

v70 electrical problems

Help, Advice, Owners' Discussion and DIY Tutorials on the current (third) generation Volvo V70 wagon and XC70 crossover, and second generation S80.

This is a forum for owners or prospective owners of the third generation V70, second generation S80, and its siblings built on the EUCD platform.
Post Reply
jordanfiji
Posts: 2
Joined: Thu Jul 12, 2018 3:11 pm
Year and Model: 2008 v70
Location: Vest-Agder
Has thanked: 2 times
Norway

v70 electrical problems

Post by jordanfiji » Thu Jul 12, 2018 3:16 pm

My V70 2008 is giving the following symptoms for a few weeks now:
- hatch open warning
- rear baggage room light not working
- rear window wiper not working
- rear window heater not working
- auto door locks not working (autolocking after 5km/hr speed)

I've done the following:
- replaced the latch unit on the hatch
- checked the back light bulb
- checked continuity on the rear window heater
- checked the wires for frays everywhere I could think of
- checked all relevant fuses

What else could be the problem, what action could I take? Thanks!

Tags:

User avatar
mrbrian200
Posts: 1314
Joined: Wed Jan 20, 2016 8:47 am
Year and Model: 2006 S60 2.5T FWD
Location: Northern Indiana/Chicago
Has thanked: 3 times
Been thanked: 59 times
United States of America

Re: v70 electrical problems

Post by mrbrian200 » Thu Jul 12, 2018 10:08 pm

I believe the autolocks don't engage when it thinks a door, hatch, or the trunk (on a sedan) is open, so that's probably not technically a 'fault'.

The wire(s) running to the hatch may not appear obviously damaged or frayed to the eye. The copper conductor can break without damaging the insulation. I've had this happen twice over the years on various vehicles.
Both were at points where the wire was subject to flexing. Once in a door grommet, and another time on an engine harness where it jumped between the chassis to a sensor attached to the intake piping that flexed the wire a little each time the engine rocked under torque.

You have to trace the wires with a circuit tester. If you find a break, you will want to replace that section of wire with very fine stranded wire so that the repair/junctions to the original harness aren't in the area that gets flexed or it's likely to break again prematurely.

jordanfiji
Posts: 2
Joined: Thu Jul 12, 2018 3:11 pm
Year and Model: 2008 v70
Location: Vest-Agder
Has thanked: 2 times
Norway

Re: v70 electrical problems

Post by jordanfiji » Tue Jul 17, 2018 7:43 am

I have now tested all of the wires from the hatch to the main body of the vehicle and all were intact and gave good continuity. I didn't go from the back of the car up to the front, but I don't think that there would be any fatigue there.

Any other ideas what could be wrong here? I've also tried to "reset" the warning light by disconnecting the negative battery terminal, though I suspect this is not necessary / effective.

User avatar
oragex
Posts: 3575
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 64 times
Been thanked: 83 times
Contact:
Canada

Re: v70 electrical problems

Post by oragex » Tue Jul 17, 2018 8:56 am

I'm thinking about the micro switches on the door latches or on the trunk. Try isolate the faulty part by pulling it's fuse if it has a separate fuse or try just unplugging the latches one by one (may require door panel removal)
2003 2.4i S60 automatic 125k miles

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests