IPD sale Volvo Parts

Volvo S60 weird "stall"

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" cars.
2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R
EdwinS60
Posts: 10
Joined: Fri Jul 13, 2018 11:24 pm
Year and Model: 2003 S60
Location: Lithuania
Has thanked: 2 times
Lithuania

Volvo S60 weird "stall"

Post by EdwinS60 » Fri Jul 13, 2018 11:34 pm

Hello. I am having a weird problem with my S60. (2003, 2,4 turbo, automatic) For a second it loses power, autopilot turns off, some lights come on including check engine light for a second and all comes back to normal. I used to have one error code P0244, turbo wasnt moving properly, they moved it a bit and it started to work again. Code isn't there anymore. I think this 1 second stuttet might have been causing stall when im driving slower.

This error stutter might not happen for a month and then happen 5 times in 1 day.

Also if I do stall, I can't start it right away, need to keep ignition on for a min...

Any ideas? No error codes

I could film it but it is so random that i would use my all phone memory for that : :)



RickHaleParker
Posts: 1127
Joined: Mon May 25, 2015 2:30 pm
Year and Model: 1998 C70 Coupe
Location: Kansas
Has thanked: 2 times
Been thanked: 93 times
United States of America

Re: Volvo S60 weird "stall"

Post by RickHaleParker » Sat Jul 14, 2018 12:53 am

It sounds like a bad electrical connection or a intermittent short, you might start by look for one. In the engine compartment is where I would look first because that is where the most problems are due to heat, ice and exposure to road spray.


1997 S90, B6304S, AW30-42
1998 C70, B5234T3, AW50-42

EdwinS60
Posts: 10
Joined: Fri Jul 13, 2018 11:24 pm
Year and Model: 2003 S60
Location: Lithuania
Has thanked: 2 times
Lithuania

Re: Volvo S60 weird "stall"

Post by EdwinS60 » Sat Jul 14, 2018 1:00 am

For example radio plays uninterrupted, lights do not dim or turn off for that second, only thing affected is that it completely loses power and autopilot turns off. I will try to film it going back from work today. Also i think engine changes sound, sounds lower, or turbo whistle goes away after that until you push on gas more



User avatar
oragex
Posts: 3233
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 41 times
Been thanked: 60 times
Contact:
Canada

Re: Volvo S60 weird "stall"

Post by oragex » Sat Jul 14, 2018 1:30 am

Is this happening in raining days ? Google up about CEM

May as well read this page https://www.volvoforums.org.uk/showthre ... 192&page=6


2003 2.4i S60 automatic 125k miles

EdwinS60
Posts: 10
Joined: Fri Jul 13, 2018 11:24 pm
Year and Model: 2003 S60
Location: Lithuania
Has thanked: 2 times
Lithuania

Re: Volvo S60 weird "stall"

Post by EdwinS60 » Sat Jul 14, 2018 1:53 am

It doesn't have any connection to rain, happens randomly. But if it happens, it happens more than once in one, lets say, 25km ride. Happened during winter, less frequently, but maybe it is progressing towards somethings death :|



EdwinS60
Posts: 10
Joined: Fri Jul 13, 2018 11:24 pm
Year and Model: 2003 S60
Location: Lithuania
Has thanked: 2 times
Lithuania

Re: Volvo S60 weird "stall"

Post by EdwinS60 » Sat Jul 14, 2018 2:07 am

Could it be a missfire done by one of injectors or something like that? Since there are no codes



RickHaleParker
Posts: 1127
Joined: Mon May 25, 2015 2:30 pm
Year and Model: 1998 C70 Coupe
Location: Kansas
Has thanked: 2 times
Been thanked: 93 times
United States of America

Re: Volvo S60 weird "stall"

Post by RickHaleParker » Sat Jul 14, 2018 2:38 am

Did you do a code scan with a OBD scanner? There could be pending codes that might give you a clue.


1997 S90, B6304S, AW30-42
1998 C70, B5234T3, AW50-42

EdwinS60
Posts: 10
Joined: Fri Jul 13, 2018 11:24 pm
Year and Model: 2003 S60
Location: Lithuania
Has thanked: 2 times
Lithuania

Re: Volvo S60 weird "stall"

Post by EdwinS60 » Sat Jul 14, 2018 3:42 am

Nope no codes, i have Elm327 scanner



RickHaleParker
Posts: 1127
Joined: Mon May 25, 2015 2:30 pm
Year and Model: 1998 C70 Coupe
Location: Kansas
Has thanked: 2 times
Been thanked: 93 times
United States of America

Re: Volvo S60 weird "stall"

Post by RickHaleParker » Sat Jul 14, 2018 5:59 am

Elm327 is a hardware interface. Some OBD software cannot read pending codes. What OBD software are you using? Torque Pro reads active and pending codes.


1997 S90, B6304S, AW30-42
1998 C70, B5234T3, AW50-42

Georgeandkira
Posts: 495
Joined: Tue Apr 07, 2009 8:24 am
Year and Model: 2007 V70 base
Location: Hudson & Champlain Valleys, USA
Has thanked: 7 times
Been thanked: 16 times
United States of America

LONGSHOT

Post by Georgeandkira » Sat Jul 14, 2018 6:06 am

May sound crazy...but...FULLY inspect your battery connections....specifically the condition of the lead swag and/or crimped-on lug. I've seen them corroded to where electricity didn't pass.



Post Reply

Return to “Volvo V70 & XC-70 2001-2007
S60 2001-2009”

Who is online

Users browsing this forum: No registered users and 15 guests