IPD sale Volvo Parts

2010 Volvo S80 T6 AWD Repair Manual

Help, Advice, Owners' Discussion and DIY Tutorials on the current (third) generation Volvo V70 wagon and XC70 crossover, and second generation S80.

This is a forum for owners or prospective owners of the third generation V70, second generation S80, and its siblings built on the EUCD platform.
Post Reply
tnsoldier1977
Posts: 1
Joined: Tue Jul 17, 2018 12:29 pm
Year and Model: 2010
Location: Tennessee
United States of America

2010 Volvo S80 T6 AWD Repair Manual

Post by tnsoldier1977 » Tue Jul 17, 2018 1:05 pm

Greetings all. I own a 2010 S80 T6 AWD. I've been experiencing issues with getting a High Coolant Temp warning. I think I have narrowed it down to maybe a thermostat issue. I get the warning intermittently when the vehicle has been driven and then I park, with the vehicle running, or is sitting in a drive through, the High coolant temp warning comes on. As long as the vehicle is being driven down the road, the warning does not happen. The coolant in the expansion tank is at normal level. The electric fans are working. I have attempted to recreate the issue by starting the vehicle and allowing it to run in park, but have not got it to recreate. I have also "back washed" the radiator to see if that "fixed" the problem, but the vehicle problem is still occurring if the vehicle is driven, then runs while parked or while sitting in a drive through. I have driven it the vehicle, then let it idle for approximately 8 minutes and checked the temp of the upper and lower radiator hoses with a laser temp gun. There's a 20 degree difference, which leads me to believe the radiator and fans are doing their job. Also, since the warning comes intermittently, I would believe that the water pump working as it should.
Does anyone have a link or know where I can find a repair manual or PDF to show me want all needs to be done to replace the thermostat. I have discovered that the replacement comes with a new housing, temp sensor and thermostat and that you are suppose to remove the intake manifold to get access for replacement.

A separate issue is the A/C doesn't get cold at first and will quit blowing cold after a while when the A/C does cool. A professional A/C guy told me that the expansion valve probably needs to be replaced. Anyone have a diagram or pdf on where's it's located and how to replace it?

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests