IPD sale Volvo Parts

06 S40 ignition switch replacement

Help, Advice, Owners' Discussion and DIY Tutorials devoted to the second generation C70, S40 and V50 Volvos -- awkwardly model year 2004 ½ onwards -- plus where to go for advice and discussion on Volvo's sporty C30 Coupe powered by Volvo's ubiquitous inline 5-cylinder power plant.
Post Reply
ottodsl
Posts: 3
Joined: Fri Sep 14, 2018 4:30 pm
Year and Model: 07 S40
Location: Mercer Pennsylvania
United States of America

06 S40 ignition switch replacement

Post by ottodsl » Fri Sep 14, 2018 8:10 pm

Greetings, I have an 06 S 40 T5 manual trans and it has an ignition switch problem. The other day I inserted the key and started the vehicle just as normal and after it started it quit immediately and everything was gone. Nothing electrical was working. Nothing. And the key will not go to the off position to be removed. The battery is fully charged and has good connections and grounds at the battery. My focus is twofold .
#1 , is this a key switch problem , or what might be going on ? A fusible link somewhere ?
#2 , what is the procedure for replacing the dash switch ? If I buy a used one will I need to get it programmed ? Can the programming be done anywhere other than Volvo ?
Any & all input will be much appreciated. I had Volvos back in the 70's but strayed from the fold. If I remember right it had a B40 engine.
Thank you for looking !



ottodsl
Posts: 3
Joined: Fri Sep 14, 2018 4:30 pm
Year and Model: 07 S40
Location: Mercer Pennsylvania
United States of America

Re: 06 S40 ignition switch replacement

Post by ottodsl » Sat Sep 15, 2018 11:07 am

LOL, Thanks for the help. Here is some insight for you. I found my problem. What happened is I lost electrical power at the connection for all the accessories right at the power bar coming from the positive battery post -- the one that feeds all the the accessories. As you know when you insert the key it makes a little buzzing noise & that somehow activates something inside the switch that allows it to release. So once I corrected the power problem the key released & everything is hunky dory. So here is the answer to my own issue. Hope that helps some other individual out there who is looking for an answer to an odd situation. Kudos !



Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests