IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

98 S70 N/A 5-Speed: Complete A/C job (yay!) not holding a vacuum... (sigh!) How do I troubleshoot this?

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

User avatar
June
Posts: 1491
Joined: Wed May 04, 2016 11:18 am
Year and Model: 2004 S80 T6
Location: Jacksonville, Florida
Has thanked: 224 times
Been thanked: 115 times
United States of America
June

Re: 98 S70 N/A 5-Speed: Complete A/C job (yay!) not holding a vacuum... (sigh!) How do I troubleshoot this?

Post by June » Mon Oct 08, 2018 8:18 am

Add freon to the system and use a leak detector device to find the leak. Someone chime in. Possibly you can rent a leak detector? You did coat the O-rings with AC oil before reinstalling and if the compressor was replaced oil in the compressor to coat the front seal? Mike told me those are common misses to cause leaks under vacuum. He also said use Ester oil for O-rings otherwise joints will be hard to pull apart in the future. Thought I would pass his advice on to you. Hope it helps. June


My Volvo cars owned
1989 740 GLT ordered
1994 850 4door standard shift ordered
1996 960 ordered
1998 S90 ordered totalled after 3 weeks
1998 V70 GT dealer stock car
2002 S80 T6 ordered totalled
2004 S80 T6 dealer stock car and current car owned

User avatar
theWIFES_S70
Posts: 1133
Joined: Fri Jul 24, 2015 10:34 pm
Year and Model: 1998 S70 base
Location: Queens, New York
Has thanked: 31 times
Been thanked: 24 times
Peru
theWIFES_S70

Re: 98 S70 N/A 5-Speed: Complete A/C job (yay!) not holding a vacuum... (sigh!) How do I troubleshoot this?

Post by theWIFES_S70 » Mon Oct 08, 2018 8:52 am

I think it's the drier. I couldn't really crank it down like l would've wanted to. Will disconnect it, drop it and wrench it.

I might get to it in two/three weeks...


1998 Volvo S70, N/A, 5-speed, 183K
2007 Volvo S40, 2.4i, 5-speed, 97K

User avatar
abscate
MVS Moderator
Posts: 18498
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 212 times
Been thanked: 696 times
Trinidad & Tobago
abscate

Re: 98 S70 N/A 5-Speed: Complete A/C job (yay!) not holding a vacuum... (sigh!) How do I troubleshoot this?

Post by abscate » Sat Sep 21, 2019 5:12 am

I know you got this done Marco...how did you find it and where was the leak?


Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW

User avatar
wizechatmgr
Posts: 1239
Joined: Thu Jan 12, 2017 1:07 pm
Year and Model: 1999 V70 XC AWD 2.4T
Location: Albany, NY area
Has thanked: 20 times
Been thanked: 51 times
Contact:
United States of America
wizechatmgr

Re: 98 S70 N/A 5-Speed: Complete A/C job (yay!) not holding a vacuum... (sigh!) How do I troubleshoot this?

Post by wizechatmgr » Sun Sep 22, 2019 11:32 pm

I know after doing the Evap coil on mine I developed a small leak on the high pressure side sensor. It was an o-ring that needed to be replaced.


Wisdom requires knowledge as a prerequisite, but knowledge can be developed due to a lack of wisdom.
In order to learn how to fix something, you must first learn how to break it.
1999 V70 XC AWD - ~177k miles

User avatar
theWIFES_S70
Posts: 1133
Joined: Fri Jul 24, 2015 10:34 pm
Year and Model: 1998 S70 base
Location: Queens, New York
Has thanked: 31 times
Been thanked: 24 times
Peru
theWIFES_S70

Re: 98 S70 N/A 5-Speed: Complete A/C job (yay!) not holding a vacuum... (sigh!) How do I troubleshoot this?

Post by theWIFES_S70 » Mon Oct 07, 2019 10:51 pm

abscate wrote:
Sat Sep 21, 2019 5:12 am
I know you got this done Marco...how did you find it and where was the leak?
I actually never got to it. Life got in the way... :(

Still no A/C on "the husband's S70" now. (The wife is driving an S40 now...) :mrgreen:


1998 Volvo S70, N/A, 5-speed, 183K
2007 Volvo S40, 2.4i, 5-speed, 97K

User avatar
abscate
MVS Moderator
Posts: 18498
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 212 times
Been thanked: 696 times
Trinidad & Tobago
abscate

Re: 98 S70 N/A 5-Speed: Complete A/C job (yay!) not holding a vacuum... (sigh!) How do I troubleshoot this?

Post by abscate » Tue Oct 08, 2019 5:40 am

Well bring it up, pick up Dirk, and let’s have a massive “ do three evap party” in Albany before the weather hits. I’ve got dash out time down to 35 minutes
These users thanked the author abscate for the post:
850 LPT


Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW

850 LPT
Posts: 1142
Joined: Fri May 27, 2011 8:05 am
Year and Model: 96' 850
Location: CT
Has thanked: 44 times
Been thanked: 35 times
United States of America
850 LPT

Re: 98 S70 N/A 5-Speed: Complete A/C job (yay!) not holding a vacuum... (sigh!) How do I troubleshoot this?

Post by 850 LPT » Tue Oct 08, 2019 6:36 am

abscate wrote:
Tue Oct 08, 2019 5:40 am
Well bring it up, pick up Dirk, and let’s have a massive “ do three evap party” in Albany before the weather hits. I’ve got dash out time down to 35 minutes
That would be nice, but I have no time right now. We are getting ready for a camping trip in the white mountains over the holiday weekend, and after that I need to split a rather large amount of firewood :shock:

But I am reading through these threads in preparation of doing 2 cars. I am pretty sure I need to replace every single AC component on the S70, because things like fittings look very rusty.
The 850 was still doing good over the summer, but it seems that now the leak has gotten bigger and it finally crapped out. But this car has low miles, so maybe just replacing the evap. might do the trick?

Dirk


96' 850 sedan, base, auto, pewter/charcoal, 111k miles
99' S70, base, 5-speed manual, nautic blue/ tan, 213k miles
04' V70, auto, ash gold/ tan, 225k miles, daughters car
05' V70, 5-speed manual, loaded, mistral green/ tan, 146k miles
79' Ford Capri S, Euro Spec 2.8 V6, T9 5-speed manual
58' Porsche Diesel Junior
13' Honda Odyssey :oops:

User avatar
abscate
MVS Moderator
Posts: 18498
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 212 times
Been thanked: 696 times
Trinidad & Tobago
abscate

Re: 98 S70 N/A 5-Speed: Complete A/C job (yay!) not holding a vacuum... (sigh!) How do I troubleshoot this?

Post by abscate » Tue Oct 08, 2019 11:34 am

Evap is the only big one, cheap part but lots of labour to get to it. Worse if/when you have to repair the dash mounts.

Once you do the Evap, everything else is bolt on/ off and you don’t lose the car use during the work, unless it’s the compressor (needed for SERP belt)


Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW

User avatar
theWIFES_S70
Posts: 1133
Joined: Fri Jul 24, 2015 10:34 pm
Year and Model: 1998 S70 base
Location: Queens, New York
Has thanked: 31 times
Been thanked: 24 times
Peru
theWIFES_S70

Re: 98 S70 N/A 5-Speed: Complete A/C job (yay!) not holding a vacuum... (sigh!) How do I troubleshoot this?

Post by theWIFES_S70 » Wed Oct 09, 2019 10:13 am

abscate wrote:
Tue Oct 08, 2019 11:34 am
Evap is the only big one, cheap part but lots of labour to get to it. Worse if/when you have to repair the dash mounts.

Once you do the Evap, everything else is bolt on/ off and you don’t lose the car use during the work, unless it’s the compressor (needed for SERP belt)
Well, abscate, you're forgetting the silly hand contortion you have to accomplish to attach lines to the compressor... :lol: (My god that took hours... I can only imagine what it's like for you Turbo guys!!!)

I really should get up there and do this A/C job already. (I really think I need to pony up for a new compressor...)


1998 Volvo S70, N/A, 5-speed, 183K
2007 Volvo S40, 2.4i, 5-speed, 97K

User avatar
E Showell
Posts: 2801
Joined: Thu Oct 16, 2008 4:00 pm
Year and Model: V70R '06 AWD Auto
Location: Long Valley, N.J.
Has thanked: 5 times
Been thanked: 35 times
United States of America
E Showell

Re: 98 S70 N/A 5-Speed: Complete A/C job (yay!) not holding a vacuum... (sigh!) How do I troubleshoot this?

Post by E Showell » Wed Oct 09, 2019 10:40 am

Best to do that A/C work before winter as you may need functioning A/C to clear the windows in damp cold weather.


'98 V70 NA FWD 5 spd, silver sand metallic (sold)
'99 V70 NA FWD Auto, dark blue (actively for sale)
'99 S70 NA FWD Auto, black (sold and resurrected -- Don't cry for me Argentina . . . )
'07 S80 3.2 FWD Auto, Barents Blue Metallic
'06 V70 R AWD Auto, Sonic Blue Metallic
'04 XC70 Ruby Red Metallic

Post Reply