IPD sale Volvo Parts

2013 XC90 backup camera stopped working

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo XC90s. The XC90 proved to be very popular, and very good for Volvo's sales numbers, since its introduction in model year 2003 (North America).
Post Reply
wbuhrman
Posts: 1
Joined: Thu Aug 29, 2013 9:01 am
Year and Model: 2013 XC90
Location: Maryland
United States of America

2013 XC90 backup camera stopped working

Post by wbuhrman » Tue Jan 08, 2019 1:19 pm

The backup camera on my 2013 XC90 started becoming intermittent a few months ago, and now has ceased operating completely. When the vehicle is put into reverse the screen goes black. No backup lines, no image, nothing. This is the factory installed system with navigation. Anybody seen this and know what the problem could be?

Thanks.

User avatar
RickHaleParker
Posts: 2136
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 2 times
Been thanked: 227 times
United States of America

Re: 2013 XC90 backup camera stopped working

Post by RickHaleParker » Tue Jan 08, 2019 1:50 pm

Look for loose or dirty connections to the camera.
Platform: P80 1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

Post Reply

Who is online

Users browsing this forum: Masscomguru and 11 guests