IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

VIDA resets after Tranny swap.

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo XC90s. The XC90 proved to be very popular, and very good for Volvo's sales numbers, since its introduction in model year 2003 (North America).
PoppySheaf
Posts: 50
Joined: Mon Dec 17, 2018 7:14 pm
Year and Model: 2008 XC90
Location: Columbus, Ohio
Has thanked: 8 times
Been thanked: 0
United States of America
PoppySheaf

Re: VIDA resets after Tranny swap.

Post by PoppySheaf » Tue Feb 19, 2019 5:35 am

The only thing I'm reusing is the TCM.



User avatar
oragex
Posts: 4442
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 91 times
Been thanked: 213 times
Contact:
Canada
oragex

Re: VIDA resets after Tranny swap.

Post by oragex » Tue Feb 19, 2019 6:28 am

SuperHerman wrote:
Mon Feb 18, 2019 11:45 pm
Circling back to adaptations, if one uses the original valve body on a different transmission this will cause problems. The solenoids have adjusted their patterns to adjust for clutch pack wear. Unless the wear is exact between the two transmissions, the transmission will either slam or soft shift until it relearns what is required. Best off running the adaptation process. I experienced this on my XC70 while I went through the shift points. Once they were learned, all was well, and got better the more I drove it. If you don't do it this way, it could be 2-4 weeks of improper shifting until the program sorts it all out.

Agree. Also - just my experience - good to keep in mind that the results may not be perfect, mine still behaves a little weird when cold in winter days, until it warms up - but once warmed up I am so glad I did the relearn in Vida.

Don't forget to reset the adaptations during a warm summer day so the fluid can reach the minimum temperature (I believe 60C) for the adaptation relearn to engage. The relearn procedure is sometimes misunderstood, I'm showing a few points at the end of this video basically you will want to drive in such way to have the yellow triangle light up at ALL upshifts and downshifts (also the garage relearn for D and R engagement). I found this very long because no matter what I could not got a few shifts to light the triangle. I guess following the 'up to that speed' procedure doesn't always work. Good to remember - as soon as the engine is shut off (when parking it for example) the whole learning procedure ends and if it wasn't completed, will need to do it all over again.





PoppySheaf
Posts: 50
Joined: Mon Dec 17, 2018 7:14 pm
Year and Model: 2008 XC90
Location: Columbus, Ohio
Has thanked: 8 times
Been thanked: 0
United States of America
PoppySheaf

Re: VIDA resets after Tranny swap.

Post by PoppySheaf » Tue Feb 19, 2019 9:07 am

I do appreciate yours and others around the world help and suggestions!



Justtellme
Posts: 15
Joined: Mon Feb 04, 2019 3:59 pm
Year and Model: 2010xc90 1991 780
Location: Ottawa
Has thanked: 0
Been thanked: 2 times
Canada
Justtellme

Re: VIDA resets after Tranny swap.

Post by Justtellme » Tue Feb 19, 2019 7:11 pm

Just doing some more research today.

Not sure my symptoms follow the Volvo client complaints regarding the valve body ive been reading about across all Volvo sites. (Mine happens between 3/4 ( sometimes 2/3) shuddering but only when at full operating temp and after 15/ 20 mins of driving and only at part throttle or under slight load uphill. Not noticeable during spirited driving at all)

What symptoms specifically are related to a torque convertor? Shuddering on upshifts?

Apologies for kind of highjacking this thread.......
These users thanked the author Justtellme for the post:
elite150



ThommyKent
Posts: 184
Joined: Fri Nov 30, 2012 8:30 pm
Year and Model: 91 245 97 850 T5
Location: Bellevue WA USA
Has thanked: 0
Been thanked: 2 times
Romania
ThommyKent

Re: VIDA resets after Tranny swap.

Post by ThommyKent » Thu Jun 13, 2019 5:07 pm

delete
Last edited by ThommyKent on Thu Jun 13, 2019 5:30 pm, edited 2 times in total.



ThommyKent
Posts: 184
Joined: Fri Nov 30, 2012 8:30 pm
Year and Model: 91 245 97 850 T5
Location: Bellevue WA USA
Has thanked: 0
Been thanked: 2 times
Romania
ThommyKent

Re: VIDA resets after Tranny swap.

Post by ThommyKent » Thu Jun 13, 2019 5:29 pm

I just replaced a Valve Body on an S80 V8. Shifted perfect right after installation. didn`t bother with resetting adaptation. The fluid had been changed 1000 miles prior so the fluid counter was reset then ( close enough ).Don`t get a rebuilt unit for cheap, or get a rebuild kit. Part of the problem is the pistons on the solenoids wear out the bores on the Valve Body casting. The only one who bores and puts in oversize pistons to fit Is SONNAX. If you get a cheaply rebuilt or rebuild kit the pistons will still be loose in the bores and can cause issues. The SONNAX one is virtually impossible to buy unless you are a transmission shop. I wouldn`t try rebuilding one at home. one little spring forgotten or misplaced and your screwed. They are really strange to take apart, you actually need a strong magnet to pull the pins out that hold the solenoids in. So the only way to go is an new OEM Valve Body from Volvo. $1250 to $1500 is the price range

This pic is invaluable for routing of wiring.
IMG_8715 2.PNG
You do not have the required permissions to view the files attached to this post.
These users thanked the author ThommyKent for the post:
PoppySheaf



elite150
Posts: 1
Joined: Sun Dec 01, 2019 8:46 pm
Year and Model: 2014
Location: PA
Has thanked: 1 time
Been thanked: 0
United States of America
elite150

Re: VIDA resets after Tranny swap.

Post by elite150 » Sun Dec 01, 2019 8:53 pm

Justtellme - wondering if you have any updates you could offer. My XC90 is behaving the exact same way as you describe yours is/was. Have you identified what is causing this issue? Any help would be greatly appreciated!



Justtellme
Posts: 15
Joined: Mon Feb 04, 2019 3:59 pm
Year and Model: 2010xc90 1991 780
Location: Ottawa
Has thanked: 0
Been thanked: 2 times
Canada
Justtellme

Re: VIDA resets after Tranny swap.

Post by Justtellme » Wed Dec 11, 2019 6:16 pm

elite150 wrote:
Sun Dec 01, 2019 8:53 pm
Justtellme - wondering if you have any updates you could offer. My XC90 is behaving the exact same way as you describe yours is/was. Have you identified what is causing this issue? Any help would be greatly appreciated!
Hi,
I ended up replacing the coils and plugs and thermostat hoping the problem was ignition because it seemed almost like there was a miss rather than a shifting problem
No real change.

I then flushed the transmission with 12 litres of the proper stuff from FCP, then reset the fluid counter with my VIDA.
Fluid was in very bad shape and clearly had never been changed in 210k kms.
There is still a very slight barely noticeable shudder between 2/3 every once in a while, but the flush/ change cleared the problem by 90/95%.
Always took this thing to the dealer for oil changes since I bought it and am annoyed they never changed the plugs nor the trans fluid...or even recommended doing it.
This was both in Canada and at the local dealer in the Netherlands when I brought it to Europe for three years. They modified the trans software to account for wear in 2017 when I noticed some shift irregularities but I bet a fluid change would have been 100% better than the software download.



Post Reply
  • Similar Topics
    Replies
    Views
    Last post