IPD sale Volvo Parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Coolant system issues Topic is solved

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo XC90s. The XC90 proved to be very popular, and very good for Volvo's sales numbers, since its introduction in model year 2003 (North America).
dantmcclellan
Posts: 5
Joined: Sat Feb 16, 2019 10:22 am
Year and Model: 2005 XC90 2.5T AWD
Location: MN
Has thanked: 0
Been thanked: 0
United States of America
dantmcclellan

Coolant system issues

Post by dantmcclellan » Sat Feb 16, 2019 10:31 am

I've a bit of a head-scratcher. I'll drive my 2005 xc90, it gets up to temp just fine & holds at half meter. when the engine cools down, the "low coolant" alert pops up. I check the tank, it's a little low. pop the cap, pressure release & the level comes back up to max & the alert goes away.

I've replaced the resivoir cap, the coolant is bright green & clean looking, the oil is normal & the exhaust doesn't smell like anything. No noticeable leaks.

I'm not really sure where to start with this one.

Help appreciated.



dantmcclellan
Posts: 5
Joined: Sat Feb 16, 2019 10:22 am
Year and Model: 2005 XC90 2.5T AWD
Location: MN
Has thanked: 0
Been thanked: 0
United States of America
dantmcclellan

Re: Coolant system issues

Post by dantmcclellan » Sat Feb 16, 2019 10:52 am

I should also add, it's winter in mn, hasn't been above freezing for a month or so, heat blows hot.



crlande
Posts: 228
Joined: Sat Jul 27, 2013 8:48 pm
Year and Model: 240DL;850;S70
Location: Lehigh Valley, PA
Has thanked: 0
Been thanked: 9 times
United States of America
crlande

Re: Coolant system issues  Topic is solved

Post by crlande » Sat Feb 16, 2019 11:43 am

You might want to check for the presence of combustion gases in the engine coolant.



dantmcclellan
Posts: 5
Joined: Sat Feb 16, 2019 10:22 am
Year and Model: 2005 XC90 2.5T AWD
Location: MN
Has thanked: 0
Been thanked: 0
United States of America
dantmcclellan

Re: Coolant system issues

Post by dantmcclellan » Sat Feb 16, 2019 12:08 pm

Yep, tested positive for combustion gasses. I thought that was odd since there are no other signs of a bad head gasket. I guess I was in denial. Lol.

I think I'm going to try BlueDevil.



Post Reply