IPD sale Volvo Parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

V70 T6 2010 - engine overheting message 1-2min after start of the engine

Help, Advice, Owners' Discussion and DIY Tutorials on the third generation Volvo V70 wagon and XC70 crossover, and second generation S80. Are you an owner? Prospective owner? Get in here and join us! Start a new topic or comment on an existing thread.

2008-2016 V70
2008-2016 XC70
2007-2016 S80

mbinder
Posts: 5
Joined: Mon Sep 22, 2014 12:37 am
Year and Model: V70 T6 - 2010
Location: Czech Republic
Has thanked: 0
Been thanked: 0
mbinder

V70 T6 2010 - engine overheting message 1-2min after start of the engine

Post by mbinder » Thu Feb 28, 2019 12:32 am

Hi All,

I have an issue with my V70 T6 y2010, when I start the engine, outside temperature below 0, even -10°C, in one or two minutes it shows the message engine overheating slow down, followed by fail-safe mode, check engine starts blinking 2-3 injectors are disabled. When checking the engine temperature at the same time it is between 10-30°C, this happens when the car is left started for few minutes if I go immediately after a start like 20-30 sec there is no issue. if I stop the engine and start it again the message is cleared and everything works fine.

The same happens if I come home after driving 30km on the motorway, stop to open the gate, the message about overheating comes up, followed by safe-mode, engine temperature is around 90°C.

There is no fail code written, I was also by Volvo dealer they run diagnostic and did not find any issue.

Any idea is really welcome.

Thank you
Michal



precopster
Posts: 7423
Joined: Sat Aug 21, 2010 12:20 am
Year and Model: Lots
Location: Melbourne Australia
Has thanked: 4 times
Been thanked: 94 times
Australia
precopster

Re: V70 T6 2010 - engine overheting message 1-2min after start of the engine

Post by precopster » Thu Feb 28, 2019 6:16 am

Jimmy57 wrote this fix for me for a similar problem on a 2008 V70T6: I hope it helps you and worth a try. Changing fan controller would be next after this.

The fix on that car was to remove the strip fuse, 11A/44, and clean the contact points and put it back together. The diagnostic may be to trigger fan and do some internal shunt measurement in a fraction of a second and it sets that code. That could be why it does it with other modules since it is an issue on that car. That fuse is on the front of the upper layer. Not easy to get to so you have to unlatch the box and lift it. Undo the 10mm nut on the bus. There is a grey tab on inboard(engine side) of that upper layer to push and keep pushed aside, a grey tab in front center down in about 19mm down, and the black outer box has a tab that latches onto the box just aft of that strip fuse. Then you grab and pull straight up with pliers around the box. Once it lifts 4 or 5 mm it comes on out.


Current cars:2002 XC70, 2006 Ssangyong Rodius (Stavic), 2006 XC90 2.5T, VW Transporter 2.5TDI

www.precisioncarmodules.com.

mbinder
Posts: 5
Joined: Mon Sep 22, 2014 12:37 am
Year and Model: V70 T6 - 2010
Location: Czech Republic
Has thanked: 0
Been thanked: 0
mbinder

Re: V70 T6 2010 - engine overheting message 1-2min after start of the engine

Post by mbinder » Thu Feb 28, 2019 6:45 am

thank you, I will have a look, I actually have new fans including the control unit and since that, the issue occurs, what happened was that the fans were continually running on full speed, draining the battery to zero for all the time, immediately after connecting to the power, the Volvo dealer replaced the fans and control unit saying the control unit is faulty and it is delivered as one part.



jimmy57
Posts: 6255
Joined: Fri Nov 12, 2010 9:25 am
Year and Model: 2004 V70R GT, et al
Location: Ponder Texas
Has thanked: 2 times
Been thanked: 149 times
jimmy57

Re: V70 T6 2010 - engine overheting message 1-2min after start of the engine

Post by jimmy57 » Thu Feb 28, 2019 11:26 am

That is odd. It is very unlikely that the engine could get the ECT sensor to 215C in two minutes. I wonder if there is a chafed wire or some other issue going on now.



precopster
Posts: 7423
Joined: Sat Aug 21, 2010 12:20 am
Year and Model: Lots
Location: Melbourne Australia
Has thanked: 4 times
Been thanked: 94 times
Australia
precopster

Re: V70 T6 2010 - engine overheting message 1-2min after start of the engine

Post by precopster » Fri Mar 01, 2019 12:00 pm

The T6 I was working on also had the Engine Overheat message according to the auto electrician even though fans were coming on at correct speed.

I didn't see that message during my inpection.

Initially the same symptom as yours; fans coming on at full speed until controller was replaced. ECT was also replaced.

Carefully inspect wiring on that car.


Current cars:2002 XC70, 2006 Ssangyong Rodius (Stavic), 2006 XC90 2.5T, VW Transporter 2.5TDI

www.precisioncarmodules.com.

mbinder
Posts: 5
Joined: Mon Sep 22, 2014 12:37 am
Year and Model: V70 T6 - 2010
Location: Czech Republic
Has thanked: 0
Been thanked: 0
mbinder

Re: V70 T6 2010 - engine overheting message 1-2min after start of the engine

Post by mbinder » Sat Jul 06, 2019 6:45 am

Hi All,
I have not managed to get the right bottom of this, but it seems it was related to some wiring under the fusion box or between fusion box and the fans control unit as after changing oil in the gearbox the message never appeared again, for about a month, then was the car unfortunately destroyed during small fix of water pipe followed by crash during test drive.

thanks all for the answers.



Post Reply