IPD sale Volvo Parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Brakes Not Working When Turning On My S60 2007

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" cars.
2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R
ddevinatea
Posts: 4
Joined: Thu Mar 07, 2019 10:13 am
Year and Model: 2007 S60 2.0T
Location: Peru
Has thanked: 4 times
Been thanked: 0
Peru
ddevinatea

Brakes Not Working When Turning On My S60 2007

Post by ddevinatea » Thu Mar 07, 2019 10:24 am

Hi there!

I have a 2007 Volvo S60 2.0T and I have the following problem;

When I turn it on and the car has been turned off for a couple of hours or early in the morning the brakes do not work properly, I mean you can break but you have to apply a lot of force. After the car heats up, for around a minute or two, the brakes work properly again. This is very dangerous and annoying since I almost crashed in my garage. I am also very concerned about the brakes failing when using the car at high speeds.

Anyone have an idea of what could it be?

Thanks in advance,

David



User avatar
erikv11
Posts: 8821
Joined: Sat Jul 25, 2009 2:03 pm
Year and Model: 850, S/V70, 06 S60R
Location: Iowa
Has thanked: 46 times
Been thanked: 138 times
United States of America
erikv11

Re: Brakes Not Working When Turning On My S60 2007

Post by erikv11 » Thu Mar 07, 2019 3:37 pm

Pretty common problem unfortunately, the seal on the brake booster is probably compromised, and the brake vacuum pump has worn out. Regardless, the vacuum pump is probably not coming on, perhaps because it isworn out. I'll find you a link.

Here is a thread with full discussion of possibilities from when I had this problem on my car, it has lots of links too. You will also want to check the switch: https://www.matthewsvolvosite.com/forum ... =9&t=85448
These users thanked the author erikv11 for the post:
ddevinatea


'95 854 T5-R, Motronic 4.4, 185k
'96 855 NA, 140k
'98 S70 NA, 205k (living out west)
'98 V70, T5 tune-injectors-turbo, LPT engine, 275k
'06 S60 R, 155k
gone: '96 NA 850 210k, '98 NA V70 182k

ddevinatea
Posts: 4
Joined: Thu Mar 07, 2019 10:13 am
Year and Model: 2007 S60 2.0T
Location: Peru
Has thanked: 4 times
Been thanked: 0
Peru
ddevinatea

Re: Brakes Not Working When Turning On My S60 2007

Post by ddevinatea » Fri Mar 08, 2019 1:30 pm

Thank you so much! I will check!



User avatar
oragex
Posts: 3993
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 76 times
Been thanked: 138 times
Contact:
Canada
oragex

Re: Brakes Not Working When Turning On My S60 2007

Post by oragex » Sat Mar 09, 2019 5:10 am

That is a little strange it works once is warmed up. How cold is the weather there? I assume the car was recently purchased?

My first thoughts went with a frozen brake fluid if weather is sub zero, from either water in the fluid or wrong fluid altogether. I've had this experience on two other cars, with contaminated brake fluid, brake pedal getting very stiff in very cold weather until the car would warm up.

But as mentioned above, it's a classic description of a failed brake booster or seal, I'm just surprised it comes back to life by itself. Maybe also look at the pump switch, see how it is here www.youtube.com/watch?v=PRbWD2OGytk
These users thanked the author oragex for the post:
ddevinatea


2003 2.4i S60 automatic 125k miles
DIY Volvo repairs videos https://www.youtube.com/playlist?list=P ... s0FSVSOT_c

jimmy57
Posts: 6159
Joined: Fri Nov 12, 2010 9:25 am
Year and Model: 2004 V70R GT, et al
Location: Ponder Texas
Has thanked: 1 time
Been thanked: 125 times
jimmy57

Re: Brakes Not Working When Turning On My S60 2007

Post by jimmy57 » Sat Mar 09, 2019 8:34 am

VVT setting and timing retard for initial run period from cold for faster warm up diminish vacuum level. This is the 95% of the reason for the pump. Once engine has run a short time, time dependent on start temp, the cam phasing and ignition timing are back to normal control and intake vacuum is 15 inches or much more. The initial settings require a lot more throttle opening to keep idling speed and the idle speed is increased for that initial period. Higher throttle kills the vacuum. The s40/v40 4 cylinder models needed the vacuum pump once warmed up. Low compression ratio together with auto trans, engine driven power steering pump, and air con compressor was enough load that so that this model needed the aux vacuum pump with normal operating temp engine. Condition is worse as altitude increases too.



User avatar
erikv11
Posts: 8821
Joined: Sat Jul 25, 2009 2:03 pm
Year and Model: 850, S/V70, 06 S60R
Location: Iowa
Has thanked: 46 times
Been thanked: 138 times
United States of America
erikv11

Re: Brakes Not Working When Turning On My S60 2007

Post by erikv11 » Sat Mar 09, 2019 10:36 am

oragex wrote:
Sat Mar 09, 2019 5:10 am
That is a little strange it works once is warmed up. ...
I think not unusual, what OP describes was exactly the symptoms when the pump was bad on our S60. Probably not very unusual it actually makes sense. See jimmy57's post for much more insight but basically once the engine warms up and develops vacuum the pump is not needed.
These users thanked the author erikv11 for the post:
ddevinatea


'95 854 T5-R, Motronic 4.4, 185k
'96 855 NA, 140k
'98 S70 NA, 205k (living out west)
'98 V70, T5 tune-injectors-turbo, LPT engine, 275k
'06 S60 R, 155k
gone: '96 NA 850 210k, '98 NA V70 182k

ddevinatea
Posts: 4
Joined: Thu Mar 07, 2019 10:13 am
Year and Model: 2007 S60 2.0T
Location: Peru
Has thanked: 4 times
Been thanked: 0
Peru
ddevinatea

Re: Brakes Not Working When Turning On My S60 2007

Post by ddevinatea » Sat Mar 09, 2019 2:02 pm

oragex wrote:
Sat Mar 09, 2019 5:10 am
That is a little strange it works once is warmed up. How cold is the weather there? I assume the car was recently purchased?

My first thoughts went with a frozen brake fluid if weather is sub zero, from either water in the fluid or wrong fluid altogether. I've had this experience on two other cars, with contaminated brake fluid, brake pedal getting very stiff in very cold weather until the car would warm up.

But as mentioned above, it's a classic description of a failed brake booster or seal, I'm just surprised it comes back to life by itself. Maybe also look at the pump switch, see how it is here www.youtube.com/watch?v=PRbWD2OGytk
Hi! I live in Lima, Peru. We are currently in the summer with temperatures within 25 and 30 degrees Celcius. I purchased this car in January this year and didnt noticed the problem. It was a bargain though US$ 5000 for a car that sold for much more US$40,000 when new



jimmy57
Posts: 6159
Joined: Fri Nov 12, 2010 9:25 am
Year and Model: 2004 V70R GT, et al
Location: Ponder Texas
Has thanked: 1 time
Been thanked: 125 times
jimmy57

Re: Brakes Not Working When Turning On My S60 2007

Post by jimmy57 » Sat Mar 09, 2019 2:38 pm

If you turn ignition on but do not start engine you should be able to push and release brake pedal 2-4 times and then you should hear the vacuum pump run for 3-10 seconds and then go off. Pushing brake twice should make the pump run. The switch is behind left headlight with two wires in a brown connector plugged onto a round switched at a junction of three rubber hoses. The pump is below the air filter housing and is silver and roughly the size of a soup can. One of those from the switch plumbing will lead to the pump.
These users thanked the author jimmy57 for the post:
ddevinatea



User avatar
abscate
MVS Moderator
Posts: 16544
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 149 times
Been thanked: 468 times
Trinidad & Tobago
abscate

Re: Brakes Not Working When Turning On My S60 2007

Post by abscate » Sat Mar 09, 2019 3:33 pm

Altitude might be contributory here. I've spent time in Cusco, most of which in dipilitating altitude sickness.


1 SWMBO for 30 years
2 Volvos
3 VWs
4 Careers
5 cats/dogs/gears
6 Perfect Ladies in waiting
7 Drivers
8 Boats- with a big pointy metal thing on top

1999 V70 T5M 56 2005 V70 NA M56 VWs BMW

ddevinatea
Posts: 4
Joined: Thu Mar 07, 2019 10:13 am
Year and Model: 2007 S60 2.0T
Location: Peru
Has thanked: 4 times
Been thanked: 0
Peru
ddevinatea

Re: Brakes Not Working When Turning On My S60 2007

Post by ddevinatea » Sat Mar 09, 2019 7:03 pm

abscate wrote:
Sat Mar 09, 2019 3:33 pm
Altitude might be contributory here. I've spent time in Cusco, most of which in dipilitating altitude sickness.
Cusco is in high altitude around 3000 meters above sea level. I am in Lima that is at sea level



Post Reply