IPD sale Volvo Parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

87 volvo 240 dl dies after warm up no restart

Help, Advice, Owners' Discussion and DIY Tutorials on all Volvo's "mid era" rear wheel drive Volvos.

1975 - 1993 240
1983 - 1992 740
1982 - 1991 760
1986 - 1991 780
1990 - 1998 940
1990 - 1998 960
1997 - 1998 V90/S90

Bdsexton06
Posts: 3
Joined: Tue Mar 19, 2019 11:49 am
Year and Model: 87 volvo 240 dl esta
Location: Clay city ky
Has thanked: 0
Been thanked: 0
United States of America
Bdsexton06

87 volvo 240 dl dies after warm up no restart

Post by Bdsexton06 » Tue Mar 19, 2019 11:56 am

I have a 87 volvo 240 dl estate. Car runs perfectly for 20-30 min. Then dies suddenly but gas can be feathered to keep running. But engine misses and backfires only to die a few moments later. The can has had both fuel pumps replaced along with the wiring harness and fuse box in the past along with a long list of other parts and services from the pervious owner who was the orginal owner. I personally have rebuilt the distributor along with the hall effect sensor and the coil. Any help in the right direction is appreciated.



93Regina
Posts: 2442
Joined: Sat Jan 18, 2014 7:11 pm
Year and Model: 93:240/940
Location: Sunflower State
Has thanked: 0
Been thanked: 34 times
93Regina

Re: 87 volvo 240 dl dies after warm up no restart

Post by 93Regina » Tue Mar 19, 2019 2:22 pm

Bdsexton06 wrote:
Tue Mar 19, 2019 11:56 am
The can has had both fuel pumps replaced...
We do not refer to our Volvos as a "can."

So, hot wire the fuel pumps, and drive on James, but don't have an accident that ruptures fuel line.

Or, buy a new fuel pump relay....Or put a test bulb on fuse circuit feeding main fuel pump...so you can watch the bulb



dj_v70
Posts: 178
Joined: Sat Jul 19, 2014 1:51 pm
Year and Model: v70 2003
Location: ri
Has thanked: 2 times
Been thanked: 16 times
dj_v70

Re: 87 volvo 240 dl dies after warm up no restart

Post by dj_v70 » Fri Mar 22, 2019 6:39 pm

Shoot some starting fluid into manifold, does car start and run for a few seconds and die after that? If so, fuel issue. If so, do you hear fuel pump running? If not, jumper fuses 4 and 6, do you hear fuel pump now?



Bdsexton06
Posts: 3
Joined: Tue Mar 19, 2019 11:49 am
Year and Model: 87 volvo 240 dl esta
Location: Clay city ky
Has thanked: 0
Been thanked: 0
United States of America
Bdsexton06

Re: 87 volvo 240 dl dies after warm up no restart

Post by Bdsexton06 » Tue Mar 26, 2019 6:18 am

calm down "can" was a typo i love my volvo just as much as the next guy. finally got to do some investigating and found its a no spark issue. getting juice to the coil. and plugs and wires are new and tested good as well as the cap and rotor. also have replaced the hall effect sensor. there are three wires running off the sensor. does anyone have a wiring diagram that shows where the wires run to so i can trace the wire back.



93Regina
Posts: 2442
Joined: Sat Jan 18, 2014 7:11 pm
Year and Model: 93:240/940
Location: Sunflower State
Has thanked: 0
Been thanked: 34 times
93Regina

Re: 87 volvo 240 dl dies after warm up no restart

Post by 93Regina » Tue Mar 26, 2019 5:40 pm

Bdsexton06 wrote:
Tue Mar 26, 2019 6:18 am
hall effect sensor.
Bdsexton06 wrote:
Tue Mar 19, 2019 11:56 am
wiring diagram that shows where the wires run to so i can trace the wire back.
Capt1ure.JPG
Capt1ure.JPG (121.18 KiB) Viewed 264 times
Capture.JPG



93Regina
Posts: 2442
Joined: Sat Jan 18, 2014 7:11 pm
Year and Model: 93:240/940
Location: Sunflower State
Has thanked: 0
Been thanked: 34 times
93Regina

Re: 87 volvo 240 dl dies after warm up no restart

Post by 93Regina » Tue Mar 26, 2019 5:44 pm




Bdsexton06
Posts: 3
Joined: Tue Mar 19, 2019 11:49 am
Year and Model: 87 volvo 240 dl esta
Location: Clay city ky
Has thanked: 0
Been thanked: 0
United States of America
Bdsexton06

Re: 87 volvo 240 dl dies after warm up no restart

Post by Bdsexton06 » Mon Apr 01, 2019 11:36 am

im thinking that it is my connector for my control module. its pretty well roached even for it having a newer (about 10 years old) wiring harness. ive been looking for a replacement online with no luck. anyone know where i can find a replacement or even a way to rig one. thanks for all the help so far.



Post Reply