IPD sale Volvo Parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

86 740 gle wagon fuel sender unit search

Help, Advice, Owners' Discussion and DIY Tutorials on all Volvo's "mid era" rear wheel drive Volvos.

1975 - 1993 240
1983 - 1992 740
1982 - 1991 760
1986 - 1991 780
1990 - 1998 940
1990 - 1998 960
1997 - 1998 V90/S90

stabworthy
Posts: 5
Joined: Sun Mar 31, 2019 3:33 pm
Year and Model: volvo 86 740 gle
Location: TX
Has thanked: 0
Been thanked: 0
United States of America
stabworthy

86 740 gle wagon fuel sender unit search

Post by stabworthy » Sun Mar 31, 2019 4:17 pm

My wife fell in love with and bought a non running 1986 volvo 740 gle wagon non turbo with the tank dropped out of the car. The guy we bought it from had claimed all it needed was the in tank fuel pump, it looks like he pulled the entire fuel sending unit and mangled the wiring in the process. now I have to try and piece all of it back together. I have searched the internet looking for a replacement or even just a picture of the fuel sending unit. I wasn't able to find a a replacement or even just a photo after some scouring. Does anyone have any reference or experience with this year/model's sending unit? Is there maybe a known modification you can do to a different sending unit to make it functional on this car? Pics below of what was pulled out.
Image
Image
Image
Image
Image
Link in case the embedded pics won't load: https://imgur.com/a/OZZ2B9q



93Regina
Posts: 2428
Joined: Sat Jan 18, 2014 7:11 pm
Year and Model: 93:240/940
Location: Sunflower State
Has thanked: 0
Been thanked: 34 times
93Regina

Re: 86 740 gle wagon fuel sender unit search

Post by 93Regina » Sun Mar 31, 2019 10:41 pm




stabworthy
Posts: 5
Joined: Sun Mar 31, 2019 3:33 pm
Year and Model: volvo 86 740 gle
Location: TX
Has thanked: 0
Been thanked: 0
United States of America
stabworthy

Re: 86 740 gle wagon fuel sender unit search

Post by stabworthy » Mon Apr 01, 2019 12:54 pm

i saw that thread right after i posted. broke forum rule 1: always use the seach bar first. i am ashamed.



Post Reply