IPD sale Volvo Parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Ecc woes- No defrost?

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.
1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70
User avatar
Kara503
Posts: 98
Joined: Tue Jul 04, 2017 2:07 pm
Year and Model: 1996 850 Plat R-Swap
Location: Oregon
Has thanked: 11 times
Been thanked: 2 times
United States of America
Kara503

Ecc woes- No defrost?

Post by Kara503 » Fri Apr 05, 2019 2:09 pm

ECC is throwing a fit on my Platinum Edition.

I don't have time to troubleshoot the system and make it work properly, I just want to manually set it to 'permanent defrost' then deal with it later so I can drive in the humid rainy weather we are having now. I removed the glovebox to find the 'floor/ defrost' damper (#15 in the image below) stuck after removing the motor. I unstuck it but no matter where I set the flap by hand I get anywhere from no air to very little air coming from the defrost vents. I can hear the flap moving around in there making a thud so I know the shaft isnt separated from the flaps. What am I missing? Is there another damper that needs to be moved in conjunction with 15 to give me defrost?
ECC-kleppensteller.jpg
ECC-kleppensteller.jpg (24.74 KiB) Viewed 80 times
Vents are stuck on head level air only. None of the damper motors respond to any commands; the only control I have is hot or cold and fan speed. Already tried several ECC modules- the lights flash and I have the same issue on all of them so I'm fairly certain it is the system itself and not the control module. I have tried multiple times to pull the ECC codes with my home made tool but for some reason I cannot get it to work. I've tried multiple LEDs with different resistors and buttons and such but nothing will even make the LED light and I have no fuses blown so I'm not sure what to do there. It also looks like someone has been inside the dash before.



User avatar
abscate
MVS Moderator
Posts: 16658
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 165 times
Been thanked: 485 times
Trinidad & Tobago
abscate

Re: Ecc woes- No defrost?

Post by abscate » Sat Apr 06, 2019 5:44 am

I think you have the wrong motor Kara, I’ll try to find the diagram to confirm

There are two hot/cool blend doors to set the temp for driver and navigator and I think those are symmetric on the unit.

Stand by for checking...

NOPe, you have it right.. that’s crappy. All I can think of is that’s the flaps have fallen off the shaft which means a tear down. I guess last ditch effort could be a junkyard part for cheap


1 SWMBO for 30 years
2 Volvos
3 VWs
4 Careers
5 cats/dogs/gears
6 Perfect Ladies in waiting
7 Drivers
8 Boats- with a big pointy metal thing on top

1999 V70 T5M 56 2005 V70 NA M56 VWs BMW

Post Reply