IPD sale Volvo Parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

S80 2.9 6 cyl no start

Help, Advice, Owners' Discussion and DIY Tutorials on the Volvo S80 model. Sometimes called an "executive car", the S80 was and continues to be Volvo's top-of-the-line passenger car.
teds80
Posts: 2
Joined: Sun Apr 07, 2019 12:56 pm
Year and Model: s80 2004
Location: philadelphia
Has thanked: 0
Been thanked: 0
United States of America
teds80

S80 2.9 6 cyl no start

Post by teds80 » Sun Apr 07, 2019 1:07 pm

I have a no start issue, starter works fine.

I would sometimes start and run fine, now never.

It had a code for crank position sensor, replaced that. Found the 2 wires at the connector were twisted together and basically connected together. Repaired the wires going to the sensor.

Now no start.... Replaced the engine ECU no change, replaced ignition switch, no change.

While cranking I can read RPM with my scanner.


Any ideas?



teds80
Posts: 2
Joined: Sun Apr 07, 2019 12:56 pm
Year and Model: s80 2004
Location: philadelphia
Has thanked: 0
Been thanked: 0
United States of America
teds80

Re: S80 2.9 6 cyl no start

Post by teds80 » Fri Apr 12, 2019 2:09 pm

I replaced the under hood fuse / relay board, now it starts, sometimes.

Once started it idles and seems to run fine, have not driven it. Problem, if I run the RPM above 1,500 it throws a code 5200 which seems to be crank position sensor. I already replaced that, could I have a weak new sensor?



Post Reply