IPD sale Volvo Parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

AC compressor not running

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" cars.
2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R
hu5ker555
Posts: 93
Joined: Wed Nov 30, 2011 6:33 am
Year and Model: 2008 S60, 2005 S80
Location: Kansas
Has thanked: 15 times
Been thanked: 1 time
United States of America
hu5ker555

AC compressor not running

Post by hu5ker555 » Tue Apr 09, 2019 6:07 am

So I turned on my AC for the first time this season and no cold air. Listened for the AC compressor to kick on and it does not. Where do I start?



EngineeringBloke
Posts: 184
Joined: Sat Sep 08, 2012 7:31 pm
Year and Model: 2006 2.5T S60
Location: Boston
Has thanked: 24 times
Been thanked: 18 times
United States of America
EngineeringBloke

Re: AC compressor not running

Post by EngineeringBloke » Tue Apr 09, 2019 7:48 am

Check for diagnostic codes via the ODB2 port (VIDA or Torque app), or ask a for a test at an auto parts store.

Get a coolant kit (can of A/C coolant with a pressure gauge) from an auto parts store. Check the pressure in your system. You check the low pressure side:
http://acprocold.com/blog/car-tipstrick ... ng-ac-pro/

If the pressure is right, then you do NOT try to add coolant.

Might be a leak of coolant or a failed A/C component.



User avatar
oragex
Posts: 3994
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 76 times
Been thanked: 138 times
Contact:
Canada
oragex

Re: AC compressor not running

Post by oragex » Tue Apr 09, 2019 10:37 am

How warm is the weather ?
Also search for 'a/c clutch gap' see how large is yours or take a picture. But as above, it can be a system leak if last summer was working without issues


2003 2.4i S60 automatic 125k miles
DIY Volvo repairs videos https://www.youtube.com/playlist?list=P ... s0FSVSOT_c

ignatz
Posts: 76
Joined: Mon May 07, 2007 6:23 pm
Year and Model: 2002 V70t
Location: Birdsboro Pa.
Has thanked: 0
Been thanked: 0
United States of America
ignatz

Re: AC compressor not running

Post by ignatz » Tue Apr 09, 2019 11:15 am

Same for me on my 2001 V70. It lost Freon over the winter thru the filler port Schrader valve.


98 S70 T-5

hu5ker555
Posts: 93
Joined: Wed Nov 30, 2011 6:33 am
Year and Model: 2008 S60, 2005 S80
Location: Kansas
Has thanked: 15 times
Been thanked: 1 time
United States of America
hu5ker555

Re: AC compressor not running

Post by hu5ker555 » Tue Apr 09, 2019 12:46 pm

Thanks for the responses. It's in the mid-70's here now. It was working fine last summer (although I don't know that I would have ever called it "ice cold"). So maybe it just lost pressure over time and needs a boost of Freon? Should be a simple shot of 134a, right?



User avatar
oragex
Posts: 3994
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 76 times
Been thanked: 138 times
Contact:
Canada
oragex

Re: AC compressor not running

Post by oragex » Tue Apr 09, 2019 3:56 pm

Refilling with one of those refrigerant from hardware store is not always straight forward. the compressor must be running and must be refilled while the clutch is engaged, but even so I found it very tricky to read the gauge and get a real result. best left for a knowledgeable garage. plus, if there is a hole somewhere, just refilling will not help. may want to get one of these UV lamps and see in the dark if there is any leak (the refrigerant has already an ink) www.youtube.com/watch?v=5teYOnZqWuM


2003 2.4i S60 automatic 125k miles
DIY Volvo repairs videos https://www.youtube.com/playlist?list=P ... s0FSVSOT_c

precopster
Posts: 7347
Joined: Sat Aug 21, 2010 12:20 am
Year and Model: Lots
Location: Melbourne Australia
Has thanked: 3 times
Been thanked: 82 times
Australia
precopster

Re: AC compressor not running

Post by precopster » Tue Apr 09, 2019 5:50 pm

First practise without any diagnostuc equipment is to connect a test lamp to the terminal on the compressor. If it lights up every 20-50 seconds and compressor doesn't turn you have a clutch gap problem.

If it doesn't light up start looking at a diagnostic OBDII session. Using Vida you can activate the compressor with Activations menu and then determine if AC is cold. This procedure bypasses all the conditions that have to be met by the Climate computer. Likewise you can simply power up the compressor with 12V and see if AC runs cold.

In both instances don't run the compressor for more than 1 minute


Current cars:2002 XC70, 2001 V70 T5, 2006 XC90 2.5T, VW Transporter 2.5TDI

www.precisioncarmodules.com.

hu5ker555
Posts: 93
Joined: Wed Nov 30, 2011 6:33 am
Year and Model: 2008 S60, 2005 S80
Location: Kansas
Has thanked: 15 times
Been thanked: 1 time
United States of America
hu5ker555

Re: AC compressor not running

Post by hu5ker555 » Tue Apr 09, 2019 6:26 pm

I checked for fault codes through Torque...no faults. The compressor runs sometimes when I start up the car, other times it does not. I guess I'll get some Freon and try to inject some at a time when the compressor is running. If I can't get the compressor to run, is there an easy way to jump the relay? Which relay, and which ports?



User avatar
abscate
MVS Moderator
Posts: 16586
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 153 times
Been thanked: 477 times
Trinidad & Tobago
abscate

Re: AC compressor not running

Post by abscate » Tue Apr 09, 2019 6:36 pm

Do you know if you’re Torque app supports CCm codes? You can test by unpluggingthe blower motor cord and seeing if it faults.

AC systems don’t need topping up. They need to be sealed. You can have a pro search for a leak with expensive kit, or have it pumped out, then vacuum it out and test it for integrity to vacuum

The usual things that rot are the evaporator ( my favourite job) , rock hole in the condenser, or rotted out drier.

Look for UV light for the dye tracer in the Freon throughout the System.


1 SWMBO for 30 years
2 Volvos
3 VWs
4 Careers
5 cats/dogs/gears
6 Perfect Ladies in waiting
7 Drivers
8 Boats- with a big pointy metal thing on top

1999 V70 T5M 56 2005 V70 NA M56 VWs BMW

E Showell
Posts: 2594
Joined: Thu Oct 16, 2008 4:00 pm
Year and Model: V70 '98 FWD NA 5spd
Location: Long Valley, N.J.
Has thanked: 3 times
Been thanked: 23 times
United States of America
E Showell

Re: AC compressor not running

Post by E Showell » Tue Apr 09, 2019 8:13 pm

A lot of folks neglect replacing the Schrader valve when they do A/C work. The valves do go bad and leak and may actually be your problem if you're losing freon over the winter. Worth swapping if you are doing A/C work. Cheap insurance/peace of mind.


'98 V70 NA FWD 5 spd, silver sand metallic (sold)
'99 V70 NA FWD Auto, dark blue (soon to be for sale)
'99 S70 NA FWD Auto, black (sold and resurrected)
'07 S80 3.2 FWD Auto, Barents Blue Metallic
'06 V70 R AWD Auto, Sonic Blue Metallic
'04 XC70 Ruby Red Metallic

Post Reply