IPD sale Volvo Parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Engine weird sound - 3.2 - XC90 2011

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo XC90s. The XC90 proved to be very popular, and very good for Volvo's sales numbers, since its introduction in model year 2003 (North America).
CleVolvo1
Posts: 11
Joined: Thu Nov 01, 2018 1:03 pm
Year and Model: 2011 XC90
Location: Ohio
Has thanked: 0
Been thanked: 0
United States of America
CleVolvo1

Engine weird sound - 3.2 - XC90 2011

Post by CleVolvo1 » Wed Apr 10, 2019 9:59 am

Hello all,
I have a 2011 XC90 with 150,000 miles, AWD, and has the 3.2 in it. When I am driving and depress the gas pedal, basically putting some pressure or torque on the car, the engine sounds like it is pinging, scratchy, marbles, or rough, the engine runs smooth at the same time. This is very obvious when I am going up hill. I will have the pedal down a little bit and the sound is smooth, but when I press the pedal a little more the sound I am referring to comes in. I run 93 octane and the car has new plugs, air filter, and oil change.

Quick notes:
The previous owner probably ran cheap gas, I am have been putting in 93 octane -
The engine seems to be a smooth runner other than the weird sound when torque/power is applied.
I picked up the car with about 146,000 on it.



User avatar
matthew1
Site Admin
Posts: 9555
Joined: Sat Sep 14, 2002 11:03 am
Year and Model: 850 T5, 1997
Location: Denver, Colorado, US
Has thanked: 281 times
Been thanked: 110 times
United States of America
matthew1

Re: Engine weird sound - 3.2 - XC90 2011

Post by matthew1 » Wed Apr 10, 2019 10:21 am

Can you shoot a video of it? It'll give us a better chance at diagnosis. Windows up, radio off for best results.


Help keep MVS on the web -> buy from sponsors.
Also -> Amazon link
.
Like the high quality content? Thank a moderator.
Help MVS and be an MVS Contributor.


1997 850 T5, MSD ignition coil, Hallman manual boost controller, injectors, R bumper, OMP strut brace [gone]
2004 V70 R [gone]

User avatar
pgill
Posts: 80
Joined: Mon Aug 27, 2018 5:42 pm
Year and Model: 2010 S80, 2008 LR2
Location: California
Has thanked: 7 times
Been thanked: 12 times
United States of America
pgill

Re: Engine weird sound - 3.2 - XC90 2011

Post by pgill » Sun Apr 14, 2019 5:14 pm

Start with new spark plugs

I recommend

Denso (5344) IKH20

This is what I run in both of my 3.2’s

For more information see this thread

https://www.matthewsvolvosite.com/forum ... 10&t=88362

After spark plugs the PCV would be a good place to check next

Post here your results (even if you find out a different root cause)

Good luck

Paul



User avatar
pgill
Posts: 80
Joined: Mon Aug 27, 2018 5:42 pm
Year and Model: 2010 S80, 2008 LR2
Location: California
Has thanked: 7 times
Been thanked: 12 times
United States of America
pgill

Re: Engine weird sound - 3.2 - XC90 2011

Post by pgill » Sun Apr 14, 2019 5:19 pm

A picture of the spark plugs for my S80 at about 123,000 miles

I replaced these right away when I bought my S80 (used)
image.jpg



CleVolvo1
Posts: 11
Joined: Thu Nov 01, 2018 1:03 pm
Year and Model: 2011 XC90
Location: Ohio
Has thanked: 0
Been thanked: 0
United States of America
CleVolvo1

Re: Engine weird sound - 3.2 - XC90 2011

Post by CleVolvo1 » Wed Apr 17, 2019 12:52 pm

matthew1 wrote:
Wed Apr 10, 2019 10:21 am
Can you shoot a video of it? It'll give us a better chance at diagnosis. Windows up, radio off for best results.
I have video however the two clips are 70MB and 26MB I am not sure if this site will allow large files as such.



CleVolvo1
Posts: 11
Joined: Thu Nov 01, 2018 1:03 pm
Year and Model: 2011 XC90
Location: Ohio
Has thanked: 0
Been thanked: 0
United States of America
CleVolvo1

Re: Engine weird sound - 3.2 - XC90 2011

Post by CleVolvo1 » Wed Apr 17, 2019 12:53 pm

pgill wrote:
Sun Apr 14, 2019 5:19 pm
A picture of the spark plugs for my S80 at about 123,000 miles

I replaced these right away when I bought my S80 (used)

image.jpg
I replaced the plugs already, they were all pretty much done, and I mean DONE!



User avatar
pgill
Posts: 80
Joined: Mon Aug 27, 2018 5:42 pm
Year and Model: 2010 S80, 2008 LR2
Location: California
Has thanked: 7 times
Been thanked: 12 times
United States of America
pgill

Re: Engine weird sound - 3.2 - XC90 2011

Post by pgill » Wed Apr 17, 2019 1:05 pm

What Spark plugs did you buy?



CleVolvo1
Posts: 11
Joined: Thu Nov 01, 2018 1:03 pm
Year and Model: 2011 XC90
Location: Ohio
Has thanked: 0
Been thanked: 0
United States of America
CleVolvo1

Re: Engine weird sound - 3.2 - XC90 2011

Post by CleVolvo1 » Wed Apr 17, 2019 1:22 pm

NGK



CleVolvo1
Posts: 11
Joined: Thu Nov 01, 2018 1:03 pm
Year and Model: 2011 XC90
Location: Ohio
Has thanked: 0
Been thanked: 0
United States of America
CleVolvo1

Re: Engine weird sound - 3.2 - XC90 2011

Post by CleVolvo1 » Wed Apr 17, 2019 1:23 pm

Quick note I do have another XC90, exact everything, that seems to be coming into this same problem. It has OEM dealer plugs.



User avatar
matthew1
Site Admin
Posts: 9555
Joined: Sat Sep 14, 2002 11:03 am
Year and Model: 850 T5, 1997
Location: Denver, Colorado, US
Has thanked: 281 times
Been thanked: 110 times
United States of America
matthew1

Re: Engine weird sound - 3.2 - XC90 2011

Post by matthew1 » Wed Apr 17, 2019 1:52 pm

CleVolvo1 wrote:
Wed Apr 17, 2019 12:52 pm
matthew1 wrote:
Wed Apr 10, 2019 10:21 am
Can you shoot a video of it? It'll give us a better chance at diagnosis. Windows up, radio off for best results.
I have video however the two clips are 70MB and 26MB I am not sure if this site will allow large files as such.
I upped the attachment max filesize allowed. Please try now.


Help keep MVS on the web -> buy from sponsors.
Also -> Amazon link
.
Like the high quality content? Thank a moderator.
Help MVS and be an MVS Contributor.


1997 850 T5, MSD ignition coil, Hallman manual boost controller, injectors, R bumper, OMP strut brace [gone]
2004 V70 R [gone]

Post Reply