IPD sale Volvo Parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Cooling Fan running high all the time

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

pdr1966sc
Posts: 36
Joined: Mon Sep 24, 2018 5:34 pm
Year and Model: 2006 V70R
Location: Ontario
Has thanked: 0
Been thanked: 2 times
Canada
pdr1966sc

Cooling Fan running high all the time

Post by pdr1966sc » Wed Apr 10, 2019 8:09 pm

This started yesterday/today - the fan runs on high all the time.
I have a known A/C pressure sensor failure/lack of charge in the system but this has been the case ever since I got the car last October.
I an use Vida to command different speeds of the fan, but when I release control from Vida, it reverts to high again.
The Engine Coolant Temp readings in Vida were sensible.
Under normal cool (below 50F, the fan actually - rarely runs at all) - until yesterday when this run all the time started.



cn90
Posts: 6370
Joined: Wed Mar 31, 2010 9:54 am
Year and Model: 2004 V70 2.5T
Location: Omaha NE
Has thanked: 0
Been thanked: 70 times
United States of America
cn90

Re: Cooling Fan running high all the time

Post by cn90 » Wed Apr 10, 2019 9:11 pm



2004 V70 2.5T 100K+
2005 XC90 2.5T 110K+

vonbaron
Posts: 10
Joined: Sat Feb 23, 2019 9:16 pm
Year and Model: 2005 XC70
Location: Tasmania
Has thanked: 0
Been thanked: 0
Australia
vonbaron

Re: Cooling Fan running high all the time

Post by vonbaron » Sun Apr 14, 2019 7:31 am

I had this with my 2005 XC70 a few months back. I could control the fan via VIDA, no problem at all.
Then, after a short while of appearing to work well, it would revert back to high speed all the time. At the time, the air conditioning system did not work, and VIDA showed a problem with the sensor or low charge level in the system. So, I went and had the system re-charged and right away, the cooling fan stopped operating at high speed from start up.
Now, the fan works as it should.
If it were the fan controller, then the fan speed would not be able to be changed via VIDA.



pdr1966sc
Posts: 36
Joined: Mon Sep 24, 2018 5:34 pm
Year and Model: 2006 V70R
Location: Ontario
Has thanked: 0
Been thanked: 2 times
Canada
pdr1966sc

Re: Cooling Fan running high all the time

Post by pdr1966sc » Sun Apr 14, 2019 12:24 pm

Thanks Von Baron, I think based on my symptoms and your experience we are talking about a similar problem.
Cold wet and clammy here today, have the car down on my hoist at 'hobby room' will start by putting my gauges on the A/C and likely find that i need refrigerant.
As I agree- if the controller had failed or anything I would not be able to switch speeds and control it with VIDA.
I am only surprised that this is the strategy to run it high indefinitely as left without repair - it is alternator load and wear on the fan.
Will report back after running A/C tests.
Peter



pdr1966sc
Posts: 36
Joined: Mon Sep 24, 2018 5:34 pm
Year and Model: 2006 V70R
Location: Ontario
Has thanked: 0
Been thanked: 2 times
Canada
pdr1966sc

Re: Cooling Fan running high all the time

Post by pdr1966sc » Mon Apr 15, 2019 7:02 pm

OK Following up here, when I put gauges on there was some but not much pressure in the system.
Started up, added one can of R134a and system started cycling - AND - the fan switched off of high down to lower speed.
Cycling and cooling fine now, fan seams normal.

Pete



EngineeringBloke
Posts: 212
Joined: Sat Sep 08, 2012 7:31 pm
Year and Model: 2006 2.5T S60
Location: Boston
Has thanked: 28 times
Been thanked: 19 times
United States of America
EngineeringBloke

Re: Cooling Fan running high all the time

Post by EngineeringBloke » Tue Apr 16, 2019 2:10 pm

That's great Pete. Keep an eye on the pressure to see if it is holding or leaking, or you can just see if the fan running symptom returns in the future.



User avatar
abscate
MVS Moderator
Posts: 17324
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 185 times
Been thanked: 560 times
Trinidad & Tobago
abscate

Re: Cooling Fan running high all the time

Post by abscate » Wed Apr 17, 2019 4:09 am

Did you vacuum test the system first? There is no point adding Freon to a leaky System it will be both not green and not save you green at the same time.


1 SWMBO for 30 years
2 Volvos
3 VWs
4 Careers
5 cats/dogs/gears
6 Perfect Ladies in waiting
7 Drivers
8 Boats- with a big pointy metal thing on top

1999 V70 T5M 56 2005 V70 NA M56 VWs BMW

veektor
Posts: 88
Joined: Tue Feb 06, 2018 11:48 am
Year and Model: 2008 S60
Location: Kansas City
Has thanked: 3 times
Been thanked: 2 times
United States of America
veektor

Re: Cooling Fan running high all the time

Post by veektor » Mon May 13, 2019 3:50 pm

Last week I was preparing Astrid (2008 S60) for our family vacation, and one of the things I wanted to do was to charge the A/C with refrigerant. I could hear the compressor cycling on and off, and the air wasn't blowing cold. I had hooked up the HF manifold and started shooting some R134 from Walmart into the system, watching the LOW gauge and listening to the compressor. As the pressure seemed to level off around 40psi, I noticed the electric fan kicking on and staying. Because the compressor was still cycling, I kept pushing R134 into it. Then I heard a loud puff, with some steam, coming out between the fan and the engine. Bone head that I am, I pumped a little more R134 in, and heard another puff. At this point I decided to back off, turn off the engine, and look around. It appears I have inadvertently pressure tested the system, and found a leaking hose.

We decided to drive the car without A/C, which worked fine for the drive to Colorado, but it looks like the drive back through Kansas tomorrow will be miserable.

I would like to understand why the electric fan kicks on when I try to turn the A/C system on. I also could use some pointers on identifying components I should replace, besides the obviously leaking rubber hose.



User avatar
abscate
MVS Moderator
Posts: 17324
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 185 times
Been thanked: 560 times
Trinidad & Tobago
abscate

Re: Cooling Fan running high all the time

Post by abscate » Tue May 14, 2019 4:23 am

The fan Is used to relieve high presssure In they system in normal operation on a COTS system but I’m not sure about your 2008. After you fix your hose, by the far the best way To charge is evacuate and then add by mass. You can Fine tune performance +-10% around recommended charge ( label under hood) but you will get good AC if you just charge to spec


1 SWMBO for 30 years
2 Volvos
3 VWs
4 Careers
5 cats/dogs/gears
6 Perfect Ladies in waiting
7 Drivers
8 Boats- with a big pointy metal thing on top

1999 V70 T5M 56 2005 V70 NA M56 VWs BMW

jimmy57
Posts: 6217
Joined: Fri Nov 12, 2010 9:25 am
Year and Model: 2004 V70R GT, et al
Location: Ponder Texas
Has thanked: 1 time
Been thanked: 144 times
jimmy57

Re: Cooling Fan running high all the time

Post by jimmy57 » Tue May 14, 2019 8:48 am

The system on your S60 uses a physical thermometer probe and cycles compressor due to evaporator temp. If you put fan on high speed and the car is hot, 95F inside then it might be as high as 40 psi and may not cycle for a bit but one the air from vents gets into the 40's the compressor will start cycling as the evaporator temp is getting to freeze point and needs to shut off compressor for break for thawing. but otherwise that is too high pressure for that car for low side. You overcharged it.
The cycling pattern of orifice refrigerant control systems using a pressure switch is different than for expansion valve with thermal evap air probe. Rpid cycling on pressure switch systems occurs when low but with thermal probe systems it occurs when it is cooling fine especially with lower fan speed.
These users thanked the author jimmy57 for the post:
veektor



Post Reply