IPD sale Volvo Parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

2003 Xc90 P2088 code

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo XC90s. The XC90 proved to be very popular, and very good for Volvo's sales numbers, since its introduction in model year 2003 (North America).
crane550
Posts: 4
Joined: Thu Apr 11, 2019 9:24 pm
Year and Model: 2003 XC90
Location: ID
Has thanked: 1 time
Been thanked: 0
United States of America
crane550

2003 Xc90 P2088 code

Post by crane550 » Thu Apr 11, 2019 9:40 pm

Hello,

Got a problem I am at my wits end trying to solve.

I recently removed the head to fix a burnt valve and put it all back together. I have double checked the timing but I am getting a P2088 code, which is 'P2088 A Camshaft Position Actuator Control Circuit Low Bank 1". Never saw this code before. I just got VIDAS up and running, and I'm showing the following:

ECM-6400

The code will come on within 30 seconds of starting the car, even before driving. Sometimes it will idle very rough, but if I clear the code it instantly smooths out.

I have replaced with solenoid for the intake side with a new (used) unit from the junkyard. Same issue. Checked the timing, and it looks good.

I did have a low oil pressure notification when I first put the head on and started her up. The oil filter was pretty old after replacing it and changing the oil it hasn't come back. Not sure how to test the actual pressure.

Any ideas on how to fix this? Need to get this thing fixed.



User avatar
RickHaleParker
Posts: 2746
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 303 times
United States of America
RickHaleParker

Re: 2003 Xc90 P2088 code

Post by RickHaleParker » Fri Apr 12, 2019 5:39 am

Some people will tell you, You need to pick three solenoids from the junkyard and hope you get one that works.


ECM-6400 means there is a problem communicating with the solenoid. It could be the wiring or the solenoid.
Try cleaning the electrical connectors and check the wiring for shorts and opens.
These users thanked the author RickHaleParker for the post:
crane550


Platform: P80 1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

crane550
Posts: 4
Joined: Thu Apr 11, 2019 9:24 pm
Year and Model: 2003 XC90
Location: ID
Has thanked: 1 time
Been thanked: 0
United States of America
crane550

Re: 2003 Xc90 P2088 code

Post by crane550 » Fri Apr 12, 2019 10:23 am

Thanks Rick, I appreciate the input.

I found the problem! And I feel kinda dumb for it... As it turns out you have to connect the correct plug on the wiring harness onto the correct VVT solenoid. I know it kind of goes without saying, not sure how I missed it.

For the sake of others who might stumble upon this thread showing the same codes I will condense down everything I found in my troubleshooting of this to let others know what to check. These were not the root cause for me, but others have found the following solutions:

1. Sludge / low oil pressure. These VVT systems run on oil pressure and others have had this code when also having problems with oil pressure. I briefly had pressure problems when I put this back together, so it turned out to be a bit of a red herring for me.

2. VVT Solenoid/Actuator is toast. I found a new one at a junkyard for $11, the dealership wants $130 for a new one. Turns out I didn't need it, but glad I didn't pay $130 for a part I didn't need to replace.

3. Bad timing. I have read that being off on your timing can throw these codes. Not sure if it's these EXACT codes or not, but since I had the belt off recently didn't want to rule out the possibility. Others have reported this code w/ bad timing.

4. Damage to the wire/connector. This code at it's heart has to do with communication with the VVT solenoid. Others have found frayed wires that caused this.

I really hope this helps other who may have had this issue. If there are other common causes feel free to post below, or let me know if this has helped you.

Alex



crane550
Posts: 4
Joined: Thu Apr 11, 2019 9:24 pm
Year and Model: 2003 XC90
Location: ID
Has thanked: 1 time
Been thanked: 0
United States of America
crane550

Re: 2003 Xc90 P2088 code

Post by crane550 » Fri Apr 12, 2019 10:26 am

Oh, and to clarify:

On my XC90 there was a yellow marker and a green stripe on the harness that goes to the INTAKE side for the VVT connector. I had it going to the exhuast side, but at least on mine and others I have seen in pictures the yellow band/green stripe on the harness goes to the intake.



User avatar
RickHaleParker
Posts: 2746
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 303 times
United States of America
RickHaleParker

Re: 2003 Xc90 P2088 code

Post by RickHaleParker » Fri Apr 12, 2019 11:06 am

crane550 wrote:
Fri Apr 12, 2019 10:23 am
I found the problem! And I feel kinda dumb for it... As it turns out you have to connect the correct plug on the wiring harness onto the correct VVT solenoid. I know it kind of goes without saying, not sure how I missed it.
Tip: Paint stick set, Mark the connectors with different colors before you disconnect.
For cams, Blue is cool (Intake) Red is hot (Exhaust).


Platform: P80 1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

crane550
Posts: 4
Joined: Thu Apr 11, 2019 9:24 pm
Year and Model: 2003 XC90
Location: ID
Has thanked: 1 time
Been thanked: 0
United States of America
crane550

Re: 2003 Xc90 P2088 code

Post by crane550 » Fri Apr 12, 2019 12:22 pm

Haha, yes I do have them and use them. For some reason I didn't use it. Lessons learned.



Post Reply