IPD sale Volvo Parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

04 xc90 t6 running on motor

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo XC90s. The XC90 proved to be very popular, and very good for Volvo's sales numbers, since its introduction in model year 2003 (North America).
Rosborn
Posts: 5
Joined: Sun Feb 03, 2019 6:08 am
Year and Model: 2004 XC90 t6
Location: Maine
Has thanked: 0
Been thanked: 0
United States of America
Rosborn

04 xc90 t6 running on motor

Post by Rosborn » Fri Apr 12, 2019 6:27 am

04 t6 running on motor , did smoke check on hose going to turbo looked good . happened last spring didn't run it for the summer, when i started to drive this fall i, it came out of it after filling tank [ makes on sense] thought i'd ask you all.



User avatar
SuperHerman
Posts: 1072
Joined: Mon Dec 01, 2014 1:28 pm
Year and Model: 2004 & 2016 XC90
Location: Minnesota
Has thanked: 0
Been thanked: 89 times
United States of America
SuperHerman

Re: 04 xc90 t6 running on motor

Post by SuperHerman » Sat Apr 13, 2019 1:28 pm

I don't understand your problem. Can you explain with more detail?



Rosborn
Posts: 5
Joined: Sun Feb 03, 2019 6:08 am
Year and Model: 2004 XC90 t6
Location: Maine
Has thanked: 0
Been thanked: 0
United States of America
Rosborn

Re: 04 xc90 t6 running on motor

Post by Rosborn » Tue Apr 16, 2019 4:46 pm

Absolutely no power, very sluggish as if turbo's aren't working at all. Have to mash accelerator to floor to make it up small hills , shifts down to second gear and still very poor power.



User avatar
SuperHerman
Posts: 1072
Joined: Mon Dec 01, 2014 1:28 pm
Year and Model: 2004 & 2016 XC90
Location: Minnesota
Has thanked: 0
Been thanked: 89 times
United States of America
SuperHerman

Re: 04 xc90 t6 running on motor

Post by SuperHerman » Tue Apr 16, 2019 5:30 pm

Now I understand. Do you have any codes or a check engine light?

If you can put air pressure in the turbo lines, make sure the valves on both turbos move. If you pressurize the hose at the Turbo Boost Control Solenoid you will know if you have both a leak and whether the valves are working. You may need a helper to look to see if the arm moves. If you build no pressure you have a leak - if you do build pressure the arms should move on the turbo. They can get stuck, but this is rare.

I would also try smoking the other two lines on the Turbo Boost Control Solenoid for leakage.

You can also try cleaning the TBCS, let it dry and then send some power to it to see if it clicks. These are known to go bad and could be the cause of your problem.

After that check all your plastic pipes for leakage.

Codes are your friend here - for both the TBCS and the turbo boost pressure sensor.



Rosborn
Posts: 5
Joined: Sun Feb 03, 2019 6:08 am
Year and Model: 2004 XC90 t6
Location: Maine
Has thanked: 0
Been thanked: 0
United States of America
Rosborn

Re: 04 xc90 t6 running on motor

Post by Rosborn » Tue Apr 16, 2019 5:49 pm

I have no codes and no check engine light , I will try cleaning and go from there , thank you for helping me I will let you know my outcome



Post Reply