IPD sale Volvo Parts
XeMODeX - Experts in Volvo Electronics My Swedish Parts ad - genuine Volvo parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

850 base 0410 code causing high idle, poor fuel economy

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

JimBee
Posts: 1684
Joined: Tue Dec 09, 2008 9:23 pm
Year and Model:
Location:
Has thanked: 8 times
Been thanked: 16 times
JimBee

850 base 0410 code causing high idle, poor fuel economy

Post by JimBee » Fri Apr 19, 2019 5:16 pm

Last fall, before I parked this old friend for the winter, I limped home a few miles with the engine jumping around due to massive air leak—hose from IAC had come loose.

After I secured the hose the idle (which has always been steady at 700) is now high ~ 1200 and gas mileage is little off. After sitting since October, engine started fairly quickly and runs well. Initial idle when first started was ~ 800, after warming and driving around idle is back to 1200 and sometimes higher between shifts even with throttle let up.

Several years ago when I replaced the exhaust manifold, I removed the SAS motor and lines, that didn't seem to change how it ran, the idle stayed at ~ 700 and fuel economy didn't change up until the air hose fell off last fall.

The O'Reilly printout indicates 6 possible fault sources, including SAS and air leak. Since there were no changes due to removing the SAS I don't suspect that now and I can't find an air leak. Any suggestions?



tardcart
Posts: 410
Joined: Fri Feb 08, 2019 4:17 pm
Year and Model: 96 850t. 93 940t
Location: Pittstown Nj
Has thanked: 3 times
Been thanked: 37 times
United States of America
tardcart

Re: 850 base 0410 code causing high idle, poor fuel economy

Post by tardcart » Fri Apr 19, 2019 5:53 pm

when you removed the supplemental air pump and valve you didnt get a CL? The computer should have been looking for voltage to the pump I think. You may need a non SAS CPU. However since you were working in the area of the throttle body, are you sure its not hitting anything and closing at idle? or that you moved the TPS? The computer does everything in its power to hold 900 rpm idle, unless it thinks it being asked for more.



User avatar
RickHaleParker
Posts: 2832
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 312 times
United States of America
RickHaleParker

Re: 850 base 0410 code causing high idle, poor fuel economy

Post by RickHaleParker » Fri Apr 19, 2019 6:57 pm

.
Finish the SAS delete by adding the diode to the ECU.


Platform: P80 1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

JimBee
Posts: 1684
Joined: Tue Dec 09, 2008 9:23 pm
Year and Model:
Location:
Has thanked: 8 times
Been thanked: 16 times
JimBee

Re: 850 base 0410 code causing high idle, poor fuel economy

Post by JimBee » Fri Apr 19, 2019 8:05 pm

I could do the diode to get rid of the CEL but is that going to correct the high idle? It's the idle I want to bring down and hopefully restore the great gas mileage I had been getting on this manual trans base 2.4 — high 20's up to 30 highway. So that's first priority.



User avatar
RickHaleParker
Posts: 2832
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 312 times
United States of America
RickHaleParker

Re: 850 base 0410 code causing high idle, poor fuel economy

Post by RickHaleParker » Fri Apr 19, 2019 8:35 pm

The Substitute values for P0410 are:
1. Pulsed secondary air injection system (PAIR) diagnostic disabled
2. Front and rear heated oxygen sensor (HO2S) diagnostic disabled
3. Fuel trim disabled.


Platform: P80 1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

JimBee
Posts: 1684
Joined: Tue Dec 09, 2008 9:23 pm
Year and Model:
Location:
Has thanked: 8 times
Been thanked: 16 times
JimBee

Re: 850 base 0410 code causing high idle, poor fuel economy

Post by JimBee » Fri Apr 19, 2019 10:19 pm

What's strange is that none of those issues appeared to be present until that fateful night last October when the IAC hose came off the vacuum tree and I stumbled home—then the high idle and lower gas mileage became obvious. So, what's mysterious is that it seems to run well otherwise. But maybe with the diode fix it will be better. Onward and upward.



User avatar
jreed
Posts: 1064
Joined: Sun Mar 08, 2009 5:43 am
Year and Model: '97 Volvo 855 GLT
Location: RTP, North Carolina
Has thanked: 29 times
Been thanked: 18 times
United States of America
jreed

Re: 850 base 0410 code causing high idle, poor fuel economy

Post by jreed » Sun Apr 21, 2019 6:42 am

A couple additional failure points to check in the automatic idle control area are the o-ring at the base of the vacuum tree (which could be cracked and leaking) and the IAC valve (could be stuck open).


1997 855 GLT (Light Pressure Turbo) still going strong. Previous: 1986 240 GL rusted out in '06, 1985 Saab 900T rusted out in '95, 1975 Saab 99 rusted out in '95, 1973 Saab 99 rusted out in '94

User avatar
RickHaleParker
Posts: 2832
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 312 times
United States of America
RickHaleParker

Re: 850 base 0410 code causing high idle, poor fuel economy

Post by RickHaleParker » Sun Apr 21, 2019 9:59 am

JimBee wrote:
Fri Apr 19, 2019 10:19 pm
But maybe with the diode fix it will be better. Onward and upward.
Eliminate known variables then see where you are at.
These users thanked the author RickHaleParker for the post:
jreed


Platform: P80 1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

JimBee
Posts: 1684
Joined: Tue Dec 09, 2008 9:23 pm
Year and Model:
Location:
Has thanked: 8 times
Been thanked: 16 times
JimBee

Re: 850 base 0410 code causing high idle, poor fuel economy

Post by JimBee » Sun Apr 21, 2019 8:04 pm

Good points! Radio Shacks were a great source for small electronic parts. They're all gone from the Twin Cities MN area now. Hopefully, a diode sourced from Walmart or online will be correct. What will happen if its properly identified but poorly made; does something fry?

What wattage irons do ppl use to do the solder? Do they use heat sinks and rosin core solder?



User avatar
RickHaleParker
Posts: 2832
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 312 times
United States of America
RickHaleParker

Re: 850 base 0410 code causing high idle, poor fuel economy

Post by RickHaleParker » Sun Apr 21, 2019 8:19 pm

15 Watt iron and Rosin core solder.
Diode: use a 1N4003 real cheap you can get a pack of 10 for ~$1.50 on eBay.

Clean the metal surface so you get a good bond.
Clip the end off the solder.
Heat the metal.
Remove heat.
Touch metal with solder.

You want to get the metal hot enough to melt and flow the solder but not hot enough to melt the plastics or cook the electronics.
A heatsink are not a bad idea. You could dig out your Roach clips and use them.


Platform: P80 1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

Post Reply