IPD sale Volvo Parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

HU650 Radio - Slow to get FM audio

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

iamhives
Posts: 15
Joined: Tue Oct 31, 2017 6:57 pm
Year and Model: 2006 V70 2.4 NA
Location: USA
Has thanked: 0
Been thanked: 1 time
United States of America
iamhives

HU650 Radio - Slow to get FM audio

Post by iamhives » Sun Apr 21, 2019 5:01 pm

I'm having trouble with the HU650 in my 2006 V70 2.4NA. The problem is the fact that when turning the input to FM it sometimes takes a while for there to be sound. This does not occur on the CD input, radio only. It seems to take longer when the car is just started and less time if run for a while and then the car stopped and started again. Sometimes I have to turn the unit on and off several times. So far it has eventually always finally come on. Its almost as if a capacitor is taking a while to charge-up and which doesn't need to charge-up as much if previously run. I don't know if there is a capacitor to cause this but that's just what it seems like. I have previously changed the unit (because the previous one would never tune in an FM station) - but I don't think the current problem is (or is it?) related because this replacement radio has worked fine for the past 2 years. Any ideas?

While I'm asking about the radio, I also have no sound out of the drivers side rear speaker. I suspect the wiring but haven't had the time to remove the speaker to try and troubleshoot. Is this something that could be caused by the head-unit for is it likely the wiring to this speaker or the speaker itself?



537playing
Posts: 233
Joined: Fri Jun 15, 2007 6:43 pm
Year and Model: 2005 S60
Location: New York
Has thanked: 0
Been thanked: 3 times
United States of America
537playing

Re: HU650 Radio - Slow to get FM audio

Post by 537playing » Sun Apr 21, 2019 5:12 pm

I replaced my radio with a rebuilt one. It was randomly changing stations and bands. My rear speaker also has issues so I’m interested what others post on this.



EngineeringBloke
Posts: 217
Joined: Sat Sep 08, 2012 7:31 pm
Year and Model: 2006 2.5T S60
Location: Boston
Has thanked: 28 times
Been thanked: 19 times
United States of America
EngineeringBloke

Re: HU650 Radio - Slow to get FM audio

Post by EngineeringBloke » Sun Apr 21, 2019 5:32 pm

Sorry, not sure about your slow radio issue, but with regard to the rear speakers...

Fazool wrote a post about Volvo stereo and it indicates the read door speakers are in parallel with the rear deck speakers. So do you have sound from the rear deck speakers - you may need to seat in the back seat to check, and set the fader to rear.
The rear door speakers are the same 6.5" 8-ohm full-range as the front door ones. These are wired in parallel to the 8-ohm rear deck speakers to create the 4-ohm impedance to each rear channel.
If the deck speakers are good, but rear door are not, then it is likely to be the rear door speaker or its wiring.

This is from:
https://www.matthewsvolvosite.com/forum ... 33&t=43215



iamhives
Posts: 15
Joined: Tue Oct 31, 2017 6:57 pm
Year and Model: 2006 V70 2.4 NA
Location: USA
Has thanked: 0
Been thanked: 1 time
United States of America
iamhives

Re: HU650 Radio - Slow to get FM audio

Post by iamhives » Sun Apr 21, 2019 5:44 pm

In my case it only the 2nd row drivers side speaker that is not working. The speakers near the rear hatch (V70) both work. If the V70 is like the S60 in the link with the 2nd row and deck/rear pillar wired in parallel it does suggest speaker or wiring. Can others confirm?



User avatar
RickHaleParker
Posts: 2761
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 305 times
United States of America
RickHaleParker

Re: HU650 Radio - Slow to get FM audio

Post by RickHaleParker » Sun Apr 21, 2019 5:58 pm

Sounds like a temperature sensitive component in the tuner. Goes out of spec when it is cooled off, goes back in spec after it gets warmed up.


Platform: P80 1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

iamhives
Posts: 15
Joined: Tue Oct 31, 2017 6:57 pm
Year and Model: 2006 V70 2.4 NA
Location: USA
Has thanked: 0
Been thanked: 1 time
United States of America
iamhives

Re: HU650 Radio - Slow to get FM audio

Post by iamhives » Mon Apr 22, 2019 6:46 am

Thanks, Yes, it does seem something like that hence my random guess along those lines of a capacitor - but obviously could be another component as you suggest. Almost every problem I've had with electronic equipment (from routers to DVD players etc etc) has been a bad capacitor. Any thoughts on how to identify the component? Since its only radio I assume that will help narrow in on the radio circuits. I'm pretty handy and fixed electronics before. Anyone know much about the internals of the HU650 before I just rip it apart to see if there is anything obvious like bad solder joints.



User avatar
RickHaleParker
Posts: 2761
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 305 times
United States of America
RickHaleParker

Re: HU650 Radio - Slow to get FM audio

Post by RickHaleParker » Mon Apr 22, 2019 10:30 am

I use to keep a cylinder of cylinder of refrigerant under the bench for this. You chill the suspected components. When you get the right one, the radio would quit working. You can get Freeze Spray in a rattle can but it is expensive ~$1.20 - $1.50 per OZ.


Platform: P80 1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

iamhives
Posts: 15
Joined: Tue Oct 31, 2017 6:57 pm
Year and Model: 2006 V70 2.4 NA
Location: USA
Has thanked: 0
Been thanked: 1 time
United States of America
iamhives

Re: HU650 Radio - Slow to get FM audio

Post by iamhives » Mon Apr 22, 2019 12:08 pm

The slight problem with this theory is that all was well over the winter in the cold weather and this only started happening the past few weeks as the weather warmed up. Doesn't rule it out obviously as it could be a coincidence but seems to make it slight less probable.



Post Reply