IPD sale Volvo Parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Headgasket done, rough idle now

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo XC90s. The XC90 proved to be very popular, and very good for Volvo's sales numbers, since its introduction in model year 2003 (North America).
Khorn09
Posts: 8
Joined: Tue Mar 26, 2019 2:28 pm
Year and Model: 03 xc90
Location: CA
Has thanked: 0
Been thanked: 0
United States of America
Khorn09

Headgasket done, rough idle now

Post by Khorn09 » Tue Apr 30, 2019 10:07 pm

Like my previous post say, I got this car with a blown head gasket and fixed that. Got it all put together finally and she runs! Runs good too when accelerating and holding speed. However when I'm at idle the engine will jerk from time to time. Like a misfire or something. It's really noticeable while in gear because the whole car will jerk a little when in drive at a stop, but if I put in neutral at a stop it seems much much smoother. Do you guys have any idea where I should start looking? I've read posts saying pcv system, o2 sensor, coils, throttle body. I'm just wondering if anyone has dealt with this symptom. The idle doesn't surge by jumping 200 rpm back and forth. When it's in park or neutral it holds pretty rock solid aside from that shake from time to time.

2.5t, aw55



User avatar
RickHaleParker
Posts: 2647
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 296 times
United States of America
RickHaleParker

Re: Headgasket done, rough idle now

Post by RickHaleParker » Tue Apr 30, 2019 11:24 pm

It is transmission related not engine related. Sticky shift solenoids can do this.
1. How does the transmission fluid look?
2. Fluid level good?

Things to try first:
1. Take it out for a long drive at highway speeds and see if it clears up.
2. Seafoam the transmission and run it for 500 - 1000 miles.
3. Change the transmission fluid.


Platform: P80 1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

User avatar
Roger_850T
MVS Moderator
Posts: 218
Joined: Tue Dec 31, 2013 11:55 am
Year and Model: 854T 1995
Location: Frederick MD
Has thanked: 0
Been thanked: 8 times
United States of America
Roger_850T

Re: Headgasket done, rough idle now

Post by Roger_850T » Sun May 05, 2019 4:39 pm

Any codes in ViDA? If it's misfiring, it might have set a code.

If you still get that occasional shake when it's at idle in neutral, then I would think probably not the transmission. Something is causing a misfire, and it's doing it when the transmission is not connected. Do you get the "occasional shake" if it's just idling in park? I think you probably feel it more when you're sitting at a traffic light, and there is a slight load on the engine from the transmission sitting there, in gear but stopped.

Does it do it when you are cruising down the freeway? Say holding a constant 60mph?

My first thought is that there is a vacuum leak somewhere, and at idle (high vacuum) it's going lean and misfiring occasionally. Could be where the manifold attaches to the head, or any of the vacuum hoses, or the O-rings where the fuel injectors go in. Or a vacuum elbow failed, or didn't get connected.

Roger


'05 XC90 V8 140k
'95 854T 310k
'02 V70 159k
'03 S80 111k (crashed)
'93 945T 217k (gone to be parted out)
'87 245 300k+ sold, still going
'84 264 Diesel, RIP at 160k
'78 242 manual everything.
'73 P1800ES, fun until the rust set in...

Khorn09
Posts: 8
Joined: Tue Mar 26, 2019 2:28 pm
Year and Model: 03 xc90
Location: CA
Has thanked: 0
Been thanked: 0
United States of America
Khorn09

Re: Headgasket done, rough idle now

Post by Khorn09 » Wed May 15, 2019 1:02 am

Hey guys, I got it all figured out. Turned out when I put the plugs back in after I got the head gasket done, I dropped the plugs down and smashed the electrodes down. Pulled the plugs and had 2 that I had to regap. God I felt like a rookie. After that it ran great, no misfires. Also, I forgot to plug in the exhaust cam sensor...doh! No more cel lights. I just did pcv oil trap. I get about 18 mpg, so I think it might have a bad flex pipe... causing it to run rich a little bit.

So I did the oil trap, and cleaned the oil drains on the block. I vacuumed the lower one and oil came up, so I know it's clear. I checked the lines to see if they were clear and they were. I cleared the banjo bolt as well. Put it all back together and it still puffs smoke from the oil cap when it's at idle. I didn't check the ptc valve so I think that might be my culprit. Anyways, me and the wife love the XC90. We drive it everywhere! Have some new strus coming in tomorrow too. So it'll be even better.

How long do I have to wait for the obdII to be ready for smog after I cleared the misfire codes? It needs smogged.



Post Reply