IPD sale Volvo Parts
XeMODeX - Experts in Volvo Electronics My Swedish Parts ad - genuine Volvo parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Air pump '98 S70

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

crlande
Posts: 242
Joined: Sat Jul 27, 2013 8:48 pm
Year and Model: 240DL;850;S70
Location: Lehigh Valley, PA
Has thanked: 0
Been thanked: 11 times
United States of America
crlande

Air pump '98 S70

Post by crlande » Thu May 02, 2019 12:23 pm

Hello,
Any theories on why the air pump would run for several seconds at a stop light or a similar situation on fully warmed up vehicle?
P0410 occasionally after it would run but no codes last couple days.
Thanks.



User avatar
RickHaleParker
Posts: 2832
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 312 times
United States of America
RickHaleParker

Re: Air pump '98 S70

Post by RickHaleParker » Thu May 02, 2019 1:53 pm

Flaky pump relay. Contacts shorting when coil not energized.
Pump +12V shorting to another +12V.
Relay coil +12V shorting to another +12V.


Platform: P80 1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

crlande
Posts: 242
Joined: Sat Jul 27, 2013 8:48 pm
Year and Model: 240DL;850;S70
Location: Lehigh Valley, PA
Has thanked: 0
Been thanked: 11 times
United States of America
crlande

Re: Air pump '98 S70

Post by crlande » Thu May 02, 2019 2:08 pm

That makes sense. Good place to start poking around, Thanks!



User avatar
erikv11
Posts: 9103
Joined: Sat Jul 25, 2009 2:03 pm
Year and Model: 850, S/V70, 06 S60R
Location: Iowa
Has thanked: 55 times
Been thanked: 189 times
United States of America
erikv11

Re: Air pump '98 S70

Post by erikv11 » Thu May 02, 2019 4:42 pm

That's completely normal, the air pump is supposed to come on occasionally at stop lights. This has been reported many times before for P80 cars and unless it is coming on all the time, there is nothing to check out (but checking is free and usually doesn't hurt things!).

About the P0410: you already know the pump works so I'd start by checking for vacuum leaks, or just by replacing all vacuum lines related to the SAS.


'95 854 T5-R, Motronic 4.4, 185k
'96 855 NA, 140k
'98 S70 NA, 210k (living out west)
'98 V70, T5 tune-injectors-turbo, LPT engine, 280k
'06 S60 R, 160k
gone: '96 NA 850 210k, '98 NA V70 182k

crlande
Posts: 242
Joined: Sat Jul 27, 2013 8:48 pm
Year and Model: 240DL;850;S70
Location: Lehigh Valley, PA
Has thanked: 0
Been thanked: 11 times
United States of America
crlande

Re: Air pump '98 S70

Post by crlande » Thu May 02, 2019 6:17 pm

Also sounds reasonable. I was fairly sure I have never heard either of the car's pumps come on after the initial start up phase. The occasional code must have made me keen on listening for it. Thanks.



User avatar
RickHaleParker
Posts: 2832
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 312 times
United States of America
RickHaleParker

Re: Air pump '98 S70

Post by RickHaleParker » Thu May 02, 2019 8:00 pm

The function of the SAS system is to burn off excess fuel from the rich starting Air/Fuel mixture and get the catalytic converter up to operating temperature. After that there is no reason for the pump to run. The pump running when it should not be running will trip P0410.

If it was not for the pump running when it should not be running, I would tell you look for leaks in the SAS system or defective valve.

If you monitor the input to the pump relay coil. Your be able to tell if the ECM is commanding the pump to turn on or if the power is coming from somewhere else.


Platform: P80 1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

User avatar
erikv11
Posts: 9103
Joined: Sat Jul 25, 2009 2:03 pm
Year and Model: 850, S/V70, 06 S60R
Location: Iowa
Has thanked: 55 times
Been thanked: 189 times
United States of America
erikv11

Re: Air pump '98 S70

Post by erikv11 » Thu May 02, 2019 11:20 pm

We can all agree with you RIck that it is not intuitive, but still it's normal behavior. People have posted about this many times over the years. These days many P80 owners just eliminate the air pump when P0410 pops up, so you need to look to the old posts,

e.g. from Moderator MadeInJapan and one other MVSer, pump running at stop lights without p0410: viewtopic.php?t=20348


'95 854 T5-R, Motronic 4.4, 185k
'96 855 NA, 140k
'98 S70 NA, 210k (living out west)
'98 V70, T5 tune-injectors-turbo, LPT engine, 280k
'06 S60 R, 160k
gone: '96 NA 850 210k, '98 NA V70 182k

User avatar
RickHaleParker
Posts: 2832
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 312 times
United States of America
RickHaleParker

Re: Air pump '98 S70

Post by RickHaleParker » Thu May 02, 2019 11:27 pm

Common and/or not unheard of does not make something normal, anymore then repeating something over and over make it so.


Platform: P80 1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

User avatar
abscate
MVS Moderator
Posts: 17920
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 193 times
Been thanked: 621 times
Trinidad & Tobago
abscate

Re: Air pump '98 S70

Post by abscate » Fri May 03, 2019 3:22 am

I would guess there is a Low voltages drop somewhere that is fooling the ECm into thinking it’s a new start cycle. The obvious correlation To a stop sign is the transition from alternator to battery’s voltage.

Can we agree it’s a common occurrence, without the judgemental “ normal” or “abnormal”?

From the thread above
Well, problem solved for now. After the tech used a Multi Tester Pro scanner with Volvo software to turn on the air pump manually in the test mode, it's been working ever since. I installed an LED across the pump relay coil to see when the relay picks up and it comes on always after a cold start and occasionally at a stop light. I also discovered something interesting - it apparently does not come on unless the car is (or has been) in motion. If I wait for it to come on in the garage before moving, it doesn't. That agrees with what the owners manual says about the pump, that it comes on when the engine is cold and the car is in motion.

Thanks for the suggestions. :D
Wow. This one is complicated. ECM is taking inputs of temp, speed, mixture, closed loop?


Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW

User avatar
RickHaleParker
Posts: 2832
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 312 times
United States of America
RickHaleParker

Re: Air pump '98 S70

Post by RickHaleParker » Fri May 03, 2019 4:08 am

abscate wrote:
Fri May 03, 2019 3:22 am
Can we agree it’s a common occurrence, without the judgemental “ normal” or “abnormal”?
Clearly not unheard of but not enough data to declare it common.

You might be on to something, I have seen startup routines triggered by a brown out.


Platform: P80 1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

Post Reply