IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

2008 S40 Key FOB issues and starting

Help, Advice, Owners' Discussion and DIY Tutorials devoted to the second generation C70, S40 and V50 Volvos -- awkwardly model year 2004 ½ onwards -- plus where to go for advice and discussion on Volvo's sporty C30 Coupe powered by Volvo's ubiquitous inline 5-cylinder power plant.
Smith14333
Posts: 3
Joined: Thu May 16, 2019 10:18 pm
Year and Model: 2008 S40
Location: Texas
Has thanked: 0
Been thanked: 0
United States of America
Smith14333

2008 S40 Key FOB issues and starting

Post by Smith14333 » Thu May 16, 2019 10:30 pm

Hey everyone,

My wife recently starting having issues with her ‘08 S40. About 2 months ago, the keyfob stopped unlocking the car and the only way to unlock it is manually using the key which sets off the alarm once the door is opened. Putting the key fob in the ignition and turning it to the ‘run’ position silences it. I took the computer out from under the glovebox and cleaned all the connections, however the issue remained. I’ve heard that the problem could be with the receiver. The dealer wants $500 to even look at it.

Now a new issue has occurred. While driving, the vehicle stopped accelerating and the gas pedal become unresponsive. The car coasted to a stop however continued to run. I tried turning it off and turning it on again, however it would not start and has not since. It cranks and I can smell fuel, however it never starts. I am thinking it is either an ignition problem, or the key fob causing more issues. Also, the key fob still has the same issue, it doesn’t work to lock/unlock the doors and I still have to use the manual key and set off the alarm.

Any help is welcomed, really not looking forward to getting robbed by the dealer



User avatar
RickHaleParker
Posts: 3212
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 374 times
United States of America
RickHaleParker

Re: 2008 S40 Key FOB issues and starting

Post by RickHaleParker » Fri May 17, 2019 2:44 am

Change the battery in the fob.


Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0,
Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

Smith14333
Posts: 3
Joined: Thu May 16, 2019 10:18 pm
Year and Model: 2008 S40
Location: Texas
Has thanked: 0
Been thanked: 0
United States of America
Smith14333

Re: 2008 S40 Key FOB issues and starting

Post by Smith14333 » Fri May 17, 2019 7:50 am

I’ve changed the battery in the FOB with no change to the issues



Post Reply
  • Similar Topics
    Replies
    Views
    Last post