IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

07 S40 Stalling / Rough Idle after PCV replacement (P0101 code)

Help, Advice, Owners' Discussion and DIY Tutorials devoted to the second generation C70, S40 and V50 Volvos -- awkwardly model year 2004 ½ onwards -- plus where to go for advice and discussion on Volvo's sporty C30 Coupe powered by Volvo's ubiquitous inline 5-cylinder power plant.
07VolvoS40Guy
Posts: 1
Joined: Tue May 21, 2019 9:26 am
Year and Model: 07 S40
Location: Maine, USA
Has thanked: 0
Been thanked: 0
United States of America
07VolvoS40Guy

07 S40 Stalling / Rough Idle after PCV replacement (P0101 code)

Post by 07VolvoS40Guy » Tue May 21, 2019 10:10 am

Hello Everyone!

I wanted to know if anyone has an answer to what may be causing an 07 volvo s40 Turbo model to stall intermittently during idle.

Some days it will just sputter a bit then once it warms up it runs great, and wont stall if left idling once warm.

Other days it will stall out, I may have to rev it to around 2000 rpms after starting it back up, then I can drive it but for two minutes usually it sputters a bit.

Almost like the fuel is on, off, on, off then it finally goes good.

I wanted to provide a thread from another forum, where the user has a ton more information, and is experiencing the same issue.

We are both trying to fix this, now roping in multiple forums to make sure we get all of the best minds on this issue.

So Far I have replaced the PCV, Antifreeze in and out line, as well as the antifreeze to the tranny line (They were all leaking), a new antifreeze resiviour (cracked under pressure), and a new mass air flow sensor (Getting a P0101 code, and a system running too rich, and system running to lean codes)

My garage has done a smoke test, but to no resolution.

I am running out of money fast!

I heard it could be a fuel pressure sensor, or a fuel pressure regulator, but I have no idea where that may be in my engine (If you know or can provide pics please help)

The listing to the forum with a ton of information on this issue is here:
https://forums.swedespeed.com/showth...-(p0101)/page6


Please help me as I am out of sick time at work, and if I am even a second late I lose my job. I fear I am going to start it up one of these mornings and it will stall out for good .

(Car has 186,000 miles, but runs like a top when it is running good, 0 rust)

Thanks guys!



User avatar
RickHaleParker
Posts: 3211
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 374 times
United States of America
RickHaleParker

Re: 07 S40 Stalling / Rough Idle after PCV replacement (P0101 code)

Post by RickHaleParker » Tue May 21, 2019 11:48 am

P0101 = ECM-130A Mass air flow (MAF) sensor, Faulty signal.

Possible source
Contact resistance in the connector
Damaged fresh air intake hose
Dirty mass air flow (MAF) sensor.
Damaged mass air flow (MAF) sensor.

Clean the MAF connector and MAF sensor with MAF cleaner.
Check the air hoses for leaks.

If that does not do it, replace the MAF sensor.


Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0,
Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

Post Reply
  • Similar Topics
    Replies
    Views
    Last post