IPD sale Volvo Parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Advice please tranmission not engaging

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

Onenone
Posts: 2
Joined: Sat May 25, 2019 6:32 pm
Year and Model: 2000 v70 2.5lt 5cyl
Location: QLD
Has thanked: 0
Been thanked: 0
Australia
Onenone

Advice please tranmission not engaging

Post by Onenone » Sat May 25, 2019 6:48 pm

Hi...great site here!
I recently had the flashing arrow and p0740 obd2 code...though unlike most people with that my car (2000 v70 2.5 lt non turbo) stopped and the transmission wont engage at all.I didn't hear any crunching mechanical or weird smells....
I have cleaned the pnp switch and adjusted it and don't get the code anymore so I'm guessing it's ok now.
But I still don't get anything when accelerating.
Easiest things to try next I'm assuming is drain and flush trans oil, but could that really cause this??? Oil looks not terrible, faint burnt smell according to my friend(I couldn't smell it) and level is fine.
I got the impression there is not transmission oil pump on these cars.
After that I'm lead to believe it may be a solenoid and too expensive to fix.
Not sure if the reason it won't drive is a sensor/electrical or mechanical issue, so I'm unsure how to continue.
Any leads or advice greatly appreciated Thanks!



tardcart
Posts: 411
Joined: Fri Feb 08, 2019 4:17 pm
Year and Model: 96 850t. 93 940t
Location: Pittstown Nj
Has thanked: 3 times
Been thanked: 36 times
United States of America
tardcart

Re: Advice please tranmission not engaging

Post by tardcart » Sat May 25, 2019 7:49 pm

most cases of no drive are either burnt clutches or open solenoids. burnt clutches are caused by driving in limp mode which is third gear due to some idiot at Volvo. this is usually from a PNP switch in cold weather error. sticky solenoids happen any time and the car won't move. neither will resolve them selves unless the code is erased. I keep a cheap scanner in the car in case this happens. do not sit not side of the road and rev the engine hoping to get home. If you don't have a scanner disconnect the battery and that might work. 3 months ago Im leaving to get kid to school and arrow and no drive. cleared code and off and running problem since. so you have to decide if you burnt the clutch pack in limp mode or just need to clear code and change fluid.



Onenone
Posts: 2
Joined: Sat May 25, 2019 6:32 pm
Year and Model: 2000 v70 2.5lt 5cyl
Location: QLD
Has thanked: 0
Been thanked: 0
Australia
Onenone

Re: Advice please tranmission not engaging

Post by Onenone » Sat May 25, 2019 9:12 pm

Thanks for the reply...
Yeah I kept driving it after the flashing arrow came on as I was half way up the mountain I live on and couldnt stop anywhere. It got to the top and it stopped. I don't have the code now after clearing it and cleaning the switch but no gears. I disconnected the battery then...
So maybe worth flushing the transmission and giving up if that doesn't fix It? Will that fix the burnt clutch pack you mentioned?
Is the solenoid a big job id be able to do (have most tools)?
I can't afford to get it somewhere for a specialist to fix it...
Thanks again



tardcart
Posts: 411
Joined: Fri Feb 08, 2019 4:17 pm
Year and Model: 96 850t. 93 940t
Location: Pittstown Nj
Has thanked: 3 times
Been thanked: 36 times
United States of America
tardcart

Re: Advice please tranmission not engaging

Post by tardcart » Sun May 26, 2019 6:21 am

I would keep an eye out for a used transmission. I haven't done the job but am told removing the valve body is as much work as changing the trans and much less likely to solve the problem.



precopster
Posts: 7423
Joined: Sat Aug 21, 2010 12:20 am
Year and Model: Lots
Location: Melbourne Australia
Has thanked: 4 times
Been thanked: 94 times
Australia
precopster

Re: Advice please tranmission not engaging

Post by precopster » Sun May 26, 2019 7:05 am

Is that the 2000-2007 body or the last build of the P80s? We got the P2s a little early down under in case anyone's wondering why I ask..

Can you hear a whine coming from under the bonnet when you rev in P ?


Current cars:2002 XC70, 2006 Ssangyong Rodius (Stavic), 2006 XC90 2.5T, VW Transporter 2.5TDI

www.precisioncarmodules.com.

Post Reply