IPD sale Volvo Parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Fixing the server...

Come on in, introduce yourself and say hi! List Volvo events here. Have a hot Volvo? Show it off here.
User avatar
matthew1
Site Admin
Posts: 9794
Joined: Sat Sep 14, 2002 11:03 am
Year and Model: 850 T5, 1997
Location: Denver, Colorado, US
Has thanked: 358 times
Been thanked: 136 times
United States of America
matthew1

Fixing the server...

Post by matthew1 » Mon Jun 10, 2019 11:18 am

Hello gents and the few ladies who frequent MVS.

Sorry for the recent downtime. As a backup way of communicating, I use https://www.facebook.com/groups/matthewsvolvo/ and https://www.facebook.com/MatthewsVolvoSite/.

So what's going on? Short answer: I'm moving the site from Dreamhost (Los Angeles) to Google Cloud (Iowa, in this case).

Why? Short answer: Dreamhost server failed Friday morning, and has been unreachable via any method. DH customer service essentially said, and I'm taking great liberties here, that the Cloud VPS team was off over the weekend, and I'd have to wait. It's the third major fail in 3 months, after 1.5 years of smooth operation. All good things must come to an end? :?

Long answer: (coming up)


Help keep MVS on the web -> click sponsors' links here on MVS when you buy from them.
Also -> Amazon link
. Click that when you go to buy something on Amazon and MVS gets a kickback.

1997 850 T5, MSD ignition coil, Hallman manual boost controller, injectors, R bumper, OMP strut brace [gone]
2004 V70 R [gone]

User avatar
matthew1
Site Admin
Posts: 9794
Joined: Sat Sep 14, 2002 11:03 am
Year and Model: 850 T5, 1997
Location: Denver, Colorado, US
Has thanked: 358 times
Been thanked: 136 times
United States of America
matthew1

Re: Fixing the server...

Post by matthew1 » Mon Jun 10, 2019 10:09 pm

Silver lining: the site is as fast as it's ever been. Page load times are bananas fast from Denver. Also, I learned why the server migration I attempted in March https://www.matthewsvolvosite.com/forum ... =4&t=88936 failed. I didn't change any of MySQL's stock settings. Stock settings are terrrrrible for a big forum.

Right now I'm backfilling forum attachments and indexing the forum to build the forum search index.


Help keep MVS on the web -> click sponsors' links here on MVS when you buy from them.
Also -> Amazon link
. Click that when you go to buy something on Amazon and MVS gets a kickback.

1997 850 T5, MSD ignition coil, Hallman manual boost controller, injectors, R bumper, OMP strut brace [gone]
2004 V70 R [gone]

850 LPT
Posts: 1104
Joined: Fri May 27, 2011 8:05 am
Year and Model: 96' 850
Location: CT
Has thanked: 37 times
Been thanked: 30 times
United States of America
850 LPT

Re: Fixing the server...

Post by 850 LPT » Tue Jun 11, 2019 9:17 am

Hi Matt,

I was trying to upload photos this morning and got an error message that didn't make sense to me.
But I'm sure the fact that you are currently working on it has something to do with it.

Great job with the new server! I like the speed of it!

Thanks, Dirk


96' 850 sedan, base, auto, pewter/charcoal, 106k miles
99' S70, base, 5-speed manual, nautic blue/ tan, 209k miles
04' V70, auto, ash gold/ tan, 222k miles
05' V70, 5-speed manual, loaded, mistral green/ tan, 142k miles
79' Ford Capri S, Euro Spec 2.8 V6, T9 5-speed manual
58' Porsche Diesel Junior
13' Honda Odyssey :oops:

User avatar
matthew1
Site Admin
Posts: 9794
Joined: Sat Sep 14, 2002 11:03 am
Year and Model: 850 T5, 1997
Location: Denver, Colorado, US
Has thanked: 358 times
Been thanked: 136 times
United States of America
matthew1

Re: Fixing the server...

Post by matthew1 » Tue Jun 11, 2019 9:33 am

Dirk, thanks for the heads up on that. I appreciate it. I'll do an upload test and contact you offline.

The speed is good huh?

Here's a chart from Google Analytics of a particularly good metric. The other speed metrics should improve as the server caches content as its requested.
server-speed.png
server-speed.png (13.88 KiB) Viewed 683 times


Help keep MVS on the web -> click sponsors' links here on MVS when you buy from them.
Also -> Amazon link
. Click that when you go to buy something on Amazon and MVS gets a kickback.

1997 850 T5, MSD ignition coil, Hallman manual boost controller, injectors, R bumper, OMP strut brace [gone]
2004 V70 R [gone]

prwood2
Posts: 2
Joined: Tue Jun 11, 2019 8:12 am
Year and Model: 2001 V70 2.4T
Location: Salem, MA
Has thanked: 0
Been thanked: 0
prwood2

Re: Fixing the server...

Post by prwood2 » Tue Jun 11, 2019 12:18 pm

matthew1 wrote: ↑
Mon Jun 10, 2019 10:09 pm
Silver lining: the site is as fast as it's ever been. Page load times are bananas fast from Denver. Also, I learned why the server migration I attempted in March https://www.matthewsvolvosite.com/forum ... =4&t=88936 failed. I didn't change any of MySQL's stock settings. Stock settings are terrrrrible for a big forum.

Right now I'm backfilling forum attachments and indexing the forum to build the forum search index.
Just a heads-up that I sent you a few more messages on the MVS Facebook Messenger. If there's a better way to DM you, let me know. I was able to create this 'prwood2' account and log in, but as soon as I log out of it and try to log back in to my prwood account, I get a blank page and HTTP response code 500. This happens regardless of browser or type of device. There must be something sticking around from the old system that's specific to my account. Hopefully we can get prwood back up and running...



User avatar
matthew1
Site Admin
Posts: 9794
Joined: Sat Sep 14, 2002 11:03 am
Year and Model: 850 T5, 1997
Location: Denver, Colorado, US
Has thanked: 358 times
Been thanked: 136 times
United States of America
matthew1

Re: Fixing the server...

Post by matthew1 » Tue Jun 11, 2019 12:32 pm

What’s your region? Can you try a different ISP/gateway?


Help keep MVS on the web -> click sponsors' links here on MVS when you buy from them.
Also -> Amazon link
. Click that when you go to buy something on Amazon and MVS gets a kickback.

1997 850 T5, MSD ignition coil, Hallman manual boost controller, injectors, R bumper, OMP strut brace [gone]
2004 V70 R [gone]

User avatar
matthew1
Site Admin
Posts: 9794
Joined: Sat Sep 14, 2002 11:03 am
Year and Model: 850 T5, 1997
Location: Denver, Colorado, US
Has thanked: 358 times
Been thanked: 136 times
United States of America
matthew1

Re: Fixing the server...

Post by matthew1 » Tue Jun 11, 2019 12:41 pm

Best way to DM me is email [email protected]


Help keep MVS on the web -> click sponsors' links here on MVS when you buy from them.
Also -> Amazon link
. Click that when you go to buy something on Amazon and MVS gets a kickback.

1997 850 T5, MSD ignition coil, Hallman manual boost controller, injectors, R bumper, OMP strut brace [gone]
2004 V70 R [gone]

prwood2
Posts: 2
Joined: Tue Jun 11, 2019 8:12 am
Year and Model: 2001 V70 2.4T
Location: Salem, MA
Has thanked: 0
Been thanked: 0
prwood2

Re: Fixing the server...

Post by prwood2 » Tue Jun 11, 2019 1:00 pm

Now I'm getting a 500 error on user prwood2 when I try to quote-reply your post above (with this url: https://www.matthewsvolvosite.com/forum ... 0&p=510133).



User avatar
matthew1
Site Admin
Posts: 9794
Joined: Sat Sep 14, 2002 11:03 am
Year and Model: 850 T5, 1997
Location: Denver, Colorado, US
Has thanked: 358 times
Been thanked: 136 times
United States of America
matthew1

Re: Fixing the server...

Post by matthew1 » Tue Jun 11, 2019 2:03 pm

Arg!! I upset the apple cart. Working to restore the apple cart.


Help keep MVS on the web -> click sponsors' links here on MVS when you buy from them.
Also -> Amazon link
. Click that when you go to buy something on Amazon and MVS gets a kickback.

1997 850 T5, MSD ignition coil, Hallman manual boost controller, injectors, R bumper, OMP strut brace [gone]
2004 V70 R [gone]

User avatar
matthew1
Site Admin
Posts: 9794
Joined: Sat Sep 14, 2002 11:03 am
Year and Model: 850 T5, 1997
Location: Denver, Colorado, US
Has thanked: 358 times
Been thanked: 136 times
United States of America
matthew1

Re: Fixing the server...

Post by matthew1 » Tue Jun 11, 2019 2:08 pm

Wow, got my fingers burned trying to restore the forum extensions like Similar Topics, National Flags and a handful of others. Sorry about that.

Any misstep here is a potential mine.


Help keep MVS on the web -> click sponsors' links here on MVS when you buy from them.
Also -> Amazon link
. Click that when you go to buy something on Amazon and MVS gets a kickback.

1997 850 T5, MSD ignition coil, Hallman manual boost controller, injectors, R bumper, OMP strut brace [gone]
2004 V70 R [gone]

Post Reply