IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

When it rains it pours

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

markopolo
Posts: 2
Joined: Wed Jun 19, 2019 11:48 am
Year and Model: 2006 XC70
Location: zip 16440
Has thanked: 0
Been thanked: 0
United States of America
markopolo

When it rains it pours

Post by markopolo » Wed Jun 19, 2019 12:08 pm

Hi Newbie here
OK so I have a 2006 Volvo XC70. Vehicle has about 225K miles. Treated well. OK so about a month and half ago started having problem where starter would not engage when key turned to start position. I believe I have diagnosed this to be the corroded wire clip to the starter as identified by another person. This problem has not been fixed yet but will be shortly

OK onto the new problem that just started. When I turn the key to the aux position (and this seems only to be when raining or very humid) the DIM becomes erratic with spedo and RMP gauage moving and just about every message indicator going on and off. When I try to start the engine turns but does not start. I have a video but not sure how to load it.

Any thoughts and help appreciated.

Many thanks
Mark



User avatar
oragex
Posts: 4311
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 82 times
Been thanked: 189 times
Contact:
Canada
oragex

Re: When it rains it pours

Post by oragex » Wed Jun 19, 2019 2:07 pm

Hello
For the weirdo gauges, use a voltmeter and test the alternator and the battery. At idle it should look 13.5v-14.5v (depending whether the battery is being charged or is already fully charged)



markopolo
Posts: 2
Joined: Wed Jun 19, 2019 11:48 am
Year and Model: 2006 XC70
Location: zip 16440
Has thanked: 0
Been thanked: 0
United States of America
markopolo

Re: When it rains it pours

Post by markopolo » Wed Jun 19, 2019 5:31 pm

Will do. Also if I have a faulty coil pack could that be a cuase of the issue as weeel?



User avatar
- Pete -
Posts: 158
Joined: Fri Dec 06, 2013 10:13 pm
Year and Model: 01, 04, 04, 06 V70's
Location: Minnesota/Wisconsin
Has thanked: 15 times
Been thanked: 24 times
United States of America
- Pete -

Re: When it rains it pours

Post by - Pete - » Wed Jun 19, 2019 10:33 pm

markopolo wrote:
Wed Jun 19, 2019 12:08 pm
... starter would not engage when key turned to start position. I believe I have diagnosed this to be the corroded wire clip to the starter as identified by another person....

Many thanks
Mark
Does the starter motor spin, but not engage with the flywheel?
Or does the starter motor not spin at all when called upon?
The way you worded it, it could be misconstrued 1-2 different ways.


Our 06 recently did something similar to what you're describing, about it cranking but not firing. I replied to somebody else's post in regards to it a few months back. Here's what I posted. By the way, that red blurry thing in the picture is the pull for the oil dipstick.

viewtopic.php?f=9&t=87155&p=486462#p486462


2001 V70XC 135k
2004 V70 AWD 130k
2004 XC70 278k
2006 XC70 150k

User avatar
abscate
MVS Moderator
Posts: 18194
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 200 times
Been thanked: 647 times
Trinidad & Tobago
abscate

Re: When it rains it pours

Post by abscate » Thu Jun 20, 2019 8:10 am

markopolo wrote:
Wed Jun 19, 2019 5:31 pm
Will do. Also if I have a faulty coil pack could that be a cuase of the issue as weeel?
No, a coil pack won’t impact the cranking part of the starter nor the instrument cluster.


Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW

Post Reply