IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

1999 v70 NA stalls, no codes [ bad MAP vacuum hose] Topic is solved

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

Dimi2233
Posts: 10
Joined: Mon Sep 12, 2016 7:29 pm
Year and Model: 1999 V70
Location: Suunyvale CA
Has thanked: 0
Been thanked: 1 time
United States of America
Dimi2233

1999 v70 NA stalls, no codes [ bad MAP vacuum hose]  Topic is solved

Post by Dimi2233 » Mon Jul 01, 2019 6:23 pm

Hello Volvo Forum
I have Volvo 1999 , V70 2'4 l. , At low speed on Parking Lot RPM Indicator starti bouncing up and down, when I put in Parking gear ,The Engine STOP with three light on Battery, Oll Pressure ,D 2 Arrow
No code Store on History.
Somebody know what cam be the problem,
Thanks Dimi



Dimi2233
Posts: 10
Joined: Mon Sep 12, 2016 7:29 pm
Year and Model: 1999 V70
Location: Suunyvale CA
Has thanked: 0
Been thanked: 1 time
United States of America
Dimi2233

Re: No code store,I can Start but do not run Stop with 3 light on

Post by Dimi2233 » Tue Jul 16, 2019 8:58 pm

The problem was leaking vacuum hose between Manifold and pressure switch on top off Radiator.

David
These users thanked the author Dimi2233 for the post:
abscate



User avatar
abscate
MVS Moderator
Posts: 18203
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 200 times
Been thanked: 647 times
Trinidad & Tobago
abscate

Re: No code store,I can Start but do not run Stop with 3 light on

Post by abscate » Wed Jul 17, 2019 3:43 am

Thanks for the report back David. I’m guessing you have a base non Turbo model 1999?

That’s hose usually pops a code for the pressure sensor reading off thehose leaks.


Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW

User avatar
greg850r
Posts: 206
Joined: Thu May 03, 2012 5:06 pm
Year and Model: a long list
Location: Mo
Has thanked: 2 times
Been thanked: 8 times
United States of America
greg850r

Re: 1999 v70 NA stalls, no codes [ bad MAP vacuum hose]

Post by greg850r » Wed Jul 17, 2019 1:01 pm

If you don't want to chase similar problems going forward, buy a silicone hose kit from one of the sponsors at the top of this page and start replacing them all. it's 20 years old and the one that failed is the tip of the iceberg.


05 Cross Country wagon
99 C70 Convertible
96 850R wagon
96 850T wagon
96 850 GLT 5spd N/A sedan
97 850R 5spd sedan
66 GTO 421SD 4spd
67 GTO 455 T400
02 Powerstroke 4x4
85 Yota 4x4
24' 454 Challenger
07 Softail Custom
02 Sportster Custom
Parts cars not included

Post Reply