IPD sale Volvo Parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

2011 XC70 backup camera

Help, Advice, Owners' Discussion and DIY Tutorials on the third generation Volvo V70 wagon and XC70 crossover, and second generation S80. Are you an owner? Prospective owner? Get in here and join us! Start a new topic or comment on an existing thread.

2008-2016 V70
2008-2016 XC70
2007-2016 S80

babybluebug
Posts: 7
Joined: Fri Apr 27, 2018 12:44 pm
Year and Model: 2004 v70
Location: Maine
Has thanked: 0
Been thanked: 0
United States of America
babybluebug

2011 XC70 backup camera

Post by babybluebug » Wed Jul 03, 2019 4:58 am

I have an XC70 with the complete tech package w/ about 82k miles. Mysteriously, The back up camera no longer engages when car is put into reverse. Dash screen stays in map/ NAV mode.

I have gone thru menu / settings mode and all looks okay.

Camera does not engage at all. No screen change or flicker, etc.

Back-up sensors (audible beeping) are still working.

Any suggestions on how to fix this problem? Thanks.



jimmy57
Posts: 6250
Joined: Fri Nov 12, 2010 9:25 am
Year and Model: 2004 V70R GT, et al
Location: Ponder Texas
Has thanked: 2 times
Been thanked: 149 times
jimmy57

Re: 2011 XC70 backup camera

Post by jimmy57 » Wed Jul 03, 2019 7:36 am

This sounds familiar. I had a 2012 P3 do that and I think the fix was to put it in reverse and hit the camera button. There was not a setting for it that I remember finding but I found some info as to how it could be turned off and on. The backup camera can't be turned off after 2013 or 2014 when it became legally required in this market.



babybluebug
Posts: 7
Joined: Fri Apr 27, 2018 12:44 pm
Year and Model: 2004 v70
Location: Maine
Has thanked: 0
Been thanked: 0
United States of America
babybluebug

Re: 2011 XC70 backup camera

Post by babybluebug » Wed Jul 10, 2019 8:37 am

On my XC70 2011 T6, I do not have a camera button on the console (at least that I can find). Any idea if there is another way to turn on/ off the camera?

When in reverse, I am no longer getting any camera screen view. Screen stays in NAV / map mode. No flicker, blank screen etc.

As mentioned, I have gone thru the menu/ settings mode and confirmed proper settings. Thanks.



Post Reply