IPD sale Volvo Parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

1995 Volvo 850 Turbo not running.

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

jusair
Posts: 4
Joined: Sat Apr 20, 2019 6:23 pm
Year and Model: 1995 850 turbo wagon
Location: California
Has thanked: 0
Been thanked: 0
United States of America
jusair

1995 Volvo 850 Turbo not running.

Post by jusair » Sun Jul 07, 2019 7:17 pm

Hello all,
I have a 1995 volvo 850 turbo wagon with 95,xxx miles on it. I bought the car in a non running state. Previous owner said that the car wasn't getting fuel. After having the car for a couple of weeks I did a full stage 0 on it and I still have a no start condition. I am getting good spark, and good fuel pressure, 44+ psi at the rail. It has new spark plugs and wires, cam sensor, crank sensor, fuel pump, fuel filter, pcv system, fuel injectors, injector relay, maf sensor, and ect sensor. I even have a spare ecu from a matching model and year car. I might be forgetting a few items that I replaced. Fuel pump stays on while cranking getting 44 psi confirmed with a fuel pressure gauge. When I remove the fuel pump relay, the car starts right up and then dies when the excess fuel is burned up. The car also stays running and revs up while using started fluid to start it and keep it running without fuel. There is also no check engine light on. Any help will be appreciated, thank you.



tardcart
Posts: 411
Joined: Fri Feb 08, 2019 4:17 pm
Year and Model: 96 850t. 93 940t
Location: Pittstown Nj
Has thanked: 3 times
Been thanked: 36 times
United States of America
tardcart

Re: 1995 Volvo 850 Turbo not running.

Post by tardcart » Sun Jul 07, 2019 8:34 pm

you describe excess fuel situation. leaking injector. you can remove harness from each injector till it runs to find which.



jusair
Posts: 4
Joined: Sat Apr 20, 2019 6:23 pm
Year and Model: 1995 850 turbo wagon
Location: California
Has thanked: 0
Been thanked: 0
United States of America
jusair

Re: 1995 Volvo 850 Turbo not running.

Post by jusair » Mon Jul 08, 2019 9:08 am

I have tried disconnecting the Injectors but there was no change. Still not starting. Maybe most of the 5 Injextors are leaking?



tardcart
Posts: 411
Joined: Fri Feb 08, 2019 4:17 pm
Year and Model: 96 850t. 93 940t
Location: Pittstown Nj
Has thanked: 3 times
Been thanked: 36 times
United States of America
tardcart

Re: 1995 Volvo 850 Turbo not running.

Post by tardcart » Mon Jul 08, 2019 10:42 am

pull off the whole rail and set it over a pan. turn on ignition but do not crank and observe if any leak. dont bother spry testing them as you are looking for too much fuel not too little and you might cause a fire. but before this step, put a clear clean plastic bottle on the gas line at the rail and pump it full and observe it for yellow, bad smell or water on the bottom. You may have the right amount of fuel but bad fuel sitting so long. If its bad keep pumping all the fuel out.



jusair
Posts: 4
Joined: Sat Apr 20, 2019 6:23 pm
Year and Model: 1995 850 turbo wagon
Location: California
Has thanked: 0
Been thanked: 0
United States of America
jusair

Re: 1995 Volvo 850 Turbo not running.

Post by jusair » Mon Jul 08, 2019 11:12 am

Okay I will try doing that tonight. And I have already gotten the old fuel out of the tank and poured fresh gas into it. I will try the injectors over the pan thanks.



jusair
Posts: 4
Joined: Sat Apr 20, 2019 6:23 pm
Year and Model: 1995 850 turbo wagon
Location: California
Has thanked: 0
Been thanked: 0
United States of America
jusair

Re: 1995 Volvo 850 Turbo not running.

Post by jusair » Wed Jul 10, 2019 9:09 pm

So the injectors were leaking, 4 of them, so I got remanufactured oem ones. Put them in and the car started right up and sounded and ran great. I wasn't able to rev the engine past 4k rpm because it started to breakup as if it was misfiring. So I left it idling for about 30 minutes and was running great other than the 4k rpm hesitation.
Went back the next day and back to a no start again. The car cranks and sounds like its about to catch but never fires back up. Checked the injectors again and they wernt leaking. Fuel pressure was still there as well. Any ideas on what could have happened?



tardcart
Posts: 411
Joined: Fri Feb 08, 2019 4:17 pm
Year and Model: 96 850t. 93 940t
Location: Pittstown Nj
Has thanked: 3 times
Been thanked: 36 times
United States of America
tardcart

Re: 1995 Volvo 850 Turbo not running.

Post by tardcart » Thu Jul 11, 2019 5:10 am

I'm worried about the quality and filtering of your fuel. crap/water is clogging up the injectors. Just detach the pressure lead at the rail and put a hose on it and turn the key to position 2 and pump it all out. replace the filter. (again)



Post Reply