IPD sale Volvo Parts
XeMODeX - Experts in Volvo Electronics My Swedish Parts ad - genuine Volvo parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Manufacturers defect? Topic is solved

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

MDK
Posts: 446
Joined: Sun Apr 08, 2018 5:43 pm
Year and Model: 1998 xc 70
Location: Ohio
Has thanked: 0
Been thanked: 27 times
United States of America
MDK

Manufacturers defect?  Topic is solved

Post by MDK » Mon Jul 15, 2019 4:11 am

Hey all...so I'm having trouble with the reservoir that I bought from IPD. it's a Behr unit. You know I thought I have a bad coolant temp sensor..so yesterday I got another one from the scrap yard. Last night as I was changing it...I was lazy and didn't drain anything...I just got a towel and put it underneath. I didn't realize it at first but when I pulled it out..no antifreeze came out and I put the new one in. But shouldn't it have?



User avatar
E Showell
Posts: 2722
Joined: Thu Oct 16, 2008 4:00 pm
Year and Model: V70R '06 AWD Auto
Location: Long Valley, N.J.
Has thanked: 4 times
Been thanked: 29 times
United States of America
E Showell

Re: Manufacturers defect?

Post by E Showell » Mon Jul 15, 2019 4:39 am

Question is unclear. Should coolant come out of the reservoir, or should it have come out of the thermostat housing. Not clear whether you are replacing the coolant reservoir or the engine coolant temperature sensor from your post.


'98 V70 NA FWD 5 spd, silver sand metallic (sold)
'99 V70 NA FWD Auto, dark blue (soon to be for sale)
'99 S70 NA FWD Auto, black (sold and resurrected)
'07 S80 3.2 FWD Auto, Barents Blue Metallic
'06 V70 R AWD Auto, Sonic Blue Metallic
'04 XC70 Ruby Red Metallic

User avatar
abscate
MVS Moderator
Posts: 17910
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 192 times
Been thanked: 620 times
Trinidad & Tobago
abscate

Re: Manufacturers defect?

Post by abscate » Mon Jul 15, 2019 4:42 am

If you were replacing the coolant level sensor on the reservoir , it is magnetic and works throughout the plastic, so no coolant touches it nor will leak when it is pulled.


Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW

MDK
Posts: 446
Joined: Sun Apr 08, 2018 5:43 pm
Year and Model: 1998 xc 70
Location: Ohio
Has thanked: 0
Been thanked: 27 times
United States of America
MDK

Re: Manufacturers defect?

Post by MDK » Mon Jul 15, 2019 4:55 am

Ah... abscate. Now I get it .. magnetic. I guess I'll get another sensor... again. Thanks man.. the dude abides...



Post Reply