IPD sale Volvo Parts
XeMODeX - Experts in Volvo Electronics My Swedish Parts ad - genuine Volvo parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Volvo 850 strange boost problem

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

Jaumme
Posts: 33
Joined: Sat Jan 19, 2019 2:50 am
Year and Model: Volvo 850 T5 1993
Location: Valencia
Has thanked: 0
Been thanked: 1 time
Spain
Jaumme

Volvo 850 strange boost problem

Post by Jaumme » Mon Jul 15, 2019 11:14 am

My '93 volvo 850 t5 is doing some weird things when i go full throttle, it boost ok till 3/4 of the white lane on the boost gauge and then the boost comes down to the half of the white lane till 5000 rpm, at 5k rpm it goes like 3/4 again, is that normal? or what i shoud look for? the car seems to pull ok but when it reach 5k rpm you can feel it pulling more till 5500.
Last edited by Jaumme on Tue Jul 16, 2019 10:55 am, edited 1 time in total.



Jaumme
Posts: 33
Joined: Sat Jan 19, 2019 2:50 am
Year and Model: Volvo 850 T5 1993
Location: Valencia
Has thanked: 0
Been thanked: 1 time
Spain
Jaumme

Re: Volbo 850 strange boost. pronblem

Post by Jaumme » Mon Jul 15, 2019 11:15 am

i tested all i know the tcv is ok and the bypass valve is ok, the wastegate actuator is also ok, all teh vacuum tubes are perfect, there are no leaks in the intake, fuel pressure regulator and pump hold the correct pressure( its new) and everything seems to be ok so i dont know what to look for. The car has 75k kilometers,



User avatar
matthew1
Site Admin
Posts: 9843
Joined: Sat Sep 14, 2002 11:03 am
Year and Model: 850 T5, 1997
Location: Denver, Colorado, US
Has thanked: 373 times
Been thanked: 140 times
United States of America
matthew1

Re: Volbo 850 strange boost. pronblem

Post by matthew1 » Mon Jul 15, 2019 11:28 am

It could be a collapsing hose. What's the condition of these? Also, on my 850 T5, the large hose on the intake manifold would slip off its mounting point to the manifold.


Help keep MVS on the web -> click sponsors' links here on MVS when you buy from them.
Also -> Amazon link
. Click that when you go to buy something on Amazon and MVS gets a kickback.

1997 850 T5, MSD ignition coil, Hallman manual boost controller, injectors, R bumper, OMP strut brace [gone]
2004 V70 R [gone]

Jaumme
Posts: 33
Joined: Sat Jan 19, 2019 2:50 am
Year and Model: Volvo 850 T5 1993
Location: Valencia
Has thanked: 0
Been thanked: 1 time
Spain
Jaumme

Re: Volbo 850 strange boost. pronblem

Post by Jaumme » Mon Jul 15, 2019 11:47 am

all the hoses are tight and strong thats not the problem, ithink its more about electronics



User avatar
Clemens
Posts: 961
Joined: Thu Sep 03, 2015 12:34 pm
Year and Model: 96 855 R + 94 855 T5
Location: Austria
Has thanked: 63 times
Been thanked: 34 times
Austria
Clemens

Re: Volbo 850 strange boost. pronblem

Post by Clemens » Mon Jul 15, 2019 2:15 pm

i have a similar condition on my 94 T5 M. I got used to it since I couldn't find the source...


Summer: 1996 855 R
Winter: 1994 855 T5M
Donor: 1995 854 10V

Jaumme
Posts: 33
Joined: Sat Jan 19, 2019 2:50 am
Year and Model: Volvo 850 T5 1993
Location: Valencia
Has thanked: 0
Been thanked: 1 time
Spain
Jaumme

Re: Volvo 850 strange boost problem

Post by Jaumme » Tue Jul 16, 2019 11:03 am

LOL i noticed now the volbo and pronlem in the tittle lmao i was too assleep yesterday.
Ok getting in the topic again i recorded a video for you to see the problem.
maybe the tps has something to do here?



Jaumme
Posts: 33
Joined: Sat Jan 19, 2019 2:50 am
Year and Model: Volvo 850 T5 1993
Location: Valencia
Has thanked: 0
Been thanked: 1 time
Spain
Jaumme

Re: Volvo 850 strange boost problem

Post by Jaumme » Tue Jul 16, 2019 12:56 pm

i checked the TPS with an ohmmeter and here are the results, I think something is f*cked there, but i need anyone to confirm



User avatar
erikv11
Posts: 9102
Joined: Sat Jul 25, 2009 2:03 pm
Year and Model: 850, S/V70, 06 S60R
Location: Iowa
Has thanked: 55 times
Been thanked: 189 times
United States of America
erikv11

Re: Volvo 850 strange boost problem

Post by erikv11 » Tue Jul 16, 2019 1:19 pm

That does look like a dead spot in the sensor. However I understood there are two "right" ways to test the TPS:

(1) ignition on, back probe the connector, test voltage
(2) remove TPS, connect to the TPS leads, test resistance

Looks like you are doing ignition on, back probe, test resistance. What are the voltage numbers in the setup you have, does it also peak and drop (presumably), or rise steadily?

viewtopic.php?t=47868


'95 854 T5-R, Motronic 4.4, 185k
'96 855 NA, 140k
'98 S70 NA, 210k (living out west)
'98 V70, T5 tune-injectors-turbo, LPT engine, 280k
'06 S60 R, 160k
gone: '96 NA 850 210k, '98 NA V70 182k

Jaumme
Posts: 33
Joined: Sat Jan 19, 2019 2:50 am
Year and Model: Volvo 850 T5 1993
Location: Valencia
Has thanked: 0
Been thanked: 1 time
Spain
Jaumme

Re: Volvo 850 strange boost problem

Post by Jaumme » Tue Jul 16, 2019 1:43 pm

i unpluged the tps and conected aligator pliers to the pin 1 and 3 then tested resistance



User avatar
erikv11
Posts: 9102
Joined: Sat Jul 25, 2009 2:03 pm
Year and Model: 850, S/V70, 06 S60R
Location: Iowa
Has thanked: 55 times
Been thanked: 189 times
United States of America
erikv11

Re: Volvo 850 strange boost problem

Post by erikv11 » Tue Jul 16, 2019 4:26 pm

According to the link I posted, you need to use the center pin and one of the outside pins, not pins 1 and 3.


'95 854 T5-R, Motronic 4.4, 185k
'96 855 NA, 140k
'98 S70 NA, 210k (living out west)
'98 V70, T5 tune-injectors-turbo, LPT engine, 280k
'06 S60 R, 160k
gone: '96 NA 850 210k, '98 NA V70 182k

Post Reply