IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Looking at 2006 S40 2.4I with manual trans181K miles

Help, Advice, Owners' Discussion and DIY Tutorials devoted to the second generation C70, S40 and V50 Volvos -- awkwardly model year 2004 ½ onwards -- plus where to go for advice and discussion on Volvo's sporty C30 Coupe powered by Volvo's ubiquitous inline 5-cylinder power plant.
jdm1
Posts: 32
Joined: Wed Feb 24, 2010 10:28 am
Year and Model: 1988 245 1992 960
Location: Richmond, Virginia
Has thanked: 1 time
Been thanked: 0
United States of America
jdm1

Looking at 2006 S40 2.4I with manual trans181K miles

Post by jdm1 » Wed Jul 17, 2019 5:13 am

I am very familiar with the 200 and 900 series, the S40 not so much at all. School me folks, what should I look for? Are there any known reliability issues? And finally are the S40 series DIY friendly? I have done timing belts and head gaskets on both the red block and white block engines, also suspension, brakes and front-end work so have Volvo experince. Thanks in advance.

John


John
2000 XC70
1992 965
1988 240

Polestar
Posts: 9
Joined: Thu Mar 14, 2019 11:47 pm
Year and Model: 2006 XC70, 2005 S40
Location: Knoxville, Tn
Has thanked: 0
Been thanked: 0
United States of America
Polestar

Re: Looking at 2006 S40 2.4I with manual trans181K miles

Post by Polestar » Tue Jul 23, 2019 7:51 pm

I'll throw out what I know. I have an 05 S40i manual trans. 130k on it, purchased with 120k 2 years ago and immediately did timing belt/water pump. Not too bad of a job, bought a plastic cam holder off of Amazon. Did buy the Volvo parts at the dealer, If I did it again would probably go RockAuto. I've been happy with it. Online, I see a lot of blown head gaskets. I did an oil analysis initially and do have coolant in the oil, which does not show up visually, and slight coolant usage (no external leaks). Other items I've had: brakes, rear hubs, coil pack. Last week had the information screen (radio and heat+air) failed and I replaced with a junkyard part. I had the Bluepower radio but put the original back in. Also about to do the alarm unit. I have Vida-Dice which helps greatly on these newer ones. No issues with working on it. Good luck.



Polestar
Posts: 9
Joined: Thu Mar 14, 2019 11:47 pm
Year and Model: 2006 XC70, 2005 S40
Location: Knoxville, Tn
Has thanked: 0
Been thanked: 0
United States of America
Polestar

Re: Looking at 2006 S40 2.4I with manual trans181K miles

Post by Polestar » Thu Aug 01, 2019 9:31 pm

I should have said that in my opinion you really need a Vida-Dice computer setup to work on these.



Post Reply