IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

2002 S80 NA will not run longer than 10 seconds

Help, Advice, Owners' Discussion and DIY Tutorials on the Volvo S80 model. Sometimes called an "executive car", the S80 was and continues to be Volvo's top-of-the-line passenger car.
Drdave007
Posts: 3
Joined: Wed Jul 17, 2019 10:35 am
Year and Model: 2002 s80 2.9l non tu
Location: TEXAS
Has thanked: 0
Been thanked: 0
United States of America
Drdave007

2002 S80 NA will not run longer than 10 seconds

Post by Drdave007 » Wed Jul 17, 2019 10:49 am

got this 2002 s80 very cheap because no one could make it run, I think i am a competent technician, has fuel pressure 55-60psi,
injector pulse good,swapped injectors,ignition firing on all six coils, timing belt in time and hasn't been messed with. will run for ten seconds then sounds like it leans out, spraying carb cleaner makes it worse but plugs not fouling. if you grind on starter it will almost crank sometimes but sounds like its a tooth out in timing or real slow. compression 100 pounds . any ideas???? all help am very thankful for.
Last edited by matthew1 on Wed Jul 17, 2019 10:19 pm, edited 1 time in total.
Reason: improved title



User avatar
MoVolvos
Posts: 2042
Joined: Sun Jan 15, 2012 6:47 pm
Year and Model: 03S80T6~08C30T5
Location: NC
Has thanked: 23 times
Been thanked: 41 times
United States of America
MoVolvos

Re: will not run!!! help

Post by MoVolvos » Wed Jul 17, 2019 10:10 pm

Drdave007 wrote:
Wed Jul 17, 2019 10:49 am
compression 100 pounds. any ideas???? all help am very thankful for.
Well Doc?


Blessings,

BKM

1998 S70 T5 - Donated
2003 S80 T6
2003 GS300
2003 Odyssey
2008 C30 T5
2019 Atlas SE 4 Motion

Drdave007
Posts: 3
Joined: Wed Jul 17, 2019 10:35 am
Year and Model: 2002 s80 2.9l non tu
Location: TEXAS
Has thanked: 0
Been thanked: 0
United States of America
Drdave007

Re: 2002 S80 NA will not run longer than 10 seconds

Post by Drdave007 » Thu Jul 18, 2019 10:09 am

lower timing pulley getting checked next. would explain compression off



Drdave007
Posts: 3
Joined: Wed Jul 17, 2019 10:35 am
Year and Model: 2002 s80 2.9l non tu
Location: TEXAS
Has thanked: 0
Been thanked: 0
United States of America
Drdave007

Re: 2002 S80 NA will not run longer than 10 seconds

Post by Drdave007 » Fri Aug 30, 2019 9:35 pm

nope still doesnt run



User avatar
ndphotonl
Posts: 149
Joined: Sun May 27, 2018 7:09 am
Year and Model: S80 2.4T Wasa
Location: Netherlands
Has thanked: 17 times
Been thanked: 22 times
Contact:
Netherlands
ndphotonl

Re: 2002 S80 NA will not run longer than 10 seconds

Post by ndphotonl » Sun Oct 27, 2019 2:57 pm

Try a new crankshaft sensor would be my first idea.

MAF ok?
Precat O2 sensor ok?

Did you do a scan with DICE?


Volvo S80 2.4T Wasa Limited Edition
Blog / FlickR / YouTube channel

User avatar
SuperHerman
Posts: 1229
Joined: Mon Dec 01, 2014 1:28 pm
Year and Model: 2004 & 2016 XC90
Location: Minnesota
Has thanked: 0
Been thanked: 115 times
United States of America
SuperHerman

Re: 2002 S80 NA will not run longer than 10 seconds

Post by SuperHerman » Mon Oct 28, 2019 10:30 pm

On my old 2004 S80 2.9 NA that I gave my sister, after much digging and searching her problem was a clogged CAT.

Try taking out an O2 sensor and having a look - maybe a couple of well placed rubber mallet hits to listen for honey comb issues.



precopster
Posts: 7461
Joined: Sat Aug 21, 2010 12:20 am
Year and Model: Lots
Location: Melbourne Australia
Has thanked: 4 times
Been thanked: 102 times
Australia
precopster

Re: 2002 S80 NA will not run longer than 10 seconds

Post by precopster » Tue Oct 29, 2019 6:18 am

Which engine is fitted? Turbo or non? 100psi for a non turbo is almost a dead slug.


Current cars:2002 XC70, 2006 Ssangyong Rodius (Stavic), 2006 XC90 2.5T, VW Transporter 2.5TDI

www.precisioncarmodules.com.

User avatar
abscate
MVS Moderator
Posts: 18952
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 222 times
Been thanked: 739 times
Trinidad & Tobago
abscate

Re: 2002 S80 NA will not run longer than 10 seconds

Post by abscate » Thu Nov 07, 2019 3:21 pm

precopster wrote:
Tue Oct 29, 2019 6:18 am
Which engine is fitted? Turbo or non? 100psi for a non turbo is almost a dead slug.
Spec 150-180psi

Its dead, Jim.


Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

User avatar
matthew1
Site Admin
Posts: 9994
Joined: Sat Sep 14, 2002 11:03 am
Year and Model: 850 T5, 1997
Location: Denver, Colorado, US
Has thanked: 419 times
Been thanked: 158 times
United States of America
matthew1

Re: 2002 S80 NA will not run longer than 10 seconds

Post by matthew1 » Thu Nov 07, 2019 4:10 pm

"I'm a doctor not a Volvo tech!"


Help keep MVS on the web -> click sponsors' links here on MVS when you buy from them.
Also -> Amazon link
. Click that when you go to buy something on Amazon and MVS gets a kickback.

1997 850 T5, MSD ignition coil, Hallman manual boost controller, injectors, R bumper, OMP strut brace [gone]
2004 V70 R [gone]

User avatar
SuperHerman
Posts: 1229
Joined: Mon Dec 01, 2014 1:28 pm
Year and Model: 2004 & 2016 XC90
Location: Minnesota
Has thanked: 0
Been thanked: 115 times
United States of America
SuperHerman

Re: 2002 S80 NA will not run longer than 10 seconds

Post by SuperHerman » Thu Nov 07, 2019 8:35 pm

I am not so quick to call the engine dead because of the compression test. You have to eliminate a few items. First put a half of a cap of oil in each cylinder spark plug hole with all the plugs out - cover the holes with a rag thrown on top. Spin the engine a few times then let it sit a few minutes and redo your compression test. Your numbers may be low because the engine has not run in a long time. Worth the time to see if you can get the numbers up before calling it dead.

Miles on the motor and condition of the oil? Did you change the oil? It could be full of gas causing your problem with compression. Drain oil and look for metal sparkle, a sign of mechanical issues.

Unfortunately you have no history on the car as it would have shown signs of compression lost. Do what follows before you try adding oil as it will cause a false positive. You first have to look for signs of burning oil.

Visually inspect the exhaust tip for soot (sign of oil burning) and the spark plugs. Then shine a light down and inspect the piston tops, but do this after you have the plugs out for about an hour so any unburned gas can evaporate.

Report back, but I would also look at your exhaust pressure as I mentioned before.

I am not a doctor nor a Volvo mechanic, but McCoy was.



Post Reply