Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

2004 S60 Lights won’t work

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

Hilltopper60
Posts: 2
Joined: Wed Jul 24, 2019 7:18 pm
Year and Model: 2004 S60
Location: Kentucky
Has thanked: 0
Been thanked: 0
United States of America
Hilltopper60

2004 S60 Lights won’t work

Post by Hilltopper60 » Wed Jul 24, 2019 8:15 pm

I have a 2004 s60. Recently the low beam and high beam lights went out, the dashboard says “ low beam failure” I’ve checked all the fuses and relays and all seem to be fine, the only lights that are working are the fog lights. Also getting a high pitched noise and a clicking sound that comes on for a few seconds when I turn the key half way, it sounds like it’s coming from under the intake manifold somewhere. Not sure if that is related to the issue or normal. Any help is appreciated.



cn90
Posts: 6436
Joined: Wed Mar 31, 2010 9:54 am
Year and Model: 2004 V70 2.5T
Location: Omaha NE
Has thanked: 0
Been thanked: 78 times
United States of America
cn90

Re: 2004 S60 Lights won’t work

Post by cn90 » Wed Jul 24, 2019 8:20 pm

Could be the chips (mosfet) inside the control module.


2004 V70 2.5T 100K+
2005 XC90 2.5T 110K+

User avatar
SuperHerman
Posts: 1158
Joined: Mon Dec 01, 2014 1:28 pm
Year and Model: 2004 & 2016 XC90
Location: Minnesota
Has thanked: 0
Been thanked: 103 times
United States of America
SuperHerman

Re: 2004 S60 Lights won’t work

Post by SuperHerman » Wed Jul 24, 2019 10:51 pm

Check to see if the headlights have a relay. There should be a fuse box in the engine compartment up near the fire wall. On the underside of the removable cover should be a legend. Just quick guess based on the location and the sounds.



Hilltopper60
Posts: 2
Joined: Wed Jul 24, 2019 7:18 pm
Year and Model: 2004 S60
Location: Kentucky
Has thanked: 0
Been thanked: 0
United States of America
Hilltopper60

Re: 2004 S60 Lights won’t work

Post by Hilltopper60 » Thu Jul 25, 2019 11:27 am

I’ve checked the fuses and relay for the lights, all are fine. Replaced the fuses with new ones just to be sure and switched the relay out with one that I know works and still no change



DrDan
Posts: 66
Joined: Wed Jul 19, 2017 12:29 pm
Year and Model: 02 V70
Location: Frankfurt
Has thanked: 0
Been thanked: 6 times
Germany
DrDan

Re: 2004 S60 Lights won’t work

Post by DrDan » Thu Jul 25, 2019 11:42 am

There's a shunt for the low beams in the CEM, CSH4. Have you checked that one too?

Edit: Not sure if this applies to the 04, also the high beams are independent of the shunt... At least for the 02 V70 I have.
Last edited by DrDan on Thu Jul 25, 2019 11:58 am, edited 1 time in total.



DrDan
Posts: 66
Joined: Wed Jul 19, 2017 12:29 pm
Year and Model: 02 V70
Location: Frankfurt
Has thanked: 0
Been thanked: 6 times
Germany
DrDan

Re: 2004 S60 Lights won’t work

Post by DrDan » Thu Jul 25, 2019 11:47 am

Oh, the sound you describe seems to be what you'd expect to hear from the Magnetti Marelli ETM which indeed is under the manifold for the turbo cars.

Could be that your 04 already has the newer throttle body, though.



Post Reply