IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

ECM Issue?

Help, Advice, Owners' Discussion and DIY Tutorials on the Volvo S80 model. Sometimes called an "executive car", the S80 was and continues to be Volvo's top-of-the-line passenger car.
RuinedS80
Posts: 1
Joined: Sat Jul 27, 2019 1:45 pm
Year and Model: 2001 S80 T6
Location: Montana
Has thanked: 0
Been thanked: 0
United States of America
RuinedS80

ECM Issue?

Post by RuinedS80 » Sat Jul 27, 2019 2:09 pm

Hi all,
I have a 2001 S80 T6 with the P0238 trouble code. The car stopped running while driving on the highway and would present a crank and no-start issue. When inspecting the car, I noticed that one of the o2 sensor wires had been dragging on the ground and was subsequently sheared and broken. Could this have caused a short and fried the ECM? The code points to a potential MAP sensor issue but I doubt that a faulty MAP would cause the car to shut off and not start again. Any help is appreciated. Thank you.



projectsmorol
Posts: 14
Joined: Sun Jul 28, 2019 7:42 am
Year and Model: 2008 c30
Location: indiana
Has thanked: 0
Been thanked: 1 time
United States of America
projectsmorol

Re: ECM Issue?

Post by projectsmorol » Mon Jul 29, 2019 8:10 am

Replace the MAP sensor.


2008 C30:
Darton wet sleeves|CP Carrillo pistons&rods|Upgraded injectors|K16 turbo|3"downpipe|ELEVATE:cat back|custom intake|turbo intercooler hard pipe|lower motor mount|turbo blanket|intake plenum|downpipe wrap|dual bypass valve|lowering springs|rear camber arms|do88 FMIC|Porche 70mm TB|BMC air filter|MAF upgrade|Turbosmart waste gate|meth injection|IPD brake lines|NGK iridium 1 step colder|APR head studs|AEM AFR/Boost Gauge|Hilton Tuning

User avatar
MoVolvos
Posts: 2032
Joined: Sun Jan 15, 2012 6:47 pm
Year and Model: 03S80T6~08C30T5
Location: NC
Has thanked: 23 times
Been thanked: 41 times
United States of America
MoVolvos

Re: ECM Issue?

Post by MoVolvos » Tue Jul 30, 2019 10:11 am

RuinedS80 wrote:
Sat Jul 27, 2019 2:09 pm
I noticed that one of the o2 sensor wires had been dragging on the ground and was subsequently sheared and broken. Could this have caused a short and fried the ECM?
Fix and Plug back in before going down the rabbit hole. When I was at Acura the same thing happened on a new car I PDI'ed. Plumes of smoke and dies. Found the wire hanging under the car. Plugged back in and had no issues. Don't remember clearing codes. Back in the day we entry level guys counted red flashes to retrieve the codes.


Blessings,

BKM

1998 S70 T5 - Donated
2003 S80 T6
2003 GS300
2003 Odyssey
2008 C30 T5
2019 Atlas SE 4 Motion

User avatar
abscate
MVS Moderator
Posts: 18904
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 222 times
Been thanked: 735 times
Trinidad & Tobago
abscate

Re: ECM Issue?

Post by abscate » Wed Jul 31, 2019 4:05 am

RuinedS80 wrote:
Sat Jul 27, 2019 2:09 pm
Hi all,
I have a 2001 S80 T6 with the P0238 trouble code. The car stopped running while driving on the highway and would present a crank and no-start issue. When inspecting the car, I noticed that one of the o2 sensor wires had been dragging on the ground and was subsequently sheared and broken. Could this have caused a short and fried the ECM? The code points to a potential MAP sensor issue but I doubt that a faulty MAP would cause the car to shut off and not start again. Any help is appreciated. Thank you.
You could have blown a fuse from the heater circuit from a short so trace and fix that fault, though. It’s never the ECM


Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread

Post Reply