Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

09 S60 T5 - Running issues - MAF?

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

BackRoadSeeker
Posts: 41
Joined: Mon Aug 22, 2016 6:57 am
Year and Model: 1998 S70 T5
Location: Richmond, VA
Has thanked: 0
Been thanked: 0
United States of America
BackRoadSeeker

09 S60 T5 - Running issues - MAF?

Post by BackRoadSeeker » Thu Aug 08, 2019 5:52 am

Hi folks,

Well, I bought that 2009 S60 T5 that I asked for opinions on earlier... and it's testing me by giving some running issues. No codes - that would be too easy.

Here are the symptoms (and my thoughts on each):
1. Idle is rough feeling - vibrations in cabin in drive/park/neutral. I've replaced the upper torque mount, lower trans torque mount, and passenger engine mount with Lemforder/Hutchinson OEM parts.
2. Throttle 'dead spot' when setting off or general lack of sensitivity. It's extremely laggy, and when it finally does respond, the car often jumps forward suddenly.
3. Odd transmission behavior - around 40 mph or below, when I'm off the gas and coasting, the rpms drop to neutral. I don't think my 2009 auto should be doing this?

I think it's the MAF. I've done some data logging using an iCarsoft Volvo reader, and have these values:
- Idle speed in neutral, AC off, at temp : 650 - 677 rpm
- Fuel trim, bank 1, short : 0.99
- Fuel trim, bank 1, long, lower : 0.99
- MAF reading, neutral, idle, at temp : 10.5 - 10.8 kg/h
- MAF correction factor : 0.99

I know the later model P2s have the Bosch throttle units that tend to be better, which is why I'm starting with the MAF. Looking for any other guidance folks can offer. Thanks!


- James
________________________________________________
1998 S70 T5, Auto - Sold
2001 Toyota 4Runner, 298k miles and counting!