IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

'06 XC Fatal Fault?

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

User avatar
BlackBart
Posts: 441
Joined: Sat Dec 10, 2016 5:03 pm
Year and Model: 2004 XC70 BlackBetty
Location: North American Continent
Has thanked: 30 times
Been thanked: 18 times
Sweden
BlackBart

Re: '06 XC Fatal Fault?

Post by BlackBart » Wed Sep 11, 2019 11:40 am

Well that makes sense for an electrical layman.

I saw a paragraph that made my smile when Matt said, "It's not just finding the needle in the haystack, but finding which haystack."

Remember when a lever (a leever) on the side of the block made the fuel pump go up and down when the crankshaft turned?


ex-1984 245T wagon
1994 850T wagon
2004 XC70 wagon
Want: '67 122 wagon

User avatar
BlackBart
Posts: 441
Joined: Sat Dec 10, 2016 5:03 pm
Year and Model: 2004 XC70 BlackBetty
Location: North American Continent
Has thanked: 30 times
Been thanked: 18 times
Sweden
BlackBart

Re: '06 XC Fatal Fault?

Post by BlackBart » Wed Sep 11, 2019 11:56 am

Here's a link to the XeMODex CEM reprogramming. $600. They transfer the data from yours to a remanufactured and updated one.

https://xemodex.com/us/product/central- ... 455-10-22/

From their site:

COMMON COMMUNICATION FAILURES:
Water damage.
Complete loss of communication, where the CEM will not communicate with the rest of the network and the diagnostic tool.
No LIN communication with alternator (ACM).
Starter motor not working, even though start is approved by the immobilizer sequence.
Turn signals not working at all or one side turned on continuously.
Low beams, high beams or fog lights failures.
Horn not working at all.
Wipers not working at all or stuck in high speed.
Fuel pump relay not engaging.

CEM & ECU.jpeg
You do not have the required permissions to view the files attached to this post.


ex-1984 245T wagon
1994 850T wagon
2004 XC70 wagon
Want: '67 122 wagon

User avatar
BlackBart
Posts: 441
Joined: Sat Dec 10, 2016 5:03 pm
Year and Model: 2004 XC70 BlackBetty
Location: North American Continent
Has thanked: 30 times
Been thanked: 18 times
Sweden
BlackBart

Re: '06 XC Fatal Fault?

Post by BlackBart » Sun Sep 15, 2019 9:29 pm

He says it cranks but won't start, which contradicts some of those symptoms above.


ex-1984 245T wagon
1994 850T wagon
2004 XC70 wagon
Want: '67 122 wagon

User avatar
- Pete -
Posts: 162
Joined: Fri Dec 06, 2013 10:13 pm
Year and Model: 01, 04, 04, 06 V70's
Location: Minnesota/Wisconsin
Has thanked: 15 times
Been thanked: 26 times
United States of America
- Pete -

Re: '06 XC Fatal Fault?

Post by - Pete - » Sun Sep 15, 2019 10:33 pm

Tell him to check the purple wire for a small section of it being "green" with corrosion. It will be within 4-5" of the plug I pictured earlier.

With ours, it would often crank but NOT start. Occasionally while running would shut off. But the crank-no-start was the most prevalent symptom. Check the easiest stuff first = this.


2001 V70XC 135k
2004 V70 AWD 130k
2004 XC70 278k
2006 XC70 150k

Post Reply