IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

08 S40 had an 04 front subframe with engine and trans swapped over. Engine starts but sputters and won't idle.

Help, Advice, Owners' Discussion and DIY Tutorials devoted to the second generation C70, S40 and V50 Volvos -- awkwardly model year 2004 ½ onwards -- plus where to go for advice and discussion on Volvo's sporty C30 Coupe powered by Volvo's ubiquitous inline 5-cylinder power plant.
mountaincarjunkie
Posts: 5
Joined: Thu Aug 09, 2018 4:23 pm
Year and Model: 2002 Volvo S40 1.9T
Location: North Carolina
Has thanked: 0
Been thanked: 0
United States of America
mountaincarjunkie

08 S40 had an 04 front subframe with engine and trans swapped over. Engine starts but sputters and won't idle.

Post by mountaincarjunkie » Mon Sep 23, 2019 5:11 pm

I'm asking for a friend. Her father who was a long time mechanic before he retired, decided to do the deed for her and swap the engine out of her 04 into a much nicer and better 08 shell with a blown engine.

So after the swap was done the engine would do as I said, start, but sputter and won't idle. So obviously it has some air, fuel and spark happening and it's able to crank, but not enough to run or even idle.

She said her dad replaced the spark plugs, timing belt, sway bar, fuel pump along with like antifreeze and new gas.

After all of it he needs a break from it so I figured Id post here to help my friend out.

He said it's "electrical issues" but I think that's just something easy to pin it on. If it's cranking and trying to start, I think AT LEAST the ecu is connected right and knows what's up. I think it might be something like air in fuel lines, but that'd be all I can think of.

Any help would be greatly appreciated.