IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Trouble starting XC60

Help, Advice, Owners' Discussion and DIY Tutorials for the groundbreaking new Volvo S60 2011+, V60 and XC60.
austinrs
Posts: 2
Joined: Tue Sep 24, 2019 4:39 pm
Year and Model: 2010 XC60
Location: Colorado
Has thanked: 1 time
Been thanked: 0
United States of America
austinrs

Volvo Repair Database Trouble starting XC60

Post by austinrs » Tue Sep 24, 2019 4:41 pm

Pointed over here from somewhere else on the interwebs, glad I found the place!

I'm having trouble starting our XC60 in the mornings. It's a push button start (as you know), so when you push the button, it cranks fine, but the engine doesn't fire up. Usually takes a few tries, then we get a rough starting idle, and then after 5-10 seconds it works just fine.

I've replaced a few things as just standard maintenance, including new battery, new spark plugs, and new air filter, but none helped. Now I'm trying to rule out systems to find what to fix. I believe the starter is working okay since it cranks, and I believe the coil packs are okay since after I get it started, it runs just fine. I think I may be narrowing it down to the fuel pump or the injectors...? Unless there are any sensors or anything I also need to look at.

The last item of note is that once the car starts in the morning, it usually works fine the rest of the day. If she gets home at 2:00 and doesn't go anywhere, it'll take 5-6 tries in the morning. If we take it in the evening and don't get home until 10 PM or so, it only takes like 2-3 tries the next morning, if that makes any sense.

Any thoughts? Thanks in advance!



User avatar
RickHaleParker
Posts: 2957
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 328 times
United States of America
RickHaleParker

Re: Trouble starting XC60

Post by RickHaleParker » Wed Sep 25, 2019 5:37 pm

Wait 10 seconds before you push to start.


Platform: P80 1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

austinrs
Posts: 2
Joined: Tue Sep 24, 2019 4:39 pm
Year and Model: 2010 XC60
Location: Colorado
Has thanked: 1 time
Been thanked: 0
United States of America
austinrs

Re: Trouble starting XC60

Post by austinrs » Thu Sep 26, 2019 9:57 am

Do you mean after it doesn't fire up the first time I push to start?



User avatar
RickHaleParker
Posts: 2957
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 328 times
United States of America
RickHaleParker

Re: Trouble starting XC60

Post by RickHaleParker » Wed Oct 02, 2019 11:24 am

austinrs wrote:
Thu Sep 26, 2019 9:57 am
Do you mean after it doesn't fire up the first time I push to start?
In PM austinrs wrote: I discovered if I wait 30-60 seconds after the first "non-start" before pushing the start button again, my XC60 starts right up. Do you know what exactly is going on in that scenario?
Most likely fuel pressure bleeding off. Waiting 10 seconds with the key on give the fuel pump time to build the fuel pressure back up.
These users thanked the author RickHaleParker for the post:
austinrs


Platform: P80 1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

Post Reply