IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

2006 XC90 V8 - no oil pressure warning, delayed

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo XC90s. The XC90 proved to be very popular, and very good for Volvo's sales numbers, since its introduction in model year 2003 (North America).
lerock722
Posts: 5
Joined: Wed Sep 25, 2019 7:12 pm
Year and Model: 96 xc90 v8
Location: CT
Has thanked: 0
Been thanked: 0
United States of America
lerock722

2006 XC90 V8 - no oil pressure warning, delayed

Post by lerock722 » Wed Sep 25, 2019 7:25 pm

Hi all, I have a 2005 XC90 V8 and I just picked up a 2006 XC90 V8. So I test drove it a few miles with no issues. Idle, pick up was fine. Engine light was on. I hit with reader and it had a few issues. evap leak, burnt valves, worn lobes and another. I cleared the codes and took it for another couple mile test drive and no check engine light returned. Still ran smoothly up to 60+ MPH. Seller attributed the engine light being on because vehicle sat for 6-7 months. At any rate I took the vehicle. I got 2 miles down the road and the no oil pressure message started flickering on/off. Finally just stayed on. While in N if I revved engine up to about 3-4k rpms it would turn off the message but would come back on few seconds later. So I suspected the oil pan, pick up, etc may be sludge packed. I am going to drop the pan. However I have another concern. While no ticks, knocks, or anything coming from the engine it all seems fine. Even still has plenty of power but my bigger concern is that the engine is getting really, extremely hot. The temp gauge is still reading halfway, no check engine light but it's getting way too hot. I mean you can smell burning and so hot you see smoke coming off when parked. Again, no valve noise, chatter, knocks or anything though. runs smooth and no lost power. so I'm skeptical if I spun a bearing, or bent a valve, or something. I'll drop the pan and see but just curious if anyone has thoughts on this. Thanks all



lerock722
Posts: 5
Joined: Wed Sep 25, 2019 7:12 pm
Year and Model: 96 xc90 v8
Location: CT
Has thanked: 0
Been thanked: 0
United States of America
lerock722

Re: 2006 XC90 V8 - no oil pressure warning, delayed

Post by lerock722 » Thu Sep 26, 2019 12:51 pm

Just checking, nobody has any thoughts on this?

Thanks and regards,



User avatar
oragex
Posts: 4419
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 89 times
Been thanked: 209 times
Contact:
Canada
oragex

Re: 2006 XC90 V8 - no oil pressure warning, delayed

Post by oragex » Thu Sep 26, 2019 2:24 pm

I do believe the 'engine is too hot' thing, while the gauge is still at 12. The reason for this may be difficult to diagnose, I would think of coolant possibly not getting close to the head - possible clogged passages, may try Preston flush but use 2-3 bottles for 1-2 weeks or more to really kick out any limestone, and flush only with distilled water

Other choice would be oil barely gets to the cams to lubricate them causing the top to overheat.

Maybe also wrong spark plugs not transferring heat, or some lean combustion causing chamber overheating. Same with stuck piston rings

As for the oil light, may be a clogged oil pickup mesh, really not good to rev or drive it like this



lerock722
Posts: 5
Joined: Wed Sep 25, 2019 7:12 pm
Year and Model: 96 xc90 v8
Location: CT
Has thanked: 0
Been thanked: 0
United States of America
lerock722

Re: 2006 XC90 V8 - no oil pressure warning, delayed

Post by lerock722 » Thu Sep 26, 2019 6:04 pm

Oragex - thanks for your response. I plan to drop the pan in the next couple days. I'll post my findings. Just strange that the "no oil pressure" does not come on till after some miles of driving. I would think if it was on and then vehicle sat for for 12 hours it would come on right away but it didn't.



lerock722
Posts: 5
Joined: Wed Sep 25, 2019 7:12 pm
Year and Model: 96 xc90 v8
Location: CT
Has thanked: 0
Been thanked: 0
United States of America
lerock722

Re: 2006 XC90 V8 - no oil pressure warning, delayed

Post by lerock722 » Sat Sep 28, 2019 4:05 pm

So I got the pan down and was hoping for the worst but it actually wasn't bad. I'll post some pictures. I'm going to try and get the pickup tube out and cleaned. I don't want to have to take down the walls but it's gonna be tough to get the tube bolts off. I'll see if I can get in there with a flexible extension. However the screen doesn't look all that bad so my other thought is maybe it is the pump that's failing me. As I was saying it seems to only kick on the "no oil pressure" after few miles of driving. I don't know how that could attribute to the oil pump. I would think if it's bad it would not work at all. Not work for a little and then fail. Maybe i'm wrong?



lerock722
Posts: 5
Joined: Wed Sep 25, 2019 7:12 pm
Year and Model: 96 xc90 v8
Location: CT
Has thanked: 0
Been thanked: 0
United States of America
lerock722

Re: 2006 XC90 V8 - no oil pressure warning, delayed

Post by lerock722 » Sat Sep 28, 2019 4:12 pm

Here are some pics
You do not have the required permissions to view the files attached to this post.



Post Reply
  • Similar Topics
    Replies
    Views
    Last post