IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Temp gauge fluctuating even after replacing thermostat and CTS

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

User avatar
wizechatmgr
Posts: 1239
Joined: Thu Jan 12, 2017 1:07 pm
Year and Model: 1999 V70 XC AWD 2.4T
Location: Albany, NY area
Has thanked: 20 times
Been thanked: 51 times
Contact:
United States of America
wizechatmgr

Re: Temp gauge fluctuating even after replacing thermostat and CTS

Post by wizechatmgr » Thu Oct 03, 2019 8:38 am

RB3 wrote:
Mon Sep 30, 2019 11:03 am
Gonna try this today. Stat and sensor replaced last fall. Not sure if OEM. Also had water pump and timing belt replaced 2 mos. ago so naturally coolant was involved. I haven't noticed any fluctuations since and only topped it once. But after you mentioned the air, I did just run the heat the past couple mornings/evenings.

Been having random electrical issues as well. Replaced battery 2 days ago.

Thanks for tip on Stat.
I'd suggest having that alternator checked as well as the hot wire going to the fuse block. Alternator could have toasted battery from letting AC through the system - would cause all kinds of weird stuff to happen.


Wisdom requires knowledge as a prerequisite, but knowledge can be developed due to a lack of wisdom.
In order to learn how to fix something, you must first learn how to break it.
1999 V70 XC AWD - ~177k miles

RB3
Posts: 6
Joined: Sun Sep 29, 2019 4:47 am
Year and Model: 99 V70
Location: California
Has thanked: 0
Been thanked: 0
United States of America
RB3

Re: Temp gauge fluctuating even after replacing thermostat and CTS

Post by RB3 » Tue Oct 15, 2019 4:55 pm

Still no luck with the guage.
Gonna get the codes read I guess. Should I replace stat or sensor just to rule out? Maybe after codes?

Could the temp and possible fuel thing be related? Hesitation on acceleration and bogs if I coast. Almost like I'm braking. Thanks in advance



Post Reply